Formule alternative

Le
Menibelus
Bonjour,

J'aimerai savoir s'il est possible d'avoir une formule un peu moin
longue que celle ci
=((NB.SI(D5:AH5;TyAs)+NB.SI(D5:AH5;TyBo)+NB.SI(D5:AH5;TyFo)+NB.SI
(D5:AH5;TyGa)+NB.SI(D5:AH5;TyGe)+NB.SI(D5:AH5;TyJe)+NB.SI(D5:AH5;TyJu))
*ValBo)+(NB.SI(D5:AH5;TyEn)*ValEn)
sachant que TyAs, TyBo, et ValBo, ValEn, sont des noms de
cellules sur une autre feuille

Merci
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Youky \(BJ\)
Le #18322031
Bonjour,
il te faut créer une zone nommée "mytype", il doit y avoir TyAs et les
autres
ceci à n'importe quel endroir du classeur
ensuite mets cette formule à valider en matriciel
qui est l'appui sur Ctrl+Maj+Enter
=SOMME(NB.SI(Feuil2!A4:A23;mytype))
les crochets se feront deux même {=....}
Youky (BJ)

"Menibelus"
Bonjour,

J'aimerai savoir s'il est possible d'avoir une formule un peu moin
longue que celle ci
=((NB.SI(D5:AH5;TyAs)+NB.SI(D5:AH5;TyBo)+NB.SI(D5:AH5;TyFo)+NB.SI
(D5:AH5;TyGa)+NB.SI(D5:AH5;TyGe)+NB.SI(D5:AH5;TyJe)+NB.SI(D5:AH5;TyJu))
*ValBo)+(NB.SI(D5:AH5;TyEn)*ValEn)
sachant que TyAs, TyBo, ... et ValBo, ValEn, ... sont des noms de
cellules sur une autre feuille

Merci


Jacky
Le #18322281
Bonjour;
Les cellules "tyAs......à....TyJu" nommée "groupe"
essaie ceci
=SOMMEPROD((D5:AH5=groupe)*ValBo)+(NB.SI(D5:AH5;TyEn)*ValEn)

--
Salutations
JJ


"Menibelus"
Bonjour,

J'aimerai savoir s'il est possible d'avoir une formule un peu moin
longue que celle ci
=((NB.SI(D5:AH5;TyAs)+NB.SI(D5:AH5;TyBo)+NB.SI(D5:AH5;TyFo)+NB.SI
(D5:AH5;TyGa)+NB.SI(D5:AH5;TyGe)+NB.SI(D5:AH5;TyJe)+NB.SI(D5:AH5;TyJu))
*ValBo)+(NB.SI(D5:AH5;TyEn)*ValEn)
sachant que TyAs, TyBo, ... et ValBo, ValEn, ... sont des noms de
cellules sur une autre feuille

Merci


Menibelus
Le #18326481
On 7 jan, 10:24, "Jacky"
Bonjour;
Les cellules "tyAs......à....TyJu"  nommée "groupe"
essaie ceci
=SOMMEPROD((D5:AH5=groupe)*ValBo)+(NB.SI(D5:AH5;TyEn)*ValEn)

--
Salutations
JJ

"Menibelus"

> Bonjour,

> J'aimerai savoir s'il est possible d'avoir une formule un peu moin
> longue que celle ci
> =((NB.SI(D5:AH5;TyAs)+NB.SI(D5:AH5;TyBo)+NB.SI(D5:AH5;TyFo)+NB.SI
> (D5:AH5;TyGa)+NB.SI(D5:AH5;TyGe)+NB.SI(D5:AH5;TyJe)+NB.SI(D5:AH5;TyJu))
> *ValBo)+(NB.SI(D5:AH5;TyEn)*ValEn)
> sachant que TyAs, TyBo, ... et ValBo, ValEn, ... sont des noms de
> cellules sur une autre feuille

> Merci



Merci beaucoup ça marche à merveille
Publicité
Poster une réponse
Anonyme