formule avec date en VBA

Le
Ptck
Bonjour
Hier modeste ma aidé, mais le résultat est erroné
le résultat donne çà : =SI(ET(G2="VE";F2>1/12/2009);"exclue";"")
ce qui fait 31 divisé par 12 divisé par2009

et pas çà: =SI(ET(G3="VE";F3>ÚTEVAL("31/12/2009"));"exclue";"")
je n'arrive pas à avoir le bon résultat
si vous avez une idée
merci
ptck

bout de macro:
période = Application.InputBox("Exclure les ventes à partir de (sous forme
jj/mm/aaa) :", "Saisie", , , , , , 2)
[P2].FormulaR1C1 = "=IF(AND(RC[-9]=""VE"",RC[-10]>=" & DateValue(période) &
"),""exclue"","""")"
=SI(ET(G2="VE";F2>1/12/2009);"exclue";"")
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
isabelle
Le #20465571
bonjour Ptck,

essaie avec :
CLng(DateValue(période))

isabelle



Ptck a écrit :
Bonjour
Hier modeste ma aidé, mais le résultat est erroné
le résultat donne çà : =SI(ET(G2="VE";F2>1/12/2009);"exclue";"")
ce qui fait 31 divisé par 12 divisé par2009

et pas çà: =SI(ET(G3="VE";F3>ÚTEVAL("31/12/2009"));"exclue";"")
je n'arrive pas à avoir le bon résultat
si vous avez une idée
merci
ptck

bout de macro:
période = Application.InputBox("Exclure les ventes à partir de (sous forme
jj/mm/aaa) :", "Saisie", , , , , , 2)
[P2].FormulaR1C1 = "=IF(AND(RC[-9]=""VE"",RC[-10]>=" & DateValue(période) &
"),""exclue"","""")"
=SI(ET(G2="VE";F2>1/12/2009);"exclue";"")





Ptck
Le #20465631
ok

merci Isabelle
"isabelle" a écrit dans le message de news:

bonjour Ptck,

essaie avec :
CLng(DateValue(période))

isabelle



Ptck a écrit :
Bonjour
Hier modeste ma aidé, mais le résultat est erroné
le résultat donne çà : =SI(ET(G2="VE";F2>1/12/2009);"exclue";"")
ce qui fait 31 divisé par 12 divisé par2009

et pas çà: =SI(ET(G3="VE";F3>ÚTEVAL("31/12/2009"));"exclue";"")
je n'arrive pas à avoir le bon résultat
si vous avez une idée
merci
ptck

bout de macro:
période = Application.InputBox("Exclure les ventes à partir de (sous
forme jj/mm/aaa) :", "Saisie", , , , , , 2)
[P2].FormulaR1C1 = "=IF(AND(RC[-9]=""VE"",RC[-10]>=" &
DateValue(période) & "),""exclue"","""")"
=SI(ET(G2="VE";F2>1/12/2009);"exclue";"")






Modeste
Le #20465991
Bonsour® Ptck avec ferveur ;o))) vous nous disiez :

Hier modeste ma aidé, mais le résultat est erroné
le résultat donne çà : =SI(ET(G2="VE";F2>1/12/2009);"exclue";"")
ce qui fait 31 divisé par 12 divisé par2009

et pas çà: =SI(ET(G3="VE";F3>ÚTEVAL("31/12/2009"));"exclue";"")
je n'arrive pas à avoir le bon résultat
si vous avez une idée



plus simplement alors :
[P2].FormulaR1C1 = "=IF(AND(RC[-9]=""VE"",RC[-10]>=" & période & "),""exclue"","""")"
Jacquouille
Le #20470561
Bonjour Ptck

Je suis vraiment ému d'apprendre que Modeste se soit gourré.
Personnellement, je pense que c'est la paire de guillemets qui est restée
figée derrière ton écran.
En effet, telle que, Excel divisera 31 par 12, puis par 2009.
Essaie avec "31/12/2009" ou, mieux,F2>= 40178.
Bonne chance

--
Bien amicalmement,
"Le vin est au repas ce que le parfum est à la femme."

Jacquouille.

"Ptck"
Bonjour
Hier modeste ma aidé, mais le résultat est erroné
le résultat donne çà : =SI(ET(G2="VE";F2>1/12/2009);"exclue";"")
ce qui fait 31 divisé par 12 divisé par2009

et pas çà: =SI(ET(G3="VE";F3>ÚTEVAL("31/12/2009"));"exclue";"")
je n'arrive pas à avoir le bon résultat
si vous avez une idée
merci
ptck

bout de macro:
période = Application.InputBox("Exclure les ventes à partir de (sous forme
jj/mm/aaa) :", "Saisie", , , , , , 2)
[P2].FormulaR1C1 = "=IF(AND(RC[-9]=""VE"",RC[-10]>=" & DateValue(période)
& "),""exclue"","""")"
=SI(ET(G2="VE";F2>1/12/2009);"exclue";"")



Publicité
Poster une réponse
Anonyme