formule de calcul

Le
manueplou
Bonjour,

je cherche une formule pour calculer sur une ligne le nombre de colonne non vide à parir de la 1ère colonne pleine

Merci pour votre aide
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jacky
Le #16351341
Bonjour,
A défaut de réponse d'un formuliste, une solution en Vba
'-------------
Sub jj()
Dim lig As Long, x As Long, y As Long
lig = 1 'pour la ligne 1
x = Cells(lig, 1).End(2).Column
y = Columns.Count
MsgBox Application.CountIf(Range(Cells(lig, x), Cells(lig, y)), "<>")
End Sub
'----------------

--
Salutations
JJ


"manueplou"
Bonjour,

je cherche une formule pour calculer sur une ligne le nombre de colonne
non
vide à parir de la 1ère colonne pleine

Merci pour votre aide


Modeste
Le #16351601
Bonsour® manueplou avec ferveur ;o))) vous nous disiez :

je cherche une formule pour calculer sur une ligne le nombre de
colonne non vide à parir de la 1ère colonne pleine



???
=NB.SI(INDIRECT(ADRESSE(LIGNE();COLONNE()+1;4)&":"&ADRESSE(LIGNE();256; 4));"> ")


--
--
@+
;o)))
Modeste
Le #16351701
pour tenir compte des valeurs d'erreur ou espace(s)

=NB.SI(INDIRECT(ADRESSE(LIGNE();COLONNE()+1;4)&":"&ADRESSE(LIGNE();256; 4));"<>")

on pourra egalement...
préciser la ligne choisie :
=NB.SI(INDIRECT(ADRESSE(N°ligne;COLONNE()+1;4)&":"&ADRESSE(N°ligne; 256;4));"<>")
ou encore les colonnes de debut et fin :
=NB.SI(INDIRECT(ADRESSE(N°ligne;ColDebut;4)&":"&ADRESSE(N°ligne;Col Fin;4));"<>")


--
--
@+
;o)))
Papyjac
Le #16357641
Bonjour manueplou,

Je te propose la fonction NBVAL(A1:IV1)


--
P a p y j a c

"manueplou" news:
Bonjour,

je cherche une formule pour calculer sur une ligne le nombre de colonne
non
vide à parir de la 1ère colonne pleine

Merci pour votre aide



Publicité
Poster une réponse
Anonyme