Formule et case à cocher

Le
elect31
Bonjour tout le monde
sur XL 2007 et 2003
J'ai, sur une feuille, 3 cases à cocher, disposées en entête de colonne,
en A1, B1, C1. Des valeurs numériques sont en-dessous.
je voudrais simplement faire une moyenne de notes en colonne D, en ne
prenant en compte les valeurs que si la case de la colonne est cochée.
Les cases à cocher sont des contrôles activeX.
Merci si vous avez une solution
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel.C
Le #19589191
Bonjour.
En liant (propriété "linkedcell") les chackboxes à leur cellule, on
obtient pour la ligne 3 :
=MOYENNE(SI(A1:C1=VRAI;A3:C3))
(Formule matricielle, valider avec Ctrl+Maj+Entrée)
Un exemple ici :
http://www.cijoint.fr/cjlink.php?file=cj200906/cijWCPDA3k.xls
Cordialement.
Daniel

Bonjour tout le monde
sur XL 2007 et 2003
J'ai, sur une feuille, 3 cases à cocher, disposées en entête de colonne, en
A1, B1, C1. Des valeurs numériques sont en-dessous.
je voudrais simplement faire une moyenne de notes en colonne D, en ne prenant
en compte les valeurs que si la case de la colonne est cochée.
Les cases à cocher sont des contrôles activeX.
Merci si vous avez une solution


elect31
Le #19590441
Merci ça marche du feu de Dieu
elect
Daniel.C a écrit :
Bonjour.
En liant (propriété "linkedcell") les chackboxes à leur cellule, on
obtient pour la ligne 3 :
=MOYENNE(SI(A1:C1=VRAI;A3:C3))
(Formule matricielle, valider avec Ctrl+Maj+Entrée)
Un exemple ici :
http://www.cijoint.fr/cjlink.php?file=cj200906/cijWCPDA3k.xls
Cordialement.
Daniel

Bonjour tout le monde
sur XL 2007 et 2003
J'ai, sur une feuille, 3 cases à cocher, disposées en entête de
colonne, en A1, B1, C1. Des valeurs numériques sont en-dessous.
je voudrais simplement faire une moyenne de notes en colonne D, en ne
prenant en compte les valeurs que si la case de la colonne est cochée.
Les cases à cocher sont des contrôles activeX.
Merci si vous avez une solution






Publicité
Poster une réponse
Anonyme