formule conditionnelle ?

Le
lilibob23
Bonjour,
Totalement novice en la matière, je bloque sur une formule :
J'ai - dans une feuille 1 des données pour établir un devis.
- dans une feuille 2 un tableau récapitulant mon devis.
Pour les tarifs, j'ai besoin dans une cellule de la feuille 2 de faire
apparaitre un montant qui peut être pris dans 3 cellules différentes (A1, A2,
A3) de la feuille 1 :

Si la cellule A1 est 0 (je dois prendre la celllule A2 ou la cellule A3 si
la cellule A2 est 0), sinon je prends la cellule A1.

Comment mettre ça en formule ?
J'espère être assez claire.
D'avance merci pour votre aide.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
ChristianM
Le #17620651
Bonjour,
Je n'ai pas eu le temps de tester s'il pourvait y avoir des bugs :
=SI(Feuil1!$A$1=0;SI(Feuil1!$A$2=0;Feuil1!$A$3;Feuil1!$A$2);Feuil1!$A$1)
Donc : à tester avec tes valeurs

--
ChristianM


"lilibob23" news:
Bonjour,
Totalement novice en la matière, je bloque sur une formule :
J'ai - dans une feuille 1 des données pour établir un devis.
- dans une feuille 2 un tableau récapitulant mon devis.
Pour les tarifs, j'ai besoin dans une cellule de la feuille 2 de faire
apparaitre un montant qui peut être pris dans 3 cellules différentes (A1,
A2,
A3) de la feuille 1 :

Si la cellule A1 est 0 (je dois prendre la celllule A2 ou la cellule A3 si
la cellule A2 est 0), sinon je prends la cellule A1.

Comment mettre ça en formule ?
J'espère être assez claire.
D'avance merci pour votre aide.



Corto
Le #17620641
Bonjour lilibob23,
Si j'ai bien compris :
=SI(Feuil1!A1<>0;Feuil1!A1;SI(Feuil1!A2<>0;Feuil1!A2;Feuil1!A3))
Si A1 <> 0 alors A1
Sinon si A2<> 0 alors A2
Sinon A3

Corto

lilibob23 a écrit :
Bonjour,
Totalement novice en la matière, je bloque sur une formule :
J'ai - dans une feuille 1 des données pour établir un devis.
- dans une feuille 2 un tableau récapitulant mon devis.
Pour les tarifs, j'ai besoin dans une cellule de la feuille 2 de faire
apparaitre un montant qui peut être pris dans 3 cellules diffé rentes (A1, A2,
A3) de la feuille 1 :

Si la cellule A1 est 0 (je dois prendre la celllule A2 ou la cellule A3 si
la cellule A2 est 0), sinon je prends la cellule A1.

Comment mettre ça en formule ?
J'espère être assez claire.
D'avance merci pour votre aide.




lilibob23
Le #17621271
Merci beaucoup pour votre aide !
Moins de 3 minutes pour copier et mes résultats s'affichent comme je le
souhaitais !
J'userai et abuserai de ce site dorénavant !



"Corto" a écrit :

Bonjour lilibob23,
Si j'ai bien compris :
=SI(Feuil1!A1<>0;Feuil1!A1;SI(Feuil1!A2<>0;Feuil1!A2;Feuil1!A3))
Si A1 <> 0 alors A1
Sinon si A2<> 0 alors A2
Sinon A3

Corto

lilibob23 a écrit :
> Bonjour,
> Totalement novice en la matière, je bloque sur une formule :
> J'ai - dans une feuille 1 des données pour établir un devis.
> - dans une feuille 2 un tableau récapitulant mon devis.
> Pour les tarifs, j'ai besoin dans une cellule de la feuille 2 de faire
> apparaitre un montant qui peut être pris dans 3 cellules différentes (A1, A2,
> A3) de la feuille 1 :
>
> Si la cellule A1 est 0 (je dois prendre la celllule A2 ou la cellule A3 si
> la cellule A2 est 0), sinon je prends la cellule A1.
>
> Comment mettre ça en formule ?
> J'espère être assez claire.
> D'avance merci pour votre aide.
>
>



lilibob23
Le #17621261
Merci aussi à vous !
J'ai pris le temps par curiosité de tester les deux formules proposées, il
se trouve que les deux fonctionnent. Je n'aurai jamais imaginé...
Bien ! Donc j'ai encore plein d'autres questions qui vont me faire paraître
moins bête dorénavant !
Re-merci à mes aides, je doute pouvoir vous rendre la pareille......

"ChristianM" a écrit :

Bonjour,
Je n'ai pas eu le temps de tester s'il pourvait y avoir des bugs :
=SI(Feuil1!$A$1=0;SI(Feuil1!$A$2=0;Feuil1!$A$3;Feuil1!$A$2);Feuil1!$A$1)
Donc : à tester avec tes valeurs

--
ChristianM


"lilibob23" news:
> Bonjour,
> Totalement novice en la matière, je bloque sur une formule :
> J'ai - dans une feuille 1 des données pour établir un devis.
> - dans une feuille 2 un tableau récapitulant mon devis.
> Pour les tarifs, j'ai besoin dans une cellule de la feuille 2 de faire
> apparaitre un montant qui peut être pris dans 3 cellules différentes (A1,
> A2,
> A3) de la feuille 1 :
>
> Si la cellule A1 est 0 (je dois prendre la celllule A2 ou la cellule A3 si
> la cellule A2 est 0), sinon je prends la cellule A1.
>
> Comment mettre ça en formule ?
> J'espère être assez claire.
> D'avance merci pour votre aide.
>





Publicité
Poster une réponse
Anonyme