Formule Enlever "," si premier caractere de la cellule

Le
Christophe
Bonjour:

Dans une feuille je concatenate les cellules de 2 colonnes contenant
ou pas une ou plusieurs adresses email.
Lorsque la cellule de la 1ere colonne est vide alors mon résultat
commence par une virgule. Est-il possible de supprimer la virgule
dans une fonction lorsque la chaine de caracteres commence par une
virgule?

Supposons qu'en C1 j'ai = CONCATENATE(A1,",",B1)
alors si A1 est vide j'obtiens par exemple ,info@ibm.com au lieu de
info@ibm.com

J'ai essayé en C1 la formule =IF(ISBLANK((A1),B1,CONCATENATE(A1,B1)))
mais cela ne fonctionne pas.

Merci.

Christophe
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
michdenis
Le #22443521
En supposant que les cellules B1 et A1 sont les 2 cellules que tu veux concaténer

=SI(ET(B1="";A1="");"";SI(B1="";A1;SI(A1="";B1;SI(ET(B1<>"";A1<>"");B1&","&A1;""))))

--
MichD
--------------------------------------------


"Christophe"
Bonjour:

Dans une feuille je concatenate les cellules de 2 colonnes contenant
ou pas une ou plusieurs adresses email.
Lorsque la cellule de la 1ere colonne est vide alors mon résultat
commence par une virgule. Est-il possible de supprimer la virgule
dans une fonction lorsque la chaine de caracteres commence par une
virgule?

Supposons qu'en C1 j'ai = CONCATENATE(A1,",",B1)
alors si A1 est vide j'obtiens par exemple , au lieu de


J'ai essayé en C1 la formule =IF(ISBLANK((A1),B1,CONCATENATE(A1,B1)))
mais cela ne fonctionne pas.

Merci.

Christophe
Maude Este
Le #22443661
Bonsour®

"michdenis" a écrit
En supposant que les cellules B1 et A1 sont les 2 cellules que tu veux
concaténer
=SI(ET(B1="";A1="");"";SI(B1="";A1;SI(A1="";B1;SI(ET(B1<>"";A1<>"");B1&","&A1;""))))



;o))
¡&SI(OU(A1="";B1="");"";", ") &B1

--
5-8 aout ANICHE
Championnat d'Europe R/C 1/10
organisation ADALA
http://www.adalarc.com/european-championship-2010
http://maps.google.fr/?ie=UTF8&llP.327652,3.257275&spn=0.001373,0.005096&t=h&z
Christophe
Le #22448971
Bonjour:

Merci Maude. C Parfait.

Christophe
¡&SI(OU(A1="";B1="");"";", ")  &B1
Christophe
Le #22448961
Michel.

Merci.

Christophe
Publicité
Poster une réponse
Anonyme