formule matricielle - help me

Le
Merguez07
bonjour à tous,
voilà comme d'hab j'ai un pb simple, mais j'ai du mal avec les matrices et
mes tentatives se soldent par une message d'erreur d'excel

j'ai une ligne avec 1 ou 0 dans chaque cellule
idem dans la 2 ligne
dans la 3eme ligne j'ai des dates


ex :
1 1 0 1 1
1 0 1 1 0
01/10/08 01/04/08 06/04/08 01/01/08 17/08/08

je veux trouver la plus petite des dates pour lesquels j'ai 1 en première
ligne et 1 en deuxième ligne
ici il y a 2 dates concernées c'est 01/10/08 et 01/01/08 et la plus petite
est 01/01/08

bien sur je souhaiterais faire cela avec une seule formule

merci pour vos éclairages
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JB
Le #17708491
Bonsoir,

=MIN(SI((Ligne1=1)*(Ligne2=1);Dates))
Valider avec Maj+ctrl+entrée

JB
http://boisgontierjacques.free.fr

On 31 oct, 18:33, "Merguez07"
bonjour à tous,
voilà comme d'hab j'ai un pb simple, mais j'ai du mal avec les matrices et
mes tentatives se soldent par une message d'erreur d'excel

j'ai une ligne   avec 1 ou 0 dans chaque cellule
idem dans la 2 ligne
dans la 3eme ligne j'ai des dates

ex :
1                1                   0                 1                 1
1                 0                   1                1                 0
01/10/08    01/04/08    06/04/08    01/01/08    17/08/08

je veux trouver la plus petite des dates pour lesquels j'ai 1 en premiè re
ligne et 1 en deuxième ligne
ici il y a 2 dates concernées c'est 01/10/08 et 01/01/08 et la plus pet ite
est 01/01/08

bien sur je souhaiterais faire cela avec une seule formule

merci pour vos éclairages


isabelle
Le #17708481
bonjour Merguez07,

=SOMMEPROD((A1:E1=1)*(A2:E2=1)*MIN(A3:E3))/SOMMEPROD((A1:E1=1)*(A2:E2=1))

isabelle

Merguez07 a écrit :
bonjour à tous,
voilà comme d'hab j'ai un pb simple, mais j'ai du mal avec les matrices
et mes tentatives se soldent par une message d'erreur d'excel

j'ai une ligne avec 1 ou 0 dans chaque cellule
idem dans la 2 ligne
dans la 3eme ligne j'ai des dates


ex :
1 1 0 1 1
1 0 1 1 0
01/10/08 01/04/08 06/04/08 01/01/08 17/08/08

je veux trouver la plus petite des dates pour lesquels j'ai 1 en
première ligne et 1 en deuxième ligne
ici il y a 2 dates concernées c'est 01/10/08 et 01/01/08 et la plus
petite est 01/01/08

bien sur je souhaiterais faire cela avec une seule formule

merci pour vos éclairages




Merguez07
Le #17708991
brillant

merci JB

"JB" discussion :

Bonsoir,

=MIN(SI((Ligne1=1)*(Ligne2=1);Dates))
Valider avec Maj+ctrl+entrée

JB
http://boisgontierjacques.free.fr

On 31 oct, 18:33, "Merguez07"
bonjour à tous,
voilà comme d'hab j'ai un pb simple, mais j'ai du mal avec les matrices
et
mes tentatives se soldent par une message d'erreur d'excel

j'ai une ligne avec 1 ou 0 dans chaque cellule
idem dans la 2 ligne
dans la 3eme ligne j'ai des dates

ex :
1 1 0 1 1
1 0 1 1 0
01/10/08 01/04/08 06/04/08 01/01/08 17/08/08

je veux trouver la plus petite des dates pour lesquels j'ai 1 en première
ligne et 1 en deuxième ligne
ici il y a 2 dates concernées c'est 01/10/08 et 01/01/08 et la plus
petite
est 01/01/08

bien sur je souhaiterais faire cela avec une seule formule

merci pour vos éclairages





Merguez07
Le #17708971
Très Astucieux
merci isabelle

"isabelle" a écrit dans le message de groupe de discussion :

bonjour Merguez07,

=SOMMEPROD((A1:E1=1)*(A2:E2=1)*MIN(A3:E3))/SOMMEPROD((A1:E1=1)*(A2:E2=1))

isabelle

Merguez07 a écrit :
bonjour à tous,
voilà comme d'hab j'ai un pb simple, mais j'ai du mal avec les matrices
et mes tentatives se soldent par une message d'erreur d'excel

j'ai une ligne avec 1 ou 0 dans chaque cellule
idem dans la 2 ligne
dans la 3eme ligne j'ai des dates


ex :
1 1 0 1
1
1 0 1 1
0
01/10/08 01/04/08 06/04/08 01/01/08 17/08/08

je veux trouver la plus petite des dates pour lesquels j'ai 1 en première
ligne et 1 en deuxième ligne
ici il y a 2 dates concernées c'est 01/10/08 et 01/01/08 et la plus
petite est 01/01/08

bien sur je souhaiterais faire cela avec une seule formule

merci pour vos éclairages






Sam
Le #17708961
Bonjour,
=MIN(SI((A1:E1)*(A2:E2);A3:E3))
en validant par Ctrl,Maj,Entrée
Cordialement
Michel dit "Sam"

"Merguez07" 490b417c$0$8217$
bonjour à tous,
voilà comme d'hab j'ai un pb simple, mais j'ai du mal avec les matrices et
mes tentatives se soldent par une message d'erreur d'excel

j'ai une ligne avec 1 ou 0 dans chaque cellule
idem dans la 2 ligne
dans la 3eme ligne j'ai des dates


ex :
1 1 0 1 1
1 0 1 1 0
01/10/08 01/04/08 06/04/08 01/01/08 17/08/08

je veux trouver la plus petite des dates pour lesquels j'ai 1 en première
ligne et 1 en deuxième ligne
ici il y a 2 dates concernées c'est 01/10/08 et 01/01/08 et la plus petite
est 01/01/08

bien sur je souhaiterais faire cela avec une seule formule

merci pour vos éclairages




Merguez07
Le #17710141
merci SAM

j'ai maintenant de quoi choisir

"Sam" discussion : 490b4b11$0$915$
Bonjour,
=MIN(SI((A1:E1)*(A2:E2);A3:E3))
en validant par Ctrl,Maj,Entrée
Cordialement
Michel dit "Sam"

"Merguez07" 490b417c$0$8217$
bonjour à tous,
voilà comme d'hab j'ai un pb simple, mais j'ai du mal avec les matrices
et mes tentatives se soldent par une message d'erreur d'excel

j'ai une ligne avec 1 ou 0 dans chaque cellule
idem dans la 2 ligne
dans la 3eme ligne j'ai des dates


ex :
1 1 0 1
1
1 0 1 1
0
01/10/08 01/04/08 06/04/08 01/01/08 17/08/08

je veux trouver la plus petite des dates pour lesquels j'ai 1 en première
ligne et 1 en deuxième ligne
ici il y a 2 dates concernées c'est 01/10/08 et 01/01/08 et la plus
petite est 01/01/08

bien sur je souhaiterais faire cela avec une seule formule

merci pour vos éclairages








Publicité
Poster une réponse
Anonyme