formule recherche suivant info combox

Le
sylvain
bonjour a tous
dans 1 classeur ,plusieurs feuilles nommees (base 1,base 2, base 3)
une autre feuille me sert de recherche ou j'affiche un userform sur
lequel il
y a 3 combox .

dans la combox1 on peut choisir dans quelle base va s'effectuer la
recherche.j'ai besoin d'utiliser la fonction"recherche v" sur cette
feuille
comment dire a cette fonction que la recherche a faire se fera dans la
base afficher dans la combox1
c'est a dire que si dans combx1 c'est "base1" qui est selectionnee
la formule "recherche" doit effectuer sa recherche dans "base 1"
pouvez vous m'aider
merci beaucoup pour vos conseils
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel
Le #4586981
Bonjoour.
Essaie (non testé) :

Feuille = combx1.Value
Resultat = Application.VLookup(ElementRecherché, _
Sheets(Feuille).Range("A1:B10"), 2, 0)

En adaptant les plages.
Cordialement.
Daniel
"sylvain"
bonjour a tous
dans 1 classeur ,plusieurs feuilles nommees (base 1,base 2, base 3)
une autre feuille me sert de recherche ou j'affiche un userform sur
lequel il
y a 3 combox .

dans la combox1 on peut choisir dans quelle base va s'effectuer la
recherche.j'ai besoin d'utiliser la fonction"recherche v" sur cette
feuille
comment dire a cette fonction que la recherche a faire se fera dans la
base afficher dans la combox1
c'est a dire que si dans combx1 c'est "base1" qui est selectionnee
la formule "recherche" doit effectuer sa recherche dans "base 1"
pouvez vous m'aider
merci beaucoup pour vos conseils



JB
Le #4585051
Bonjour,

http://cjoint.com/?groL3YOv1O

Sheets("RECHERCHE").[H2] = Me.ChoixFeuille

=RECHERCHEV(F2;INDIRECT("'" & H2 & "'!D2:E1000");2;FAUX)

JB


On 17 juin, 13:44, sylvain
bonjour a tous
dans 1 classeur ,plusieurs feuilles nommees (base 1,base 2, base 3)
une autre feuille me sert de recherche ou j'affiche un userform sur
lequel il
y a 3 combox .

dans la combox1 on peut choisir dans quelle base va s'effectuer la
recherche.j'ai besoin d'utiliser la fonction"recherche v" sur cette
feuille
comment dire a cette fonction que la recherche a faire se fera dans la
base afficher dans la combox1
c'est a dire que si dans combx1 c'est "base1" qui est selectionnee
la formule "recherche" doit effectuer sa recherche dans "base 1"
pouvez vous m'aider
merci beaucoup pour vos conseils


sylvain
Le #4584761
merci a Daniel et a JB pour vos deux reponses
je suis tres impresionne par le suivi de mon classeur pour la reponse
(de JB)
c'est exactement cela que je recherchais
toujours un grand merci




On 17 juin, 14:39, JB
Bonjour,

http://cjoint.com/?groL3YOv1O

Sheets("RECHERCHE").[H2] = Me.ChoixFeuille

=RECHERCHEV(F2;INDIRECT("'" & H2 & "'!D2:E1000");2;FAUX)

JB

On 17 juin, 13:44, sylvain


bonjour a tous
dans 1 classeur ,plusieurs feuilles nommees (base 1,base 2, base 3)
une autre feuille me sert de recherche ou j'affiche un userform sur
lequel il
y a 3 combox .

dans la combox1 on peut choisir dans quelle base va s'effectuer la
recherche.j'ai besoin d'utiliser la fonction"recherche v" sur cette
feuille
comment dire a cette fonction que la recherche a faire se fera dans la
base afficher dans la combox1
c'est a dire que si dans combx1 c'est "base1" qui est selectionnee
la formule "recherche" doit effectuer sa recherche dans "base 1"
pouvez vous m'aider
merci beaucoup pour vos conseils- Masquer le texte des messages pr c dents -


- Afficher le texte des messages pr c dents -



Publicité
Poster une réponse
Anonyme