formule somme.si ne fonctionne pas

Le
PG49
Bonjour à tous

Les cellules ventes!A10:A375 contiennent des dates
La cellule A9 contient une date
Les cellules ventes!G10:G375 contiennent des valeurs

Existe t il un moyen d'écrire la formule suivante pour que cela fonctionne ?

=SOMME.SI((mois(ventes!A10:A375));MOIS($A$9);ventes!G10:G375)

Il semble que cela soit la fonction mois qui ne soit pas acceptée car
si dans la colonne B de la feuille ventes j'ai la formule
=MOIS(A10)
=MOIS(A11)

alors la formule ci dessous fonctionne
=SOMME.SI(ventes!B10:B375;MOIS($A$9);ventes!G10:G375)
sauf que sur la feuille vente je ne peux pas utiliser la colonne B (ni une
autre) pour faire ce calcul intermédiaire

Merci

--
.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
isabelle
Le #17957101
bonjour,

=SOMMEPROD((MOIS(ventes!A10:A375)=MOIS($A$9))*(ventes!G10:G375))

isabelle

PG49 a écrit :

Bonjour à tous

Les cellules ventes!A10:A375 contiennent des dates
La cellule A9 contient une date
Les cellules ventes!G10:G375 contiennent des valeurs

Existe t il un moyen d'écrire la formule suivante pour que cela fonctionne ?

=SOMME.SI((mois(ventes!A10:A375));MOIS($A$9);ventes!G10:G375)

Il semble que cela soit la fonction mois qui ne soit pas acceptée car
si dans la colonne B de la feuille ventes j'ai la formule
=MOIS(A10)
=MOIS(A11)
...
alors la formule ci dessous fonctionne
=SOMME.SI(ventes!B10:B375;MOIS($A$9);ventes!G10:G375)
sauf que sur la feuille vente je ne peux pas utiliser la colonne B (ni une
autre) pour faire ce calcul intermédiaire

Merci





PG49
Le #17957281
OK Merci Isabelle

cela fonctionne
En fait j'ai même mis
=SOMMEPROD((MOIS(ventes!$A$10:$A$375)=MOIS($A9))*(ANNEE(ventes!$A$10:$A$375)=ANNEE($A9))*ventes!G$10:G$375)
pour tester également l'année.
Le seul truc qui m'embête (mais bon ce n'est pas grave si somme.si ne peut
pas faire l'affaire) c'est que j'ai l'impression qu'avec sommeprod le temps
de calcul est plus long compte tenu du nombre de cellule à calculer (1224
cellules en fait).



"isabelle" a écrit dans le message de news:

bonjour,

=SOMMEPROD((MOIS(ventes!A10:A375)=MOIS($A$9))*(ventes!G10:G375))

isabelle

PG49 a écrit :

Bonjour à tous

Les cellules ventes!A10:A375 contiennent des dates
La cellule A9 contient une date
Les cellules ventes!G10:G375 contiennent des valeurs

Existe t il un moyen d'écrire la formule suivante pour que cela fonctionne
?

=SOMME.SI((mois(ventes!A10:A375));MOIS($A$9);ventes!G10:G375)

Il semble que cela soit la fonction mois qui ne soit pas acceptée car
si dans la colonne B de la feuille ventes j'ai la formule
=MOIS(A10)
=MOIS(A11)
...
alors la formule ci dessous fonctionne
=SOMME.SI(ventes!B10:B375;MOIS($A$9);ventes!G10:G375)
sauf que sur la feuille vente je ne peux pas utiliser la colonne B (ni une
autre) pour faire ce calcul intermédiaire

Merci






Publicité
Poster une réponse
Anonyme