Formule Sommeprod

Le
Tibert
Bonjour à tous

J'aurais besoin d'aide pour établir une formule, comme se n'est pas
facil à expliquer

ci joint fichier

Merci à vous et bonne journée

http://cjoint.com/?kmnJVVxWo0
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
LSteph
Le #20337821
Bonjour,
=SOMMEPROD(($C$2:$C$35=$L2)*($D$2:$D$35)*($B$2:$B$35))

Ce n'est pas d ou il y a 10 qui peut être égal à "TF mais bien C me
semble-t-il
et ce que tu fais là ferait 760 et non 620 mais ce n'est pas tout...
B_________C_______D________Produit B*D
2 TF 10 20
4 TF 50 200
2 FF18 90
6 FF18 30
2 TS 50
2 TF 70 140
2 TS
2 TS

2 TF 10 20
3 TF 20 60
4 TF 30 120
5 TF 40 200
8 TS 20
9 TS 30
10 TS 60

... si en regard tu as mis pomme banana ... etc
la logique visuelle de ton tableau exigerait sans doute que ce critère
aussi soit intégré au sommeprod

=SI($M2="";"";SOMMEPROD(($C$2:$C$35=$L2)*($D$2:$D$35)*($B$2:$B$35)*
(GAUCHE($A$2:$A$35;TROUVE(" ";$A2;1)-1)=$M2)))

'lSteph

On 12 oct, 13:36, Tibert
Bonjour à tous

J'aurais besoin d'aide pour établir une formule, comme se n'est pas
facil à expliquer

ci joint fichier

Merci à vous et bonne journée

http://cjoint.com/?kmnJVVxWo0


Jacky
Le #20337861
Bonjour,
Pas sur d'avoir compris...
...(D2:D35) si est égale (L2)


Il n'y aura jamais la valeur de L2 (TF) dans la colonne D

Essaie
En N2
=SOMMEPROD(($C$2:$C$35=$L2)*($B$2:$B$35)*(D$2:D$35))

--
Salutations
JJ


"Tibert"
Bonjour à tous

J'aurais besoin d'aide pour établir une formule, comme se n'est pas
facil à expliquer

ci joint fichier

Merci à vous et bonne journée

http://cjoint.com/?kmnJVVxWo0
Sam
Le #20339391
Bonjour,
c'est vrai qu'on additionne des pommes avec des navets !
je crois qu'il y a un pb de code.

nota : pour sommeprod, j'écris comme ceci, y t'il un inconvénient ou c'est
mieux ?
=SOMMEPROD(($C$2:$C$35=$L2)*1;$B$2:$B$35;$D$2:$D$35)

Cordialement
Michel dit "Sam"

"LSteph"
Bonjour,
=SOMMEPROD(($C$2:$C$35=$L2)*($D$2:$D$35)*($B$2:$B$35))

Ce n'est pas d ou il y a 10 qui peut être égal à "TF mais bien C me
semble-t-il
et ce que tu fais là ferait 760 et non 620 mais ce n'est pas tout...
B_________C_______D________Produit B*D
2 TF 10 20
4 TF 50 200
2 FF18 90
6 FF18 30
2 TS 50
2 TF 70 140
2 TS
2 TS

2 TF 10 20
3 TF 20 60
4 TF 30 120
5 TF 40 200
8 TS 20
9 TS 30
10 TS 60

... si en regard tu as mis pomme banana ... etc
la logique visuelle de ton tableau exigerait sans doute que ce critère
aussi soit intégré au sommeprod

=SI($M2="";"";SOMMEPROD(($C$2:$C$35=$L2)*($D$2:$D$35)*($B$2:$B$35)*
(GAUCHE($A$2:$A$35;TROUVE(" ";$A2;1)-1)=$M2)))

'lSteph

On 12 oct, 13:36, Tibert
Bonjour à tous

J'aurais besoin d'aide pour établir une formule, comme se n'est pas
facil à expliquer

ci joint fichier

Merci à vous et bonne journée

http://cjoint.com/?kmnJVVxWo0


Tibert
Le #20339661
Merci à vous tous
pour vos réponse, vous m'avez beaucoup aidé et je l'ai adapté à mon
tableau original et sa fonctionne en utilisant

=SOMMEPROD(($C$2:$C$35=$L2)*($B$2:$B$35)*(D$2:D$35))

par compte si il y a pas de somme sa met 0 pour ne pas avoir 0 dans la
cellule il faut utiliser SI(ESTERR( avant SOMMEPROD

Encore merci pour votre aide

Bonne soirée à vous


On 12 oct, 14:52, "Jacky"
Bonjour,
Pas sur d'avoir compris...>...(D2:D35) si est égale (L2)

Il n'y aura jamais la valeur de L2 (TF)  dans la colonne D

Essaie
En N2
=SOMMEPROD(($C$2:$C$35=$L2)*($B$2:$B$35)*(D$2:D$35))

--
Salutations
JJ

"Tibert"
Bonjour à tous

J'aurais besoin d'aide pour établir une formule, comme se n'est pas
facil à expliquer

ci joint fichier

Merci à vous et bonne journée

http://cjoint.com/?kmnJVVxWo0


Jacky
Le #20339911
Re...
...pour ne pas avoir 0 dans la cellule il faut utiliser ....


Voir ici
http://www.cijoint.fr/cjlink.php?file=cj200910/cij2NDChkJ.xls

--
Salutations
JJ


"Tibert"
Merci à vous tous
pour vos réponse, vous m'avez beaucoup aidé et je l'ai adapté à mon
tableau original et sa fonctionne en utilisant

=SOMMEPROD(($C$2:$C$35=$L2)*($B$2:$B$35)*(D$2:D$35))

par compte si il y a pas de somme sa met 0 pour ne pas avoir 0 dans la
cellule il faut utiliser SI(ESTERR( avant SOMMEPROD

Encore merci pour votre aide

Bonne soirée à vous


On 12 oct, 14:52, "Jacky"
Bonjour,
Pas sur d'avoir compris...>...(D2:D35) si est égale (L2)

Il n'y aura jamais la valeur de L2 (TF) dans la colonne D

Essaie
En N2
=SOMMEPROD(($C$2:$C$35=$L2)*($B$2:$B$35)*(D$2:D$35))

--
Salutations
JJ

"Tibert"
Bonjour à tous

J'aurais besoin d'aide pour établir une formule, comme se n'est pas
facil à expliquer

ci joint fichier

Merci à vous et bonne journée

http://cjoint.com/?kmnJVVxWo0


Tibert
Le #20340041
Ok et merci

Bonne soirée


On 12 oct, 20:06, "Jacky"
Re...>...pour ne pas avoir 0 dans la cellule il faut utiliser ....

Voir icihttp://www.cijoint.fr/cjlink.php?file=cj200910/cij2NDChkJ.xls

--
Salutations
JJ

"Tibert"
Merci à vous tous
pour vos réponse, vous m'avez beaucoup aidé et je l'ai adapté à m on
tableau original et sa fonctionne en utilisant

=SOMMEPROD(($C$2:$C$35=$L2)*($B$2:$B$35)*(D$2:D$35))

par compte si il y a pas de somme sa met 0 pour ne pas avoir 0 dans la
cellule il faut utiliser     SI(ESTERR(   avant    SOMMEPROD

Encore merci pour votre aide

Bonne soirée à vous

On 12 oct, 14:52, "Jacky"


> Bonjour,
> Pas sur d'avoir compris...>...(D2:D35) si est égale (L2)

> Il n'y aura jamais la valeur de L2 (TF) dans la colonne D

> Essaie
> En N2
> =SOMMEPROD(($C$2:$C$35=$L2)*($B$2:$B$35)*(D$2:D$35))

> --
> Salutations
> JJ

> "Tibert" >
> Bonjour à tous

> J'aurais besoin d'aide pour établir une formule, comme se n'est pas
> facil à expliquer

> ci joint fichier

> Merci à vous et bonne journée

>http://cjoint.com/?kmnJVVxWo0- Masquer le texte des messages précéde nts -

- Afficher le texte des messages précédents -


LSteph
Le #20341511
ref en english mais bonne ref citée il y a peu dans ce forum


http://www.xldynamic.com/source/xld.SUMPRODUCT.html

;-)

Sam a écrit :
Bonjour,
c'est vrai qu'on additionne des pommes avec des navets !
je crois qu'il y a un pb de code.

nota : pour sommeprod, j'écris comme ceci, y t'il un inconvénient ou c'est
mieux ?
=SOMMEPROD(($C$2:$C$35=$L2)*1;$B$2:$B$35;$D$2:$D$35)

Cordialement
Michel dit "Sam"

"LSteph"
Bonjour,
=SOMMEPROD(($C$2:$C$35=$L2)*($D$2:$D$35)*($B$2:$B$35))

Ce n'est pas d ou il y a 10 qui peut être égal à "TF mais bien C me
semble-t-il
et ce que tu fais là ferait 760 et non 620 mais ce n'est pas tout...
B_________C_______D________Produit B*D
2 TF 10 20
4 TF 50 200
2 FF18 90
6 FF18 30
2 TS 50
2 TF 70 140
2 TS
2 TS

2 TF 10 20
3 TF 20 60
4 TF 30 120
5 TF 40 200
8 TS 20
9 TS 30
10 TS 60

... si en regard tu as mis pomme banana ... etc
la logique visuelle de ton tableau exigerait sans doute que ce critère
aussi soit intégré au sommeprod

=SI($M2="";"";SOMMEPROD(($C$2:$C$35=$L2)*($D$2:$D$35)*($B$2:$B$35)*
(GAUCHE($A$2:$A$35;TROUVE(" ";$A2;1)-1)=$M2)))

'lSteph

On 12 oct, 13:36, Tibert
Bonjour à tous

J'aurais besoin d'aide pour établir une formule, comme se n'est pas
facil à expliquer

ci joint fichier

Merci à vous et bonne journée

http://cjoint.com/?kmnJVVxWo0






Sam
Le #20345701
Bonjour,
merci, c'est vraiment bien détaillé.
Je ne connaissais pas l'utilisation du "OU" (+)
Cordialement
Michel dit "Sam"

"LSteph"
ref en english mais bonne ref citée il y a peu dans ce forum


http://www.xldynamic.com/source/xld.SUMPRODUCT.html

;-)

Sam a écrit :
Bonjour,
c'est vrai qu'on additionne des pommes avec des navets !
je crois qu'il y a un pb de code.

nota : pour sommeprod, j'écris comme ceci, y t'il un inconvénient ou
c'est mieux ?
=SOMMEPROD(($C$2:$C$35=$L2)*1;$B$2:$B$35;$D$2:$D$35)

Cordialement
Michel dit "Sam"

"LSteph"
Bonjour,
=SOMMEPROD(($C$2:$C$35=$L2)*($D$2:$D$35)*($B$2:$B$35))

Ce n'est pas d ou il y a 10 qui peut être égal à "TF mais bien C me
semble-t-il
et ce que tu fais là ferait 760 et non 620 mais ce n'est pas tout...
B_________C_______D________Produit B*D
2 TF 10 20
4 TF 50 200
2 FF18 90
6 FF18 30
2 TS 50
2 TF 70 140
2 TS
2 TS

2 TF 10 20
3 TF 20 60
4 TF 30 120
5 TF 40 200
8 TS 20
9 TS 30
10 TS 60

... si en regard tu as mis pomme banana ... etc
la logique visuelle de ton tableau exigerait sans doute que ce critère
aussi soit intégré au sommeprod

=SI($M2="";"";SOMMEPROD(($C$2:$C$35=$L2)*($D$2:$D$35)*($B$2:$B$35)*
(GAUCHE($A$2:$A$35;TROUVE(" ";$A2;1)-1)=$M2)))

'lSteph

On 12 oct, 13:36, Tibert
Bonjour à tous

J'aurais besoin d'aide pour établir une formule, comme se n'est pas
facil à expliquer

ci joint fichier

Merci à vous et bonne journée

http://cjoint.com/?kmnJVVxWo0







Publicité
Poster une réponse
Anonyme