Formule sous condition

Le
Jacques \(BE\)
Bonjour

Comment ajouter automatiquement dans la colonne B la formule
"=AUJOURD'HUI()" et
dans la colonne C la formule "ÎLLULE("nomfichier")" si la cellule A
contient une donnée ?

Merci de vos réponses

Jacques(BE)
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel
Le #4493481
Bonjour.
En B1, tu mettre :
=SI(A1<>"";AUJOURDHUI();"")
et une formule semblable en C1
Recopie ensuite vers le bas.
Cordialement.
Daniel
"Jacques (BE)" %
Bonjour

Comment ajouter automatiquement dans la colonne B la formule
"=AUJOURD'HUI()" et
dans la colonne C la formule "ÎLLULE("nomfichier")" si la cellule A
contient une donnée ?

Merci de vos réponses

Jacques(BE)




cousinhub
Le #4493471
Bonjour, avec une procédure intégrée dans le code de la feuille.
Cependant, y inscrire la formule (aujourdhui()) n'a que très peu
d'intérêt, celle-ci changeant à chaque ouverture du fichier.
Tu peux inscrire ceci :

Private Sub Worksheet_Change(ByVal Target As Range)
If Target.Column = 1 And Target.Count = 1 Then
Target.Offset(0, 1) = Date
Target.Offset(0, 2) = Evaluate("ÎLL(""nomfichier"")")
End If
End Sub

remarque 2, inscrire le nom du fichier?????
Le fait d'inscrire le résultat (Evaluate...), te permet de garder sur ta
cellule de destination le nom actuel du fichier, en cas de changement de
nom ultérieur.
Bon courage

Bonjour

Comment ajouter automatiquement dans la colonne B la formule
"=AUJOURD'HUI()" et
dans la colonne C la formule "ÎLLULE("nomfichier")" si la cellule A
contient une donnée ?

Merci de vos réponses

Jacques(BE)




Jacques \(BE\)
Le #4493421
Merci à vous deux.

Jacques(BE)

"cousinhub" news:
Bonjour, avec une procédure intégrée dans le code de la feuille.
Cependant, y inscrire la formule (aujourdhui()) n'a que très peu
d'intérêt, celle-ci changeant à chaque ouverture du fichier.
Tu peux inscrire ceci :

Private Sub Worksheet_Change(ByVal Target As Range)
If Target.Column = 1 And Target.Count = 1 Then
Target.Offset(0, 1) = Date
Target.Offset(0, 2) = Evaluate("ÎLL(""nomfichier"")")
End If
End Sub

remarque 2, inscrire le nom du fichier?????
Le fait d'inscrire le résultat (Evaluate...), te permet de garder sur ta
cellule de destination le nom actuel du fichier, en cas de changement de
nom ultérieur.
Bon courage

Bonjour

Comment ajouter automatiquement dans la colonne B la formule
"=AUJOURD'HUI()" et
dans la colonne C la formule "ÎLLULE("nomfichier")" si la cellule A
contient une donnée ?

Merci de vos réponses

Jacques(BE)






Publicité
Poster une réponse
Anonyme