freebsd 9.2 / probleme de dhclient

Le
patpro ~ patrick proniewski
Bonjour,

Depuis que je suis passé sur Freebsd 9.2 pour ma passerelle/firewall
ADSL, j'ai un souci : quand la freebox perd la synchro ADSL, mon
interface DHCP perd son IP, mais elle ne la retrouve pas quand la
synchro ADSL revient.

Je n'ai jamais eu le problème avec les versions précédentes de FreeBSD
donc j'imagine que quelque chose a changé dans le client DHCP.

Le pire, c'est que je n'ai pas trouvé d'autre moyen que de rebooter pour
restaurer ma config réseau. Relancer dhclient ne donne rien, ça c'est
sûr.
Je ne trouve rien sur les forums qui se rapproche de mon problème, et je
n'ai aucune trace dans les logs, ce qui n'aide pas.

Des idées ?

patpro

--
photo http://photo.patpro.net/
blog http://www.patpro.net/
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Patrick Lamaizière
Le #25782732
patpro ~ patrick proniewski :

Depuis que je suis passé sur Freebsd 9.2 pour ma passerelle/firewall
ADSL, j'ai un souci : quand la freebox perd la synchro ADSL, mon
interface DHCP perd son IP, mais elle ne la retrouve pas quand la
synchro ADSL revient.

Je n'ai jamais eu le problème avec les versions précédentes de FreeBSD
donc j'imagine que quelque chose a changé dans le client DHCP.

Le pire, c'est que je n'ai pas trouvé d'autre moyen que de rebooter pour
restaurer ma config réseau. Relancer dhclient ne donne rien, ça c'est
sûr.
Je ne trouve rien sur les forums qui se rapproche de mon problème, et je
n'ai aucune trace dans les logs, ce qui n'aide pas.

Des idées ?



un ifconfig down / up ça le fait pas (sans relancer dhclient) ?
patpro ~ patrick proniewski
Le #25782782
In article Patrick Lamaizière

un ifconfig down / up ça le fait pas (sans relancer dhclient) ?




Je ne me souviens plus de tout ce que j'ai tenté, mais la prochaine fois
que le cas se présente je noterai l'effet de la commande.
Quoi qu'il en soit ce serait vachement plus sympa si le comportement des
anciennes versions pouvait revenir.
Avant, l'interface en question ne perdait pas son IP toute seule...

patpro

--
photo http://photo.patpro.net/
blog http://www.patpro.net/
Bruno Ducrot
Le #25783092
Bruno,

On 2013-11-13, patpro ~ patrick proniewski wrote:
In article Patrick Lamaizière

un ifconfig down / up ça le fait pas (sans relancer dhclient) ?




Je ne me souviens plus de tout ce que j'ai tenté, mais la prochaine fois
que le cas se présente je noterai l'effet de la commande.
Quoi qu'il en soit ce serait vachement plus sympa si le comportement des
anciennes versions pouvait revenir.
Avant, l'interface en question ne perdait pas son IP toute seule...



BTW, ça marchait avec quelle version de FreeBSD ?
Ca aiderait pour un diff. Et j'aimerais aussi connaître
l'interface en question.

A plus,

--
Bruno Ducrot

A quoi ca sert que Ducrot hisse des carcasses ?
Damien Wyart
Le #25783152
* Bruno Ducrot
Bruno,



Tiens, Patrick a changé de prénom subrepticement :)

--
DW
patpro ~ patrick proniewski
Le #25784372
In article Bruno Ducrot
> Je ne me souviens plus de tout ce que j'ai tenté, mais la prochaine fois
> que le cas se présente je noterai l'effet de la commande.
> Quoi qu'il en soit ce serait vachement plus sympa si le comportement des
> anciennes versions pouvait revenir.
> Avant, l'interface en question ne perdait pas son IP toute seule...

BTW, ça marchait avec quelle version de FreeBSD ?
Ca aiderait pour un diff. Et j'aimerais aussi connaître
l'interface en question.




Je n'ai pas de certitude absolue, malheureusement. Je sais qu'entre la 6
et la 8.3 je n'ai jamais eu le souci. Mais j'ai changé de machine en
avril dernier, et depuis c'est un peu flou.
Je pense que je n'ai pas eu le problème en 9.1 (système de départ pour
ma nouvelle machine), et que les choses se sont gâtées quand je suis
passé en 9.2 (12 octobre).

L'interface c'est :

em1: flagsˆ43<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
optionsB19b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,TSO4,WOL_
MAGIC,VLAN_HWTSO>
ether 70:54:*:*:*:*
inet 82.*.*.* netmask 0xffffff00 broadcast 82.*.*.255
nd6 options)<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
media: Ethernet autoselect (100baseTX <full-duplex>)
status: active

chipset 82574L pour le port là (em0 utilise le chipset 82579LM, et
dessert mon LAN).

patpro

--
photo http://photo.patpro.net/
blog http://www.patpro.net/
patpro ~ patrick proniewski
Le #25784662
> > Je ne me souviens plus de tout ce que j'ai tenté, mais la prochaine fois
> > que le cas se présente je noterai l'effet de la commande.



pas eu à attendre des masses (malheureusement)

sudo ifconfig em1 down
sudo ifconfig em1 up

fonctionne, et mon IP revient. Je passe de ça :

inet 0.0.0.0 netmask 0xff000000 broadcast 255.255.255.255

à ça :

inet 82.*.*.* netmask 0xffffff00 broadcast 82.*.*.255

Je me demande si je ne gagnerai pas à ajouter une ligne

fixed-address $MONIP

dans le dhclient.conf. Un avis sur la question ?

patpro

--
photo http://photo.patpro.net/
blog http://www.patpro.net/
Patrick Lamaizière
Le #25785272
patpro ~ patrick proniewski :

dans le dhclient.conf. Un avis sur la question ?



sais pas :) visiblement y'a pas eu de modif dans dhclient dans 9 depuis
20 mois alors... A part une surveillance du lien de l'interface, mais
ça devrait générer une trace de debug. Tu as essayé de le lancer au
premier plan et de voir ce qu'il dit ? (Je n'ai pas trouvé comment
était activé le debug ni si ça log.)

dhclient.c: debug("%s link state %s -> %s", ifi->name,

J'ai pas de souci au taf soit dit en passant (em aussi, je regarderai le
chipset demain)
kevin vanier
Le #25785382
Le 11/11/2013 08:43, patpro ~ patrick proniewski a écrit :
Bonjour,

Depuis que je suis passé sur Freebsd 9.2 pour ma passerelle/firewall
ADSL, j'ai un souci : quand la freebox perd la synchro ADSL, mon
interface DHCP perd son IP, mais elle ne la retrouve pas quand la
synchro ADSL revient.

Je n'ai jamais eu le problème avec les versions précédentes de FreeBSD
donc j'imagine que quelque chose a changé dans le client DHCP.

Le pire, c'est que je n'ai pas trouvé d'autre moyen que de rebooter pour
restaurer ma config réseau. Relancer dhclient ne donne rien, ça c'est
sûr.




Bonjour/soir/nuit

Est ce trop contraignant d'inverser les cartes réseaux pour voir comment
vont se comporter celles ci ?

Pas de switch entre la Gateway et la Box ?

++
patpro ~ patrick proniewski
Le #25785532
In article kevin vanier
Est ce trop contraignant d'inverser les cartes réseaux pour voir comment
vont se comporter celles ci ?



c'est l'affaire de 30 secondes. À la base par souci de sécu je voulais
garder le chipset "M" sur le LAN car :

In addition, the Intel 82579LM Gigabit Ethernet Controller supports
Intel AMT, which is a part of Intel’s vProTM technology.

et que :

Some of the features of Intel AMT include:
• Out-of-band (OOB) system access, to discover assets even while PCs are
powered off
• Remote trouble-shooting and recovery, which allows remote diagnosis
and recovery of systems after OS failures
• Hardware-based agent presence checking that automatically detects and
alerts when critical software agents have been stopped or are missing
• Proactive network defense, which uses filters to block incoming
threats while isolating infected clients before they impact the network
• Remote hardware and software asset tracking, helping to track computer
assets and keep virus protection up-to-date
• Keyboard, video and mouse (KVM) remote control, which allows
redirection of a managed system’s video to a remote console which can
then interact with it using the console’s own mouse and keyboard.

Mais c'est un peu de la parano, vu que mon CPU ne supporte pas AMT de
toute manière (en même temps, qui sait, hein ?)

Pas de switch entre la Gateway et la Box ?



nope. j'ai :

[freebox]---[em1-freebsd-em0]--[switch]--[LAN]

Je testerai sans doute l'inverse au niveau des branchements, mais il
faut que je prenne le temps de trouver un moyen de reproduire le
symptome à tous les coups, histoire de pas attendre bêtement que le
problème se reproduise.

patpro

--
photo http://photo.patpro.net/
blog http://www.patpro.net/
patpro ~ patrick proniewski
Le #25785522
In article Patrick Lamaizière
patpro ~ patrick proniewski :

> dans le dhclient.conf. Un avis sur la question ?

sais pas :) visiblement y'a pas eu de modif dans dhclient dans 9 depuis
20 mois alors... A part une surveillance du lien de l'interface, mais
ça devrait générer une trace de debug. Tu as essayé de le lancer au
premier plan et de voir ce qu'il dit ? (Je n'ai pas trouvé comment
était activé le debug ni si ça log.)



j'ai déjà regardé du coté du débug. Je n'ai rien trouvé pour dhclient à
part un flag qui force le démon à rester au premier plan jusqu'à ce
qu'il attrape une IP, après quoi il repasse à l'arrière plan. Je ne suis
pas persuadé qu'il repasserait au premier plan quand l'interface perd
son IP (à quel terminal s'attacherait-il ?). D'autant que techniquement
elle ne la perd pas son IP, elle passe simplement à "0.0.0.0"

cette aprem', RTT, je vais pouvoir brutaliser ma connexion pour tester
différents trucs. À suivre.

patpro

--
photo http://photo.patpro.net/
blog http://www.patpro.net/
Publicité
Poster une réponse
Anonyme