FreeCAD et fedora

Le
Marc Dejardin
Bonjour,
J'essaie d'installer FreeCAD sur une fedora core 11.
Aucun paquet spécifique pour la FC11 n'est disponible, donc je suis
reparti des sources.
Après quelques essais, la compilation se passe bien.
Le problème apparait lors du lancement du programme :
J'obtiens un segmentation fault

gdb semble me dire que cela vient de qt-mt :
Program received signal SIGSEGV, Segmentation fault.
0x0477153a in ?? () from /usr/lib/qt-3.3/lib/libqt-mt.so.3

De plus gdb me sort tout un tas de messages du genre :
Starting program: /root/rpmbuild/SOURCES/FreeCAD-0.9.2646/bin/FreeCAD -t 0
warning: .dynamic section for "/lib/libutil.so.1" is not at the expected
address
warning: difference appears to be caused by prelink, adjusting expectations

Ce qui est bizarre, c'est que le programme demande qt4 lors du
configure alors pourquoi cette bibilothèque qt3

Comme je n'ai pas envie d'y passer ma vie, je voudrais savoir si
quelqu'un a déjà réussi à compiler et à faire tourner FreeCAD sur une
fedora, et aurait un rpm sous la main.

Sinon, j'ai essayé wine sur le paquet windows sans plus de succès.

Merci de tout conseil ou avis
M.D.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
batyann811
Le #21113581
Le 02/02/2010 15:27, Marc Dejardin a écrit :
Comme je n'ai pas envie d'y passer ma vie, je voudrais savoir si
quelqu'un a déjà réussi à compiler et à faire tourner FreeCAD sur une
fedora, et aurait un rpm sous la main.




Tu as essayé les rpms du site officiel ?
Marc Dejardin
Le #21114041
Le 02/02/2010 17:23, batyann811 a écrit :
Le 02/02/2010 15:27, Marc Dejardin a écrit :
Comme je n'ai pas envie d'y passer ma vie, je voudrais savoir si
quelqu'un a déjà réussi à compiler et à faire tourner FreeCAD sur une
fedora, et aurait un rpm sous la main.




Tu as essayé les rpms du site officiel ?


Oui, mais ce sont des rpms pour opensuse.
Ça coince au niveau des dépendances qui ne sont pas organisées
comme chez fedora.
Merci
user
Le #21114661
Marc Dejardin wrote:

Bonjour,
J'essaie d'installer FreeCAD sur une fedora core 11.
Aucun paquet spécifique pour la FC11 n'est disponible, donc je suis
reparti des sources.
Après quelques essais, la compilation se passe bien.
Le problème apparait lors du lancement du programme :
J'obtiens un segmentation fault...

gdb semble me dire que cela vient de qt-mt :
Program received signal SIGSEGV, Segmentation fault.
0x0477153a in ?? () from /usr/lib/qt-3.3/lib/libqt-mt.so.3






il y a un make-qt3 et un make-qt4.

Prenez le bon...


--
--
What's on Shortwave guide: choose an hour, go!
http://shortwave.tk
700+ Radio Stations on SW http://swstations.tk
300+ languages on SW http://radiolanguages.tk
Marc Dejardin
Le #21116391
Le 02/02/2010 15:27, Marc Dejardin a écrit :
Bonjour,
J'essaie d'installer FreeCAD sur une fedora core 11.
Aucun paquet spécifique pour la FC11 n'est disponible, donc je suis
reparti des sources.
Après quelques essais, la compilation se passe bien.
Le problème apparait lors du lancement du programme :
J'obtiens un segmentation fault...

gdb semble me dire que cela vient de qt-mt :
Program received signal SIGSEGV, Segmentation fault.
0x0477153a in ?? () from /usr/lib/qt-3.3/lib/libqt-mt.so.3

De plus gdb me sort tout un tas de messages du genre :
Starting program: /root/rpmbuild/SOURCES/FreeCAD-0.9.2646/bin/FreeCAD -t 0
warning: .dynamic section for "/lib/libutil.so.1" is not at the expected
address
warning: difference appears to be caused by prelink, adjusting expectations

Ce qui est bizarre, c'est que le programme demande qt4 lors du
configure... alors pourquoi cette bibilothèque qt3...

Comme je n'ai pas envie d'y passer ma vie, je voudrais savoir si
quelqu'un a déjà réussi à compiler et à faire tourner FreeCAD sur une
fedora, et aurait un rpm sous la main.

Sinon, j'ai essayé wine sur le paquet windows sans plus de succès.

Merci de tout conseil ou avis
M.D.


Bonjour,
En fait c'est SoQt qui utilise QT-3.
J'ai trouvé un paquet de SoQt qui utilise QT4 (fc12 au lieu de fc11 qui
est ma distro).
Ça semble marcher (pour le moins, le programme démarre)
Merci de votre aide.
M.D.
Publicité
Poster une réponse
Anonyme