[FW35] Pas de ASP.net 3.5

Le
Laurent Jordi
Salut,

Je viens de créer un projet ASP.net 3.5 avec VISUAL Studio 2008. Etant donné
que j'ai installé Visual Studio sur le serveur de dev, je suis certain que
le Framework 3.5 est installé. J'ai créé un site racine mais lorsque j evais
dans ses propriétés et dans l'onglet ASP.net je trouve seulement ASP.1.1 et
2.0 mais pas 3.5.

Je sais que le CLR est le même mais je suis étonné de ne pas voir 3.5 dans
la liste. Faut-il impérativement installer Windows Server 2008 ? Le site
tournera-t-il normalement avec l'option 2.0 ?

D'avance merci pour votre aide

Laurent Jordi
http://www.ezlogic.mc
http://www.laurentjordi.net
Nouveau blog : http://sossoa.blogspot.com/
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
jbongran
Le #11339941
"Laurent Jordi" news:
Salut,

Je viens de créer un projet ASP.net 3.5 avec VISUAL Studio 2008. Etant
donné que j'ai installé Visual Studio sur le serveur de dev, je suis
certain que le Framework 3.5 est installé. J'ai créé un site racine mais
lorsque j evais dans ses propriétés et dans l'onglet ASP.net je trouve
seulement ASP.1.1 et 2.0 mais pas 3.5.

Je sais que le CLR est le même mais je suis étonné de ne pas voir 3.5 dans
la liste. Faut-il impérativement installer Windows Server 2008 ? Le site
tournera-t-il normalement avec l'option 2.0 ?

D'avance merci pour votre aide

Laurent Jordi
http://www.ezlogic.mc
http://www.laurentjordi.net
Nouveau blog : http://sossoa.blogspot.com/



asp.net 3.5 est une collection de librairies qui étend le 2.0.
Ceci explique qu'il n'y ait pas une entrée 3.5 dans IIS.
Visual Studio a dû rajouter un appel explicite à la "version" 3.5
Pour un exemple de web.config, regarder ici:
http://forums.iis.net/p/1133618/1860351.aspx
Laurent Jordi
Le #11339931
Salut,

Ah ok... j'ai pu contater que cela fonctionnait bien. Domage qu'il n'y ait
pas rétrocompatibilité du FW 2.0 avec le 1.1... (Ou alors domage que je ne
sache pas qu'elle existe)...

En tous les cas, Visual Studio 2008 c'est de la balle...

++

Laurent Jordi
http://www.ezlogic.mc
http://www.laurentjordi.net
Nouveau blog : http://sossoa.blogspot.com/



"jbongran" 47619ea4$0$12376$
"Laurent Jordi" news:
Salut,

Je viens de créer un projet ASP.net 3.5 avec VISUAL Studio 2008. Etant
donné que j'ai installé Visual Studio sur le serveur de dev, je suis
certain que le Framework 3.5 est installé. J'ai créé un site racine mais
lorsque j evais dans ses propriétés et dans l'onglet ASP.net je trouve
seulement ASP.1.1 et 2.0 mais pas 3.5.

Je sais que le CLR est le même mais je suis étonné de ne pas voir 3.5
dans la liste. Faut-il impérativement installer Windows Server 2008 ? Le
site tournera-t-il normalement avec l'option 2.0 ?

D'avance merci pour votre aide

Laurent Jordi
http://www.ezlogic.mc
http://www.laurentjordi.net
Nouveau blog : http://sossoa.blogspot.com/



asp.net 3.5 est une collection de librairies qui étend le 2.0.
Ceci explique qu'il n'y ait pas une entrée 3.5 dans IIS.
Visual Studio a dû rajouter un appel explicite à la "version" 3.5
Pour un exemple de web.config, regarder ici:
http://forums.iis.net/p/1133618/1860351.aspx


Publicité
Poster une réponse
Anonyme