[Fwd: Re: etch/wifi/rt61pci (carte dwl-g510) : pas de résolution dns, plantage au redémarrage interface]

Le
Bulot gregory
> bonjour,
>
> j'utilise rt61pci et wpasuplicant pour ma carte wifi :
> module version 2.0.12 (je pense via m-a a-i rtx2000)
>

en désespoir de cause je suis revenu au module du site ralink (rt61 au
lieu de rt61pci)

- a chaque démarrage de la machine rt61pci, continu de se charger (malgre
l'ajout de blacklist rt61pci dans /etc/modprobe.d/blacklist), je
modprobe -r rt61pci,
(rt61 étant déjà chargé)
- iwlist ra0 scan m'affiche bien tous les pa voisins + le mien
- je suis en wpa (wpapsk - tkip dans rt61sta.dat) : que je saisisse la
clef wpapsk en clair ou en hexa je ne ping pas mon routeur (ou quoique
cela soit d'autre)


Note :
1/comme je laisse parfois eth0 'up', je ping comme cela :
ping -c 1 -I ra0 192.168.0.250
2/le rt61stat.dat n'a de modifié que le SSID, AuthMode=TKIP,
EncryptType=TKIP, et WPAPSK=[pass en clair ou hexa]
3/je ne suis pas en dhcp
4/le network/interface ne posséde que l'ip,netmask, gateway





--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Bulot gregory
Le #9649011
>> bonjour,





en désespoir de cause je suis revenu au module du site ralink (rt61 au
lieu de rt61pci)



visiblement "network-manager" (kesako ?) pose des soucis dans le
rt61sta.dat, il faut (a la fin du fichier chez moi)
NativeWpa=0

pis un ptit networking restart

je ne positionnne pas encore de résolu ... j'attend de voir la stabilité

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
fra-duf-no-spam
Le #9649001
Le 13963ième jour après Epoch,
Bulot gregory écrivait:

bonjour,

j'utilise rt61pci et wpasuplicant pour ma carte wifi :
module version 2.0.12 (je pense via m-a a-i rtx2000...)




en désespoir de cause je suis revenu au module du site ralink (rt61 au
lieu de rt61pci)

- a chaque démarrage de la machine rt61pci, continu de se charger (m algre
l'ajout de blacklist rt61pci dans /etc/modprobe.d/blacklist), je
modprobe -r rt61pci,



Essaye de le blacklister dans udev, c'est peut-être lui qui le charge.
Bulot gregory
Le #9648991
> visiblement "network-manager" (kesako ?) pose des soucis dans le
rt61sta.dat, il faut (a la fin du fichier chez moi)
NativeWpa=0

pis un ptit networking restart

je ne positionnne pas encore de résolu ... j'attend de voir la stabilité



visiblement, j'ai bien fait de ne pas tagger résolu, j'ai toujours pas de
résolution de noms en wifi !

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Bulot Grégory
Le #9648951
[je repost ma réponse (de mémoire) qui semble s'être perdue]
Le mardi 25 mars 2008 16:30, François TOURDE a écrit :


Essaye de le blacklister dans udev, c'est peut-être lui qui le charg e.



visiblement cela change pas mal de chose avec udev :

dans z25... ou z45.... j'ai viré la ligne wlan0
redémarrage rapide (pas d'attente sur mta)
=> pas d'ip (fixe pas de dhcp) attribué à ra0


remise en place du wlan0, mais remplacement par ra0
=>pas d'ip attribué à ra0

/etc/init.d/networking restart
=> ip attribué a ra0, ping sur ip directe ok, mais www.google.com : pas de
résolution de noms, que fait de plus qu'un restart par rapport a ce qu 'il se
passe lors du boot ?

/etc/resolv.conf pointe sur :
- 192.168.1.1 passerelle pour eth0
- 192.168.0.254 passerelle (freebox mode routeur) pour ra0
Bulot gregory
Le #9648931
> [je repost ma réponse (de mémoire) qui semble s'être perdue]
Le mardi 25 mars 2008 16:30, François TOURDE a écrit :


Essaye de le blacklister dans udev, c'est peut-être lui qui le charge.



visiblement cela change pas mal de chose avec udev :

dans z25... ou z45.... j'ai viré la ligne wlan0
redémarrage rapide (pas d'attente sur mta)
=> pas d'ip (fixe pas de dhcp) attribué à ra0


remise en place du wlan0, mais remplacement par ra0
=>pas d'ip attribué à ra0





pour la résolution de nom, ceci arrange les choses :
ifconfig ra0 192.168.0.26 up
route add default gw 192.168.0.254
et
cat /etc/resolv.conf
nameserver 212.27.54.252
nameserver 212.27.53.252
#nameserver 192.168.0.254
nameserver 192.168.1.1

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Bulot gregory
Le #9648921
bon, y'a un truc qui a l'air de fonctionner 'dans tous les cas' (routeur
freebox/wifi en wpapsk), il faudra que je teste ça chez un client avec
livebox en mixte wep/wpa pour être sur .....

dans mon /etc/network/interface:
auto ra0
#iface ra0 inet dhcp
iface ra0 inet static
address 192.168.0.26
netmask 255.255.255.0
gateway 192.168.0.254
pre-up /root/WifiLIC.sh WPA 1>/var/log/wifi.log 2>&1

/root/WifiLIC.sh :
#!/bin/sh
# actuellement l'évalution du fichier pilote est "sale"
# il faudrait executer le fichier pilote pour récupérer directement les
valeurs ...
date
fichierConfPilote=/etc/Wireless/RT61STA/rt61sta.dat


LeSSID=$(grep ^SSID $fichierConfPilote | awk -F "=" '{print $2}')
ClefWPA=$(grep ^WPAPSK $fichierConfPilote | awk -F "=" '{print $2}')
echo -e "n======= $0 ========"
case $1 in
"WPA")
echo "Affectation du essid ..."
iwconfig ra0 essid $LeSSID
echo "Affectation de la clef $1 ..."
iwpriv ra0 set WPAPSK="$ClefWPA"
echo "Démarrage de l'interface wifi ..."
ifconfig ra0 up
echo "pause de 5s pour réponse AP ..."
sleep 5s
;;
"WEP")
echo "Wep non actif sur $0"
;;
*)
echo "Action non reconnue pour $0"
;;
esac

y'a des trucs crade qui passe pendant le démarrage ... mais ça marche ... :

cat /var/log/wifi.log
======= /root/WifiLIC.sh ======= Affectation du essid ...
Error for wireless request "Set ESSID" (8B1A) :
SET failed on device ra0 ; Network is down.
Affectation de la clef WPA ...
Interface doesn't accept private ioctl...
set (8BE2): Network is down
Démarrage de l'interface wifi ...
pause de 5s pour réponse AP ...


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
gbulot
Le #9696021
X-Priority: 5 (Lowest)
Message-ID:
X-Sender:
Received: from tal33-2-82-230-114-102.fbx.proxad.net [82.230.114.102] with
HTTP/1.1 (POST); Fri, 28 Mar 2008 09:22:27 +0100
User-Agent: RoundCube Webmail/0.1
Content-Type: text/plain; charset="UTF-8"
Content-Transfer-Encoding: 8bit


On Wed, 26 Mar 2008 11:13:15 +0100 (CET), "Bulot gregory"

bon y'a vraiment des trucs que je comprends pas avec le wifi.déjà
y'a-t-il des utilisateurs wifi ici qui ont taté de la livebox en wifi
(Wep-Wpa), du routeur dlink avec la même machine et la même carte ?

- j'utilise des dwl-g510 (ralink rt61 pour le chipset).
- j'utilise le pilote de chez ralink (2007_1210_RT61_Linux_STA_v1.1.2.0) en
2.6.22 pour mon noyau (lenny non modifié)
- je n'utilise pas d'interface graphique (.
- mes clients utilisent soit du wep, soit du wpa, soit au choix (cas des
livebox qui ont une option par défaut en "wep ou wpa")

en lisant le readme de chez ralink, j'avais cru comprendre qu'en utilisant
les iwconfig et iwpriv (dans le /etc/network/interface par ex), le
rt61sta.dat n'était plus utilisé ! je me dis cool la config 'itinérante'
va être facile à gérer plus besoin de modifier le rt61sta.dat, juste un
shell en pre-up dans /etc/network/interface ou je met en paramètre le
profil qui va bien (un peu comme le wpasupplicant.conf pour le rt61pci.

et bien non !! j'ai perdu 2 jours à galérer pour rien !

Comme faites vous pour réussir une config wifi 'itinérante' qui marche à
tous le coups ?

par ailleurs je viens de m'apercevoir qu'un processus (qui semble être
'network-manager') écrase systématiquement (y'a plus d'entré namserver
!!) mon /etc/resolv.conf, en regardant le /etc/init.d/network-manager, je
ne vois nul part une fonction s'occupant de cela.


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Frédéric BOITEUX
Le #9696011
Salut,

Le ven 28 mar 2008 09:22:27 CET, gbulot

On Wed, 26 Mar 2008 11:13:15 +0100 (CET), "Bulot gregory"

...
Comme faites vous pour réussir une config wifi 'itinérante' qui marche à
tous le coups ?



Perso, j'utilise wpasupplicant, qui permet cela (voir les README.* dans
son répertoire de doc).

par ailleurs je viens de m'apercevoir qu'un processus (qui semble êt re
'network-manager') écrase systématiquement (y'a plus d'entrà © namserver
!!) mon /etc/resolv.conf, en regardant le /etc/init.d/network-manager, je
ne vois nul part une fonction s'occupant de cela.


C'est clair que soit tu passes par networkmanager, soit tu dois lui
interdire la gestion de la connexion sans-fil ! Pour le resolv.conf, je
te conseille fortement d'utiliser le paquet resolvconf...

Fred.
Publicité
Poster une réponse
Anonyme