galeres pour debuter ....à lire pour ne pas se decourager

Le
no_spam
bjr , programmant en C depuis es années , j'ai decouvert à la mediatheque par hasard un bouquin "programmer en python" de 0'reilly et j e l'ai pris par curiosite .
ca m'a paru interessant car la programmation GUI paraissait facile ( par rapport a C ! )

j'ai donc chargé python 3.1 , ecrit un petit prog avec quelques cases edit et une photo dans un canvas . ca m'a pris moins de 5 minutes . Chapeau !
ensuite je me suis dit je vais le "pseudo compiler" avec py2exe que j'avais vu sur un site . j'ai chargé la derniere version 0.6.9 .
1er echec : a force de relire , en anglais :( des posts sur des sites j'ai compris que py2 ne marchait pas pour la 3.1 . j'ai apercu sur leur site un py2 pour la version python 2.6 que j'ai donc telechargé , puis
desinstallation de python 3.1 , telecharge la python 2.6.5 , installee , lancement de l'install de py2exe-0.6.9.win32-py2.6.exe -> 2eme echec , elle ne se lance meme pas , message d'erreur comme si c'etait meme pas du
code windows .
rechergee sur des sites miroirs -> idem !
j'ai donc charge la version py2 inferieure la 2.5 , essai de lancement : elle se lance !
donc desinstall a nouveau de python 2.6 , chargement de python 2.5 , installation , installation de py2 version 2.5 , ca marche !!!
donc je suis oblige d'utiliser une tres VIEILLE version de python et py2 !
ca fait un peu amateur pour une premiere approche .

avez vous les memes problemes ? j'ai windows xp sp2 .
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Bruno Desthuilliers
Le #21433011
debenpyt a écrit :
bjr , programmant en C depuis es années , j'ai decouvert à la
mediatheque par hasard un bouquin "programmer en python" de 0'reilly
et j e l'ai pris par curiosite . ca m'a paru interessant car la
programmation GUI paraissait facile ( par rapport a C ... ! )

j'ai donc chargé python 3.1 ,



Attention, il y a pas mal d'incompatibilités entre Python 2.x et Python 3.x.

Pour info, les versions utilisés en prod actuellement sont
essentiellement la 2.5 et la 2.6.

ecrit un petit prog avec quelques cases
edit et une photo dans un canvas . ca m'a pris moins de 5 minutes .
Chapeau ! ensuite je me suis dit je vais le "pseudo compiler" avec
py2exe que j'avais vu sur un site . j'ai chargé la derniere version
0.6.9 . 1er echec : a force de relire , en anglais :( des posts sur
des sites j'ai compris que py2 ne marchait pas pour la 3.1 . j'ai
apercu sur leur site un py2 pour la version python 2.6 que j'ai donc
telechargé , puis desinstallation de python 3.1 , telecharge la
python 2.6.5 , installee , lancement de l'install de
py2exe-0.6.9.win32-py2.6.exe -> 2eme echec , elle ne se lance meme
pas , message d'erreur comme si c'etait meme pas du code windows .
rechergee sur des sites miroirs -> idem ! j'ai donc charge la version
py2 inferieure la 2.5 , essai de lancement : elle se lance ! donc
desinstall a nouveau de python 2.6 , chargement de python 2.5 ,
installation , installation de py2 version 2.5 , ca marche !!! donc
je suis oblige d'utiliser une tres VIEILLE version de python



Tellement très vieille qu'elle est encore très courante en prod !-)

et py2 !
ca fait un peu amateur pour une premiere approche ....



Réflexion à transmettre aux mainteneurs de py2exe... si possible avec le
message d'erreur.

avez vous les memes problemes ? j'ai windows xp sp2 .



<troll>
Non, je n'ai pas windows xp. Mais je conçois que ce soit en soi un
problème !-)
</troll>

Blague à part, là je pense que Michel (Claveau) sera plus à même de
t'aider que moi, c'est lui le spécialiste MS ici.
no_spam
Le #21433981
Le Wed, 24 Mar 2010 17:21:34 +0100, Bruno Desthuilliers

avez vous les memes problemes ? j'ai windows xp sp2 .



<troll>
Non, je n'ai pas windows xp. Mais je conçois que ce soit en soi un
problème !-)
</troll>



tu as raison de mettre : troll mais ca n'excuse rien .
cela semblerait dire que les gens qui programment en python serait anti- microsoft ???? et ?? linuxiens peut etre ? !
pour moi c'est une querelle depassee ; professionellemnt je developpe sur des machines UNIX , mais par loisir j'envisage de developper une appli
facile d'emploi pour des gens agés en maison de retraite , je cible le parc installé par les conseils generaux : des machines xp dis donc !
Bruno Desthuilliers
Le #21435421
debenpyt a écrit :
Le Wed, 24 Mar 2010 17:21:34 +0100, Bruno Desthuilliers

avez vous les memes problemes ? j'ai windows xp sp2 .


<troll>
Non, je n'ai pas windows xp. Mais je conçois que ce soit en soi un
problème !-)
</troll>



tu as raison de mettre : troll mais ca n'excuse rien .



??? gné ???

pour moi c'est une querelle depassee ;



Eh bé...

Respire un coup, détend toi, et reviens parmi nous. Y a que toi qui y
vois une querelle - ici, c'est surtout un sujet de plaisanterie idiote
du vendredi soir. Dieu (ou qui ou quoi que ce soit d'autre) merci, on
n'en est plus à se prendre le chou là dessus, ce serait trop triste.

Amicalement (si si)
B.
Publicité
Poster une réponse
Anonyme