[gentoo-user-fr] Aspell et linguas

Le
gwenhael
Bonjour,
Je suis confronté à un problème relatif à aspell et à LINGUAS.
En faisant mes mises à jour j'ai vu apparaître un aspell-en-0.51.1
qui bloque avec aspell-0.60.5.
Je n'ai pas défini mon linguas dans make.conf à 'en' mais à 'fr'
donc il n'y a pas de raisons que ce packages vienne à s'installer.
Pour m'éviter les problèmes de version de aspell j'ai voulu installer
aspell-en-6.0.0 mais emerge me dit qu'il est masqué, eix me dit le contra=
ire.
Et en faisant un depclean, emerge veut me supprimer tout ce qui est en fr
(man-pages-fr et aspell-fr)
Quelqu'un sait pourquoi le système ne tiens pas compte du LINGUAS spéci=
fié?
Y a t'il eut un changement récent qui entraînerait ce problème ?
Merci d'avance.
Gwenhaël

-
http://www.trabucayre.com
Arsenic et vieilles ferailles
--
gentoo-user-fr@lists.gentoo.org mailing list
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
isAAAc
Le #7800731
------=_Part_5681_31161886.1203925994349
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

bizarre, je suis moi aussi en lilnguas fr, et aucune maj à faire de ce co té
là ca matin

c'est quoi qui te demande de faire des modifs à ce niveau ? quel paquet ?

Le 25/02/08, gwenhael

Bonjour,
Je suis confronté à un problème relatif à aspell et à LINGUAS.
En faisant mes mises à jour j'ai vu apparaître un aspell-en-0.51.1
qui bloque avec aspell-0.60.5.
Je n'ai pas défini mon linguas dans make.conf à 'en' mais à 'fr'
donc il n'y a pas de raisons que ce packages vienne à s'installer.
Pour m'éviter les problèmes de version de aspell j'ai voulu installer
aspell-en-6.0.0 mais emerge me dit qu'il est masqué, eix me dit le
contraire.
Et en faisant un depclean, emerge veut me supprimer tout ce qui est en fr
(man-pages-fr et aspell-fr)
Quelqu'un sait pourquoi le système ne tiens pas compte du LINGUAS
spécifié?
Y a t'il eut un changement récent qui entraînerait ce problème ?
Merci d'avance.
Gwenhaël

-------
http://www.trabucayre.com
Arsenic et vieilles ferailles

--
mailing list





------=_Part_5681_31161886.1203925994349
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

bizarre, je suis moi aussi en lilnguas fr, et aucune maj à faire de ce co té là ca matin Bonjour, donc il n&#39;y a pas de raisons que ce packages vienne à s&#39;installe r. Et en faisant un depclean, emerge veut me supprimer tout ce qui est en fr< br> (man-pages-fr et aspell-fr)<br> Quelqu&#39;un sait pourquoi le systèm e ne tiens pas compte du LINGUAS spécifié?<br> Y a t&#39;il eut un chan gement récent qui entraînerait ce problème ?<br>
Merci d&#39;avance. <br> </blockquote></div><br>

------=_Part_5681_31161886.1203925994349--
--
mailing list
gwenhael
Le #7800721
Ben en fait je n'en sais strictement rien ...
C'est pas une mise à jour mais purement et simplement l'ajout de aspell-e n.
J'aurais tendance à en déduire que c'est soit aspell soit l'ensemble de s paquets utilisant nls.
Je me demande si d'avoir fait un emerge -e system hier n'as pas déclench é ce problème...
a+
Gwen

On Mon, 25 Feb 2008 08:53:14 +0100
isAAAc
bizarre, je suis moi aussi en lilnguas fr, et aucune maj à faire de ce coté
là ca matin

c'est quoi qui te demande de faire des modifs à ce niveau ? quel paquet ?

Le 25/02/08, gwenhael >
> Bonjour,
> Je suis confronté à un problème relatif à aspell et à LINGUAS.
> En faisant mes mises à jour j'ai vu apparaître un aspell-en-0.51.1
> qui bloque avec aspell-0.60.5.
> Je n'ai pas défini mon linguas dans make.conf à 'en' mais à 'fr'
> donc il n'y a pas de raisons que ce packages vienne à s'installer.
> Pour m'éviter les problèmes de version de aspell j'ai voulu install er
> aspell-en-6.0.0 mais emerge me dit qu'il est masqué, eix me dit le
> contraire.
> Et en faisant un depclean, emerge veut me supprimer tout ce qui est en fr
> (man-pages-fr et aspell-fr)
> Quelqu'un sait pourquoi le système ne tiens pas compte du LINGUAS
> spécifié?
> Y a t'il eut un changement récent qui entraînerait ce problème ?
> Merci d'avance.
> Gwenhaël
>
> -------
> http://www.trabucayre.com
> Arsenic et vieilles ferailles
>
> --
> mailing list
>
>




-------
http://www.trabucayre.com
Arsenic et vieilles ferailles
--
mailing list
Damien Thébault
Le #7800711
--=-BGlHplnoFk7YwOdQnE3B
Content-Type: text/plain; charset=utf-8
Content-Transfer-Encoding: quoted-printable

Le lundi 25 février 2008 à 08:23 +0100, gwenhael a écrit :
Bonjour,
Je suis confronté à un problème relatif à aspell et à LINGUAS.
En faisant mes mises à jour j'ai vu apparaître un aspell-en-0.5 1.1
qui bloque avec aspell-0.60.5.



C'est simple : dans l'ebuild de la nouvelle version de aspell (0.60*),
on voit ça :
RDEPEND="[...]
!=app-dicts/aspell-en-0.5*"
# English dictionary 0.5 is incompatible with aspell-0.6

Donc ça veut dire que tu as aspell-en-0.5* installé, et qu'il y a un
conflit avec la nouvelle version que tu veux installer.
La solution (comme souvent dans ce genre de cas là), c'est de
désinstaller le paquet qui a l'ancienne version.
Donc désinstalle aspell-en et ça devrait tout bien marcher aprà ¨s.

--
Damien Thebault

Key C15AB8AF
Fingerprint 8FB9 8576 7033 4B45 3DF5 88E8 5471 1A44 C15A B8AF

--=-BGlHplnoFk7YwOdQnE3B
Content-Type: application/pgp-signature; name=signature.asc
Content-Description: Ceci est une partie de message
=?ISO-8859-1?Q?numériquement?= =?ISO-8859-1?Q?_signée?
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.7 (GNU/Linux)

iD8DBQBHwwp8VHEaRMFauK8RApgzAJwIPunN7LOeZejez5SWnbSs+UfmMACfWztY
o7VlJtA704cN3SNi/NyaD34 =SGrG
-----END PGP SIGNATURE-----

--=-BGlHplnoFk7YwOdQnE3B--

--
mailing list
gwenhael
Le #7800701
On Mon, 25 Feb 2008 19:35:40 +0100
Damien Thébault
Le lundi 25 février 2008 à 08:23 +0100, gwenhael a écrit :
> Bonjour,
> Je suis confronté à un problème relatif à aspell et à LINGUAS.
> En faisant mes mises à jour j'ai vu apparaître un aspell-en-0.51.1
> qui bloque avec aspell-0.60.5.

C'est simple : dans l'ebuild de la nouvelle version de aspell (0.60*),
on voit ça :
RDEPEND="[...]
!=app-dicts/aspell-en-0.5*"
# English dictionary 0.5 is incompatible with aspell-0.6

Donc ça veut dire que tu as aspell-en-0.5* installé, et qu'il y a un
conflit avec la nouvelle version que tu veux installer.
La solution (comme souvent dans ce genre de cas là), c'est de
désinstaller le paquet qui a l'ancienne version.
Donc désinstalle aspell-en et ça devrait tout bien marcher après.

--
Damien Thebault

Key C15AB8AF
Fingerprint 8FB9 8576 7033 4B45 3DF5 88E8 5471 1A44 C15A B8AF


Sauf que le problème ne viens pas du fait qu'il y a un blocage mais un pa quet qui n'as strictement rien à faire sur mon ordi...
Je n'ai absolument pas besoin de aspell-en et jusqu'à ce matin il n'éta it pas installé...
a+
Gwenhaël

-------
http://www.trabucayre.com
Arsenic et vieilles ferailles
--
mailing list
gwenhael
Le #7800691
En fait j'ai à mon avis un problème avec portage qui peut-être ne rec onnait pas la variable LINGUAS dans certains cas ( ou dans tous).
Par contre je ne sais pas où chercher ni comment confirmer ou infirmer ma supposition.
Si quelqu'un a une idée je suis preneur.
Merci d'avance
Gwenhaël

On Mon, 25 Feb 2008 21:11:51 +0100
gwenhael
On Mon, 25 Feb 2008 19:35:40 +0100
Damien Thébault
> Le lundi 25 février 2008 à 08:23 +0100, gwenhael a écrit :
> > Bonjour,
> > Je suis confronté à un problème relatif à aspell et à LINGU AS.
> > En faisant mes mises à jour j'ai vu apparaître un aspell-en-0.51. 1
> > qui bloque avec aspell-0.60.5.
>
> C'est simple : dans l'ebuild de la nouvelle version de aspell (0.60*),
> on voit ça :
> RDEPEND="[...]
> !=app-dicts/aspell-en-0.5*"
> # English dictionary 0.5 is incompatible with aspell-0.6
>
> Donc ça veut dire que tu as aspell-en-0.5* installé, et qu'il y a un
> conflit avec la nouvelle version que tu veux installer.
> La solution (comme souvent dans ce genre de cas là), c'est de
> désinstaller le paquet qui a l'ancienne version.
> Donc désinstalle aspell-en et ça devrait tout bien marcher après.
>
> --
> Damien Thebault
>
> Key C15AB8AF
> Fingerprint 8FB9 8576 7033 4B45 3DF5 88E8 5471 1A44 C15A B8AF
Sauf que le problème ne viens pas du fait qu'il y a un blocage mais un paquet qui n'as strictement rien à faire sur mon ordi...
Je n'ai absolument pas besoin de aspell-en et jusqu'à ce matin il n'é tait pas installé...
a+
Gwenhaël

-------
http://www.trabucayre.com
Arsenic et vieilles ferailles
--
mailing list






-------
http://www.trabucayre.com
Arsenic et vieilles ferailles
--
mailing list
Possum
Le #7800681
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Chez moi, ça donne ça:

~ $ equery depends aspell-en
[ Searching for packages depending on aspell-en... ]
app-text/aspell-0.60.5 (!linguas_vi & !linguas_uk & !linguas_sv &
!linguas_sr & !linguas_sl & !linguas_sk & !linguas_ru & !linguas_ro &
!linguas_pt & !linguas_pl & !linguas_no & !linguas_nl & !linguas_it &
!linguas_is & !linguas_hr & !linguas_he & !linguas_gl & !linguas_ga &
!linguas_fr & !linguas_fo & !linguas_fi & !linguas_et & !linguas_es &
!linguas_eo & !linguas_en & !linguas_el & !linguas_de & !linguas_da &
!linguas_cy & !linguas_cs & !linguas_ca & !linguas_br & !linguas_bg &
!linguas_be & !linguas_af? app-dicts/aspell-en)
~ (linguas_en? app-dicts/aspell-en)
app-text/enchant-1.3.0 (virtual/aspell-dict)
kde-base/kdelibs-3.5.8-r3 (spell? >=app-dicts/aspell-en-6.0.0)

~ $ equery depends aspell
[ Searching for packages depending on aspell... ]
app-dicts/aspell-en-6.0.0 (>=app-text/aspell-0.60)
app-dicts/aspell-fr-0.60 (>=app-text/aspell-0.60)
dev-lang/php-5.2.5_p20080206-r3 (spell? >=app-text/aspell-0.50)
kde-base/kdelibs-3.5.8-r3 (spell? >=app-text/aspell-0.60.5)
mail-client/squirrelmail-1.4.13-r1 (spell? app-text/aspell)
~ $

~ $ grep LINGU /etc/make.conf
LINGUAS="fr"
~ $

Donc, je dirais que le fautif est.... kdelibs qui demande
|=app-dicts/aspell-en-6.0.0

Y'a des chances pour que ça soit pareil pour toi si tu "kdeïses"

gwenhael a écrit :
| En fait j'ai à mon avis un problème avec portage qui peut-être ne
reconnait pas la variable LINGUAS dans certains cas ( ou dans tous).
| Par contre je ne sais pas où chercher ni comment confirmer ou infirmer
ma supposition.
| Si quelqu'un a une idée je suis preneur.
| Merci d'avance
| Gwenhaël
|
| On Mon, 25 Feb 2008 21:11:51 +0100
| gwenhael |
|> On Mon, 25 Feb 2008 19:35:40 +0100
|> Damien Thébault |>
|>> Le lundi 25 février 2008 à 08:23 +0100, gwenhael a écrit :
|>>> Bonjour,
|>>> Je suis confronté à un problème relatif à aspell et à LINGUAS.
|>>> En faisant mes mises à jour j'ai vu apparaître un aspell-en-0.51.1
|>>> qui bloque avec aspell-0.60.5.
|>> C'est simple : dans l'ebuild de la nouvelle version de aspell (0.60*),
|>> on voit ça :
|>> RDEPEND="[...]
|>> !=app-dicts/aspell-en-0.5*"
|>> # English dictionary 0.5 is incompatible with aspell-0.6
|>>
|>> Donc ça veut dire que tu as aspell-en-0.5* installé, et qu'il y a un
|>> conflit avec la nouvelle version que tu veux installer.
|>> La solution (comme souvent dans ce genre de cas là), c'est de
|>> désinstaller le paquet qui a l'ancienne version.
|>> Donc désinstalle aspell-en et ça devrait tout bien marcher après.
|>>
|>> --
|>> Damien Thebault
|>>
|>> Key C15AB8AF
|>> Fingerprint 8FB9 8576 7033 4B45 3DF5 88E8 5471 1A44 C15A B8AF
|> Sauf que le problème ne viens pas du fait qu'il y a un blocage mais
un paquet qui n'as strictement rien à faire sur mon ordi...
|> Je n'ai absolument pas besoin de aspell-en et jusqu'à ce matin il
n'était pas installé...
|> a+
|> Gwenhaël
|>
|> -------
|> http://www.trabucayre.com
|> Arsenic et vieilles ferailles
|> --
|> mailing list
|>
|>
|
|
| -------
| http://www.trabucayre.com
| Arsenic et vieilles ferailles

- --
Sauvez un arbre, mangez un castor !

Ce mail est signé numériquement,
Clef publique GnuPG: http://marsupial-power.org/down/possum-gpg.asc
http://marsupial-power.org
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.7 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFHxEDs7shKAOv6mmYRAtFnAJoCckR3/BzjjLJZCdS/hY1U7Gj1KwCgiLxw
HLMtzCoasQemdygQ9ok+DWc =kwmS
-----END PGP SIGNATURE-----
--
mailing list
gwenhael
Le #7800671
Bonjour,
j'ai kdelibs en effet mais j'ai un use a -spell pour lui donc il ne va pas prendre en compte aspell-en
Non décidement je ne sais pas pkoi il veux absolument m'installer aspell- en et pourquoi il veux me supprimer aspell-fr
Gwenhael

On Tue, 26 Feb 2008 17:40:12 +0100
Possum
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Chez moi, ça donne ça:

~ $ equery depends aspell-en
[ Searching for packages depending on aspell-en... ]
app-text/aspell-0.60.5 (!linguas_vi & !linguas_uk & !linguas_sv &
!linguas_sr & !linguas_sl & !linguas_sk & !linguas_ru & !linguas_ro &
!linguas_pt & !linguas_pl & !linguas_no & !linguas_nl & !linguas_it &
!linguas_is & !linguas_hr & !linguas_he & !linguas_gl & !linguas_ga &
!linguas_fr & !linguas_fo & !linguas_fi & !linguas_et & !linguas_es &
!linguas_eo & !linguas_en & !linguas_el & !linguas_de & !linguas_da &
!linguas_cy & !linguas_cs & !linguas_ca & !linguas_br & !linguas_bg &
!linguas_be & !linguas_af? app-dicts/aspell-en)
~ (linguas_en? app-dicts/aspell-en)
app-text/enchant-1.3.0 (virtual/aspell-dict)
kde-base/kdelibs-3.5.8-r3 (spell? >=app-dicts/aspell-en-6.0.0)

~ $ equery depends aspell
[ Searching for packages depending on aspell... ]
app-dicts/aspell-en-6.0.0 (>=app-text/aspell-0.60)
app-dicts/aspell-fr-0.60 (>=app-text/aspell-0.60)
dev-lang/php-5.2.5_p20080206-r3 (spell? >=app-text/aspell-0.50)
kde-base/kdelibs-3.5.8-r3 (spell? >=app-text/aspell-0.60.5)
mail-client/squirrelmail-1.4.13-r1 (spell? app-text/aspell)
~ $

~ $ grep LINGU /etc/make.conf
LINGUAS="fr"
~ $

Donc, je dirais que le fautif est.... kdelibs qui demande
|=app-dicts/aspell-en-6.0.0

Y'a des chances pour que ça soit pareil pour toi si tu "kdeïses"

gwenhael a écrit :
| En fait j'ai à mon avis un problème avec portage qui peut-être ne
reconnait pas la variable LINGUAS dans certains cas ( ou dans tous).
| Par contre je ne sais pas où chercher ni comment confirmer ou infirmer
ma supposition.
| Si quelqu'un a une idée je suis preneur.
| Merci d'avance
| Gwenhaël
|
| On Mon, 25 Feb 2008 21:11:51 +0100
| gwenhael |
|> On Mon, 25 Feb 2008 19:35:40 +0100
|> Damien Thébault |>
|>> Le lundi 25 février 2008 à 08:23 +0100, gwenhael a écrit :
|>>> Bonjour,
|>>> Je suis confronté à un problème relatif à aspell et à LING UAS.
|>>> En faisant mes mises à jour j'ai vu apparaître un aspell-en-0.51 .1
|>>> qui bloque avec aspell-0.60.5.
|>> C'est simple : dans l'ebuild de la nouvelle version de aspell (0.60*),
|>> on voit ça :
|>> RDEPEND="[...]
|>> !=app-dicts/aspell-en-0.5*"
|>> # English dictionary 0.5 is incompatible with aspell-0.6
|>>
|>> Donc ça veut dire que tu as aspell-en-0.5* installé, et qu'il y a un
|>> conflit avec la nouvelle version que tu veux installer.
|>> La solution (comme souvent dans ce genre de cas là), c'est de
|>> désinstaller le paquet qui a l'ancienne version.
|>> Donc désinstalle aspell-en et ça devrait tout bien marcher aprè s.
|>>
|>> --
|>> Damien Thebault
|>>
|>> Key C15AB8AF
|>> Fingerprint 8FB9 8576 7033 4B45 3DF5 88E8 5471 1A44 C15A B8AF
|> Sauf que le problème ne viens pas du fait qu'il y a un blocage mais
un paquet qui n'as strictement rien à faire sur mon ordi...
|> Je n'ai absolument pas besoin de aspell-en et jusqu'à ce matin il
n'était pas installé...
|> a+
|> Gwenhaël
|>
|> -------
|> http://www.trabucayre.com
|> Arsenic et vieilles ferailles
|> --
|> mailing list
|>
|>
|
|
| -------
| http://www.trabucayre.com
| Arsenic et vieilles ferailles

- --
Sauvez un arbre, mangez un castor !

Ce mail est signé numériquement,
Clef publique GnuPG: http://marsupial-power.org/down/possum-gpg.asc
http://marsupial-power.org
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.7 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFHxEDs7shKAOv6mmYRAtFnAJoCckR3/BzjjLJZCdS/hY1U7Gj1KwCgiLxw
HLMtzCoasQemdygQ9ok+DWc=
=kwmS
-----END PGP SIGNATURE-----
--
mailing list






-------
http://www.trabucayre.com
Arsenic et vieilles ferailles
--
mailing list
Possum
Le #7800661
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Et le resultat d'un equery depends aspell-en, ça donne quoi chez toi ?

gwenhael a écrit :
| Bonjour,
| j'ai kdelibs en effet mais j'ai un use a -spell pour lui donc il ne va
pas prendre en compte aspell-en
| Non décidement je ne sais pas pkoi il veux absolument m'installer
aspell-en et pourquoi il veux me supprimer aspell-fr
| Gwenhael
|

<couik>

- --
Sauvez un arbre, mangez un castor !

Ce mail est signé numériquement,
Clef publique GnuPG: http://marsupial-power.org/down/possum-gpg.asc
http://marsupial-power.org
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.7 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFHxGFo7shKAOv6mmYRAjSBAKCcFOMBco/MW6GmhqDUj7gN6a6fRgCfY7+q
jO8isqyWDd7XDT7iDFpYnEM =OLBY
-----END PGP SIGNATURE-----
--
mailing list
gwenhael
Le #7800651
Ca donne
app-text/aspell-0.60.5 (!linguas_vi & !linguas_uk & !linguas_sv & !linguas_ sr & !linguas_sl & !linguas_sk & !linguas_ru & !linguas_ro & !linguas_pt & !linguas_pl & !linguas_no & !linguas_nl & !linguas_it & !linguas_is & !ling uas_hr & !linguas_he & !linguas_gl & !linguas_ga & !linguas_fr & !linguas_f o & !linguas_fi & !linguas_et & !linguas_es & !linguas_eo & !linguas_en & ! linguas_el & !linguas_de & !linguas_da & !linguas_cy & !linguas_cs & !lingu as_ca & !linguas_br & !linguas_bg & !linguas_be & !linguas_af? app-dicts/as pell-en)
(linguas_en? app-dicts/aspell-en)
app-text/enchant-1.3.0 (virtual/aspell-dict)
kde-base/kdelibs-3.5.8-r3 (spell? >=app-dicts/aspell-en-6.0.0)
mail-client/claws-mail-3.0.2-r1 (spell? virtual/aspell-dict)

mais pourquoi le '!' devant linguas_fr dans aspell ?
a+ Gwen

On Tue, 26 Feb 2008 19:58:48 +0100
Possum
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Et le resultat d'un equery depends aspell-en, ça donne quoi chez toi ?

gwenhael a écrit :
| Bonjour,
| j'ai kdelibs en effet mais j'ai un use a -spell pour lui donc il ne va
pas prendre en compte aspell-en
| Non décidement je ne sais pas pkoi il veux absolument m'installer
aspell-en et pourquoi il veux me supprimer aspell-fr
| Gwenhael
|

<couik>

- --
Sauvez un arbre, mangez un castor !

Ce mail est signé numériquement,
Clef publique GnuPG: http://marsupial-power.org/down/possum-gpg.asc
http://marsupial-power.org
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.7 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFHxGFo7shKAOv6mmYRAjSBAKCcFOMBco/MW6GmhqDUj7gN6a6fRgCfY7+q
jO8isqyWDd7XDT7iDFpYnEM=
=OLBY
-----END PGP SIGNATURE-----
--
mailing list






-------
http://www.trabucayre.com
Arsenic et vieilles ferailles
--
mailing list
Possum
Le #7800641
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

J'ai la réponse !!

vi /usr/portage/app-text/aspell/aspell-0.60.5.ebuild

# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header:
/var/cvsroot/gentoo-x86/app-text/aspell/aspell-0.60.5.ebuild,v 1.18
2008/01/26 18:49:16 philantrop Exp $

# N.B. This is before inherit of autotools, as autotools.eclass adds the
# relevant dependencies to DEPEND.
WANT_AUTOMAKE="1.10"

inherit libtool eutils flag-o-matic autotools

DESCRIPTION="A spell checker replacement for ispell"
HOMEPAGE="http://aspell.net/"
SRC_URI="mirror://gnu/aspell/${P}.tar.gz"

LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc
~sparc-fbsd x86 ~x86-fbsd"
IUSE="gpm nls examples"
# Note; app-text/aspell-0.6 and app-dicts/aspell-en-0.6 must go stable
together

# Build PDEPEND from list of language codes provided in the tree.
# The PDEPEND string is static - this code just makes it easier to mainta in.
def="app-dicts/aspell-en"
for l in
~ "af" "be" "bg" "br" "ca" "cs" "cy" "da" "de" "el"
~ "en" "eo" "es" "et" "fi" "fo" "fr" "ga" "gl" "he"
~ "hr" "is" "it" "nl" "no" "pl" "pt" "ro" "ru" "sk"
~ "sl" "sr" "sv" "uk" "vi"; do
~ dep="linguas_${l}? ( app-dicts/aspell-${l} )"
~ [[ -z ${PDEPEND} ]] &&
~ PDEPEND="${dep}" ||
~ PDEPEND="${PDEPEND}
${dep}"
~ def="!linguas_${l}? ( ${def} )"
done
PDEPEND="${PDEPEND}
${def}"

On a donc une dépendance directe de aspell-en + si la variable LINGU AS
est définie:

def="app-dicts/aspell-en" et plus loin def="!linguas_${l}? ( ${def} ) "

Voilà donc le pourquoi du comment.

Maintenant, aspell-en, l'est pas gros hein comme package ;)

Mais je comprends que ça te fasse raler vu que c'est un truc dont tu
veux pas forcément.


gwenhael a écrit :
| Ca donne
| app-text/aspell-0.60.5 (!linguas_vi & !linguas_uk & !linguas_sv &
!linguas_sr & !linguas_sl & !linguas_sk & !linguas_ru & !linguas_ro &
!linguas_pt & !linguas_pl & !linguas_no & !linguas_nl & !linguas_it &
!linguas_is & !linguas_hr & !linguas_he & !linguas_gl & !linguas_ga &
!linguas_fr & !linguas_fo & !linguas_fi & !linguas_et & !linguas_es &
!linguas_eo & !linguas_en & !linguas_el & !linguas_de & !linguas_da &
!linguas_cy & !linguas_cs & !linguas_ca & !linguas_br & !linguas_bg &
!linguas_be & !linguas_af? app-dicts/aspell-en)
| (linguas_en? app-dicts/aspell-en)
| app-text/enchant-1.3.0 (virtual/aspell-dict)
| kde-base/kdelibs-3.5.8-r3 (spell? >=app-dicts/aspell-en-6.0.0)
| mail-client/claws-mail-3.0.2-r1 (spell? virtual/aspell-dict)
|
| mais pourquoi le '!' devant linguas_fr dans aspell ?
| a+ Gwen
|
| On Tue, 26 Feb 2008 19:58:48 +0100
| Possum |
| Et le resultat d'un equery depends aspell-en, ça donne quoi chez t oi ?
|
| gwenhael a écrit :
| | Bonjour,
| | j'ai kdelibs en effet mais j'ai un use a -spell pour lui donc il ne v a
| pas prendre en compte aspell-en
| | Non décidement je ne sais pas pkoi il veux absolument m'installe r
| aspell-en et pourquoi il veux me supprimer aspell-fr
| | Gwenhael
| |
|
| <couik>
|
- --
mailing list
|>
|>

| -------
| http://www.trabucayre.com
| Arsenic et vieilles ferailles

- --
Sauvez un arbre, mangez un castor !

Ce mail est signé numériquement,
Clef publique GnuPG: http://marsupial-power.org/down/possum-gpg.asc
http://marsupial-power.org
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.7 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFHxHnX7shKAOv6mmYRAmEXAJ9D+Fzkfk35nhSv1qWR+8YuVl+fiACfUFe/
OcNqid6d/o5LEKmOyirfuWc=
=JSdE
-----END PGP SIGNATURE-----

--
mailing list
Publicité
Poster une réponse
Anonyme