[gentoo-user-fr] ati-drivers-8.35.5 ne se compile plus (gentoo 64bits)

Le
M. ROPA
Bonjour

suite à une mise à jour datant du 31/07 je n'arrive plus
à compiler ati-drivers-8.35.5

Depuis 15 jours, j'ai tout essayé : bugzilla, binutils-config,
emerge -ev system (aucun soucis) puis emerge -ev world avec
des erreurs analogues de compilation sur différents paquets
(/usr/lib/gcc/x86_64-pc-linux-gnu/4.1.2/../../../../x86_64-pc-linux-gnu/bin/ld:
warning: libstdc++.so.6, needed by .)

Voici ce que j'obtiens lors d'un emerge de ati-drivers :

* Building fgl_glxgears
/usr/lib/gcc/x86_64-pc-linux-gnu/4.1.2/../../../../x86_64-pc-linux-gnu/bin/ld:
warning: libstdc++.so.6, needed by
/usr/lib/gcc/x86_64-pc-linux-gnu/4.1.2/../../../../lib64/libGLU.so, not
found (try using -rpath or -rpath-link)
/usr/lib/gcc/x86_64-pc-linux-gnu/4.1.2/../../../../lib64/libGLU.so:
référence indéfinie vers « operator delete(void*)@GLIBCXX_3.4 »
/usr/lib/gcc/x86_64-pc-linux-gnu/4.1.2/../../../../lib64/libGLU.so:
référence indéfinie vers « vtable for
__cxxabiv1::__vmi_class_type_info@CXXABI_1.3 »
/usr/lib/gcc/x86_64-pc-linux-gnu/4.1.2/../../../../lib64/libGLU.so:
référence indéfinie vers « operator delete[](void*)@GLIBCXX_3.4 »
/usr/lib/gcc/x86_64-pc-linux-gnu/4.1.2/../../../../lib64/libGLU.so:
référence indéfinie vers « __cxa_pure_virtual@CXXABI_1.3 »
/usr/lib/gcc/x86_64-pc-linux-gnu/4.1.2/../../../../lib64/libGLU.so:
référence indéfinie vers « vtable for
__cxxabiv1::__si_class_type_info@CXXABI_1.3 »
/usr/lib/gcc/x86_64-pc-linux-gnu/4.1.2/../../../../lib64/libGLU.so:
référence indéfinie vers « vtable for
__cxxabiv1::__class_type_info@CXXABI_1.3 »
/usr/lib/gcc/x86_64-pc-linux-gnu/4.1.2/../../../../lib64/libGLU.so:
référence indéfinie vers « operator new[](unsigned long)@GLIBCXX_3.4 »
/usr/lib/gcc/x86_64-pc-linux-gnu/4.1.2/../../../../lib64/libGLU.so:
référence indéfinie vers « __gxx_personality_v0@CXXABI_1.3 »
/usr/lib/gcc/x86_64-pc-linux-gnu/4.1.2/../../../../lib64/libGLU.so:
référence indéfinie vers « operator new(unsigned long)@GLIBCXX_3.4 »
collect2: ld a retourné 1 code d'état d'exécution

!!! ERROR: x11-drivers/ati-drivers-8.35.5 failed.
Call stack:
ebuild.sh, line 1632: Called dyn_compile
ebuild.sh, line 983: Called qa_call 'src_compile'
ebuild.sh, line 44: Called src_compile
ati-drivers-8.35.5.ebuild, line 182: Called die

!!! fgl_glxgears build failed
!!! If you need support, post the topmost build error, and the call
stack if relevant.
!!! A complete build log is located at
'/var/log/portage/x11-drivers:ati-drivers-8.35.5:20070814-134104.log'.


Je soupçonne un problème du coté de binutils
mais je ne sais plus quoi tenter.

A l'aide


--
gentoo-user-fr@gentoo.org mailing list
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Guillaume Pujol
Le #7802721
Le 14/08/07, M. ROPA
Bonjour



Bonjour,

suite à une mise à jour datant du 31/07 je n'arrive plus
à compiler ati-drivers-8.35.5



et quels paquets ont été mis à jour le 31/07 ? pour le savoir, utilis e
par exemple 'genlop -l' (du paquet 'genlop').
Sinon, t'as essayé la version ~amd64 du driver ?
--
mailing list
M. ROPA
Le #7802701
Guillaume Pujol a écrit :
Le 14/08/07, M. ROPA
Bonjour




Bonjour,


suite à une mise à jour datant du 31/07 je n'arrive plus
à compiler ati-drivers-8.35.5




et quels paquets ont été mis à jour le 31/07 ? pour le savoir, utilise
par exemple 'genlop -l' (du paquet 'genlop').
Sinon, t'as essayé la version ~amd64 du driver ?



J'ai essayé la version ~amd64 sans aucun succès.



Les mises à jour effectuées :

jui 31 10:26 dev-util:unifdef-1.20:20070731-082620.log
jui 31 10:28 sys-apps:busybox-1.5.1:20070731-082636.log
jui 31 10:31 app-emacs:mule-ucs-0.85_rc3:20070731-082845.log
jui 31 10:31 sys-apps:hdparm-7.6:20070731-083137.log
jui 31 10:32 app-arch:cabextract-1.2:20070731-083145.log
jui 31 10:33 sys-kernel:linux-headers-2.6.21:20070731-083205.log
jui 31 10:37 sys-libs:ncurses-5.6-r1:20070731-083308.log
jui 31 10:39 app-shells:bash-3.2_p17:20070731-083820.log
jui 31 10:40 media-fonts:cronyx-fonts-2.3.1-r2:20070731-084028.log
jui 31 10:40 media-fonts:cronyx-fonts-2.3.1-r2:20070731-084031.log
jui 31 10:40 sys-apps:man-pages-2.62:20070731-083953.log
jui 31 10:42 www-client:mozilla-firefox-bin-2.0.0.5:20070731-084038.log
jui 31 10:46 sys-devel:gettext-0.16.1:20070731-084210.log
jui 31 10:46 sys-devel:gettext-0.16.1:20070731-084654.log
jui 31 10:47 sys-apps:sed-4.1.5:20070731-084700.log
jui 31 10:48 dev-lang:yasm-0.6.0:20070731-084727.log
jui 31 10:48 net-misc:rsync-2.6.9-r2:20070731-084814.log
jui 31 10:49 sys-process:lsof-4.78:20070731-084858.log
jui 31 10:50 sys-fs:udev-104-r13:20070731-085018.log
jui 31 10:50 sys-libs:readline-5.2_p4:20070731-084918.log
jui 31 11:45 sys-libs:glibc-2.5-r4:20070731-085048.log
jui 31 11:48 app-arch:rar-3.7.0:20070731-094846.log
jui 31 11:48 dev-libs:glib-2.12.12:20070731-094607.log
jui 31 11:49 dev-libs:atk-1.12.4:20070731-094956.log
jui 31 11:49 dev-libs:atk-1.18.0:20070731-094858.log
jui 31 11:51 sys-apps:dbus-1.0.2-r2:20070731-095000.log
jui 31 11:57 app-crypt:mit-krb5-1.5.3:20070731-095113.log
jui 31 11:57 media-libs:xvid-1.1.3:20070731-095708.log
jui 31 11:58 net-libs:libpcap-0.9.5:20070731-095754.log
jui 31 12:02 app-antivirus:clamav-0.91:20070731-095819.log
jui 31 12:02 dev-perl:Net-DNS-0.60:20070731-100207.log
jui 31 12:02 sys-apps:ivman-0.6.14:20070731-100220.log
jui 31 12:04 x11-libs:pango-1.14.10:20070731-100450.log
jui 31 12:04 x11-libs:pango-1.16.4:20070731-100245.log
jui 31 12:05 dev-python:pycairo-1.4.0:20070731-100544.log
jui 31 12:05 sys-apps:file-4.21:20070731-100538.log
jui 31 12:05 sys-apps:file-4.21-r1:20070731-100502.log
jui 31 12:06 dev-python:pycrypto-2.0.1-r5:20070731-100613.log
jui 31 12:06 dev-python:pycrypto-2.0.1-r6:20070731-100558.log
jui 31 12:12 dev-java:sun-jdk-1.5.0.11:20070731-101247.log
jui 31 12:12 dev-java:sun-jdk-1.5.0.12:20070731-100616.log
jui 31 12:22 app-emulation:emul-linux-x86-java-1.6.0.01:20070731-102234.log
jui 31 12:22 app-emulation:emul-linux-x86-java-1.6.0.02:20070731-101256.log
jui 31 12:23 net-www:netscape-flash-9.0.48.0-r1:20070731-102244.log
jui 31 12:34 x11-libs:gtk+-2.10.13:20070731-102316.log
jui 31 12:35 media-gfx:dcraw-8.73:20070731-103455.log
jui 31 12:37 net-dialup:ppp-2.4.4-r9:20070731-103709.log
jui 31 12:37 net-misc:curl-7.15.5-r1:20070731-103509.log
jui 31 12:38 x11-misc:notification-daemon-0.3.6-r1:20070731-103840.log
jui 31 12:38 x11-misc:notification-daemon-0.3.7:20070731-103748.log
jui 31 12:45 app-text:ghostscript-esp-8.15.3:20070731-103846.log
jui 31 12:45 x11-libs:libnotify-0.4.4:20070731-104508.log
jui 31 12:46 xfce-base:xfce-mcs-plugins-4.4.1:20070731-104653.log
jui 31 12:46 xfce-base:xfce-mcs-plugins-4.4.1-r1:20070731-104557.log
jui 31 12:47 xfce-extra:terminal-0.2.6_p25931:20070731-104658.log
jui 31 13:29 media-libs:sdl-net-1.2.6:20070731-112916.log
jui 31 13:36 dev-util:subversion-1.3.2-r4:20070731-112942.log
jui 31 13:36 dev-util:subversion-1.3.2-r4:20070731-113643.log
jui 31 13:37 app-emacs:auctex-11.84-r1:20070731-113704.log
jui 31 13:37 app-emacs:auctex-11.84-r1:20070731-113720.log
jui 31 13:37 app-emacs:php-mode-1.1.0:20070731-113723.log
jui 31 13:37 app-emacs:php-mode-1.1.0:20070731-113727.log
jui 31 13:37 app-emacs:pymacs-0.22-r1:20070731-113653.log
jui 31 13:37 app-emacs:pymacs-0.22-r1:20070731-113701.log
jui 31 13:54 media-gfx:gimp-2.2.14:20070731-115449.log
jui 31 13:54 media-gfx:gimp-2.2.16:20070731-113728.log
jui 31 13:55 app-emacs:python-mode-1.0:20070731-115454.log
jui 31 13:55 app-emacs:python-mode-1.0:20070731-115510.log
jui 31 14:35 www-client:mozilla-firefox-2.0.0.5:20070731-115518.log
jui 31 14:37 gnome-extra:gnome-screensaver-2.16.2:20070731-123753.log
jui 31 14:37 gnome-extra:gnome-screensaver-2.16.2-r1:20070731-123559.log
jui 31 15:15 mail-client:mozilla-thunderbird-2.0.0.5:20070731-123757.log
jui 31 15:21 x11-plugins:enigmail-0.95.1:20070731-131637.log
jui 31 15:26 gnome-base:gnome-applets-2.16.2:20070731-132644.log
jui 31 15:26 gnome-base:gnome-applets-2.16.2-r1:20070731-132149.log
jui 31 15:27 app-cdr:gnomebaker-0.5.1-r2:20070731-132744.log
jui 31 15:27 app-cdr:gnomebaker-0.6.1-r2:20070731-132655.log


Jean-Philippe


--
mailing list
Thierry Volpiatto
Le #7802691
Bonjour,
as tu essayé de lançer un revdep-rebuild à la suite de ta mise à jo ur ?
--
A bientot
Thierry
PS:You can find my pubkey here:
http://pgp.mit.edu/
--
mailing list
Thierry Volpiatto
Le #7802671
Desolé j'utilise nvidia
Essayes peut être avec un autre kernel (la version en dessous de la tienn e)
--
A +
Thierry
PS:You can find my pubkey here:
http://pgp.mit.edu/
--
mailing list
M. ROPA
Le #7802681
Thierry Volpiatto a écrit :
Bonjour,
as tu essayé de lançer un revdep-rebuild à la suite de ta mise à jour ?



Oui, j'ai même essayé de tout recompiler.

emerge -ev system passe sans problème par contre
emerge -ev world bloque sur un tas de paquets :
libmcs, ftgl, mesa-progs, libquicktime, gtkglarea, ....


Bref, je ne comprends plus rien.
J'aimerais savoir si c'est mon système ou bien
une erreur de dépendance qui se corrigera, je l'espère,
lors d'une prochaine mise à jour.

Si l'un d'entre vous utilise le driver ati-driver-8.35.5
avec une gentoo 64bits à jour, peut-il essayer de le recompiler
histoire de voir si ça passe.

Jean-Philippe

--
mailing list
M. ROPA
Le #7802661
M. ROPA a écrit :
Thierry Volpiatto a écrit :

Bonjour,
as tu essayé de lançer un revdep-rebuild à la suite de ta mise à jour ?




Oui, j'ai même essayé de tout recompiler.

emerge -ev system passe sans problème par contre
emerge -ev world bloque sur un tas de paquets :
libmcs, ftgl, mesa-progs, libquicktime, gtkglarea, ....


Bref, je ne comprends plus rien.
J'aimerais savoir si c'est mon système ou bien
une erreur de dépendance qui se corrigera, je l'espère,
lors d'une prochaine mise à jour.

Si l'un d'entre vous utilise le driver ati-driver-8.35.5
avec une gentoo 64bits à jour, peut-il essayer de le recompiler
histoire de voir si ça passe.

Jean-Philippe





Pour compiler ati-drivers, j'ai du downgrader à sys-devel/binutils-2.16.1-r3
au lieu de sys-devel/binutils-2.17 (stable), installer
x11-libs/libXinerama qui
ne faisait pas parti des dépendances de ati-drivers et redescendre vers le
noyau linux-2.6.20-gentoo-r8

Le fait d'utiliser sys-devel/binutils-2.16.1-r3 m'a permis aussi de
compiler :
libmcs, ftgl, mesa-progs, libquicktime, gtkglarea,
qui ne passaient pas avec sys-devel/binutils-2.17
lors d'un 'emerge -ev world'

Bref, j'ai l'impression qu'au mois d'août, il ne faut pas faire
de mise à jour : vive les vacances ;-)

Jean-Philippe ROPA








--
mailing list
Publicité
Poster une réponse
Anonyme