[gentoo-user-fr] emerge -uD world et libsdl et sdl-sound

Le
Doug Le Tough
Bonjour à toutes, tous

Je suis en train de mettre à jour ma gentoo (64bits) via emerge -uD world=
et
je suis confronté au problème suivant:

Lors de la mise à jour des paquets liés à SDL (sdl-sound, sdl-image,
sdl-ttf) emerge s'arrete en pretextant qu'il ne trouve pas la bonne
version de libsdl.

-*-*-*-*-*-*-*-*-*-*-*-*-
Checking for sdl-config /usr/bin/sdl-config
Checking for SDL - version >= 1.2.10 no

et tout le blahblah sur LD_LIBRARY_PATH et /etc/ld.so.conf
-*-*-*-*-*-*-*-*-*-*-*-*-

Or, libsdl-1.2.11-r2 est installé.
sdl-config --version me renvoie bien la bonne version (1.2.11).
J'ai bien pensé à un problème de libray_path et j'ai donc ajusté la=
variable
sur /usr/lib64 puis sur /usr/lib32 mais j'ai toujours la même erreur.

J'ai vérifié /etc/ld.so.conf, tout semble normal (/usr/lib64 et /usr/li=
b32
s'y trouvent).

Le fichier /usr/lib64/pkgconfig/sdl.pc existe et semble ok.

J'ai également essayé en ajustant PKG_CONFIG_PATH.

J'ai totalement supprimé ces paquets afin de les réinstaller 1 par 1 ma=
is le
resultat est le même.

La lecture du fichier de log pour chacun des paquets concernés ne m'a gu=
ère
éclairé.

J'ai même essayé sans le paquet emul-linux-x86-sdl en me disant qu'un
conflit de version pouvait être à l'origine de ce problème mais sans
succès.

Info complémentaire :

Pour preuve que libsdl est correctement installée, les applications
nécessitant lbsdl seule fonctionnent !

Serait-ce donc là un problème de détection de version dans le configu=
re ?


Mes humbles connaissances ne me permettent pas de m'en sortir.

Merci de votre aide et autres conseils avisés.

J'avais longuement hésité avant de me lancer dans la mise à jour de ce
système, pas assez finalement ;-)

--
@+
Doug [Linux user #307925]
[Pourquoi t'es qui, qu'est ce que tu fais par où ?]
[Plus ou moins avec une chance de peut-être]

--
gentoo-user-fr@gentoo.org mailing list
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Yoann Pannier
Le #7802751
Doug Le Tough wrote, On 2007-08-14 00:39:
Lors de la mise à jour des paquets liés à SDL (sdl-sound, sdl-image,
sdl-ttf...) emerge s'arrete en pretextant qu'il ne trouve pas la bonne
version de libsdl.



Checking for SDL - version >= 1.2.10... no



revdep-rebuild ?

--
Yoann Pannier
--
mailing list
Doug Le Tough
Le #7802731
Le mardi 14 août 2007 12:29, Yoann Pannier a écrit :
Doug Le Tough wrote, On 2007-08-14 00:39:
> Lors de la mise à jour des paquets liés à SDL (sdl-sound , sdl-image,
> sdl-ttf...) emerge s'arrete en pretextant qu'il ne trouve pas la bonne
> version de libsdl.
>
> Checking for SDL - version >= 1.2.10... no

revdep-rebuild ?



Même pas, j'avais déjà essayé.

Le problème est un lien manquant entre /usr/lib64/libgg.so.1.0.0
et /usr/lib64/libgg.so.0

Le problème est donc résolu (Merci à Sebastien Mombrun qui m 'a répondu sur
fr.comp.os.linux.configuration)

--
@+
Doug [Linux user #307925]
[Pourquoi t'es qui, qu'est ce que tu fais par où ?]
[Plus ou moins avec une chance de peut-être]

--
mailing list
Publicité
Poster une réponse
Anonyme