[gentoo-user-fr] flash 9 = segmentation fault

Le
Pascal Ronecker
Salut a tous,

j'avais déjà posté ce problème amusant y a quelques temps, à la sortie
de flash 9.
Certains sites ne fonctionnant plus qu'avec icelui, me voici bien mal mis.

Je résume :
je prends sur le site à daube la dernière version,
je mets libflashplayer.so et flashplayer.xpt dans /opt/netscape/plugins
(j'ai un lien symbo depuis le repertoire de firefox qui pointe là dessus)

prochain redémarrage, dès que j'arrive sur une page avec du flash : bim,
seg fault.


Une idée ?

une piste : il s'agit d'une très vieille machine, trèèèès mal à jour
concernant gcc notamment . ca peut jouer ?
--
gentoo-user-fr@gentoo.org mailing list
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Bruno PINAUD
Le #7801931
Le Thursday 08 November 2007 08:31:59 Pascal Ronecker, vous avez écrit :
Salut a tous,

j'avais déjà posté ce problème amusant y a quelques temps, à la sortie
de flash 9.
Certains sites ne fonctionnant plus qu'avec icelui, me voici bien mal mis.

Je résume :
je prends sur le site à daube la dernière version,
je mets libflashplayer.so et flashplayer.xpt dans /opt/netscape/plugins
(j'ai un lien symbo depuis le repertoire de firefox qui pointe là dessu s)

prochain redémarrage, dès que j'arrive sur une page avec du flash : b im,
seg fault.


Une idée ?

une piste : il s'agit d'une très vieille machine, trèèèès mal à jour
concernant gcc notamment .... ca peut jouer ?



Salut,
Tout à fait, ça peut jouer. C'est pas tellement gcc qui va poser probl èmes
mais binutils et peut-être la libc. Pourquoi ne pas faire un emerge de
flash ? Ca évite bien des problèmes....

--
Bruno
--
mailing list
Pascal Ronecker
Le #7801921
Bruno PINAUD wrote:
Le Thursday 08 November 2007 08:31:59 Pascal Ronecker, vous avez écrit :

Salut a tous,

j'avais déjà posté ce problème amusant y a quelques temps, à la sortie
de flash 9.
Certains sites ne fonctionnant plus qu'avec icelui, me voici bien mal mis.

Je résume :
je prends sur le site à daube la dernière version,
je mets libflashplayer.so et flashplayer.xpt dans /opt/netscape/plugins
(j'ai un lien symbo depuis le repertoire de firefox qui pointe là dessus)

prochain redémarrage, dès que j'arrive sur une page avec du flash : bim,
seg fault.


Une idée ?

une piste : il s'agit d'une très vieille machine, trèèèès mal à jour
concernant gcc notamment .... ca peut jouer ?




Salut,
Tout à fait, ça peut jouer. C'est pas tellement gcc qui va poser problèmes
mais binutils et peut-être la libc. Pourquoi ne pas faire un emerge de
flash ? Ca évite bien des problèmes....




c'est en principe vrai, mais pour ce paquet là, à part télécharger le
tar.gz sur le site de l'éditeur et te l'installer là où je l'ai mis,
l'ebuild ne fait rien de plus.
(j'ai testé, avec le même résultat)

Ca fait *vraiment* longtemps que ce desktop "dort" et manque de mises a
jour, genre un an, et encore c'était déjà fait en trainant la patte.
Je me demande si c'est sans espoir, j'ai encore les packages suivants
d'installés :


gcc
Latest version available: 4.2.2
Latest version installed: 3.3.2-r5


glibc
Latest version available: 2.7
Latest version installed: 2.3.5-r2



dans le genre "je me suis bien mis dans la mouise", jh'éiste à tenter
des mises à jour là ...

--
mailing list
Pascal Ronecker
Le #7801911
Didier Link wrote:
Le Thu, 08 Nov 2007 10:21:59 +0100,
Pascal Ronecker

Salut,

>>> Salut,
>>> Tout à fait, ça peut jouer. C'est pas tellement gcc qui va poser
>>> problèmes mais binutils et peut-être la libc. Pourquoi ne pas faire
>>> un emerge de flash ? Ca évite bien des problèmes....
>>>
>>>
>> c'est en principe vrai, mais pour ce paquet là, à part télécharger le
>> tar.gz sur le site de l'éditeur et te l'installer là où je l'ai mis,
>> l'ebuild ne fait rien de plus.
>> (j'ai testé, avec le même résultat)

On va dire que c'est plus propre de cette manière, Gentoo y retrouve
ces petits au moins ;)

>> Ca fait *vraiment* longtemps que ce desktop "dort" et manque de mises
>> a jour, genre un an, et encore c'était déjà fait en trainant la patte.
>> Je me demande si c'est sans espoir, j'ai encore les packages suivants
>> d'installés :
>>
>>
>> gcc
>> Latest version available: 4.2.2
>> Latest version installed: 3.3.2-r5
>>
>>
>> glibc
>> Latest version available: 2.7
>> Latest version installed: 2.3.5-r2
>>
>>
>>
>> dans le genre "je me suis bien mis dans la mouise", jh'éiste à tenter
>> des mises à jour là ...
>>

Et ta version de firefox si c'est pas indiscret ?? ;)

Pour ma part j'avais eu ce soucis il y a longtemps (justement :)) et ça
c'est réglé avec les versions récentes de firefox et du plugin flash
version beta 9

Je crois que tu vas devoir tenter une mise à jour ou te passer du
flash, désolé ...

Bon courage !

Didier

����z����+�f��)�+-



j'avais un firefox 2.0.0.3 mais la tpoute dernière donne le même
résultat. (ceci étant dit, je suis un abruti de ne pas avoir commencé
par là de toute façon)

gcc 3.3->3.4 est en cours, je procède par étapes ...
--
mailing list
Pascal Ronecker
Le #7801901
Pascal Ronecker wrote:
Didier Link wrote:

Le Thu, 08 Nov 2007 10:21:59 +0100,
Pascal Ronecker

Salut,


Salut,
Tout à fait, ça peut jouer. C'est pas tellement gcc qui va poser
problèmes mais binutils et peut-être la libc. Pourquoi ne pas faire
un emerge de flash ? Ca évite bien des problèmes....





c'est en principe vrai, mais pour ce paquet là, à part télécharger le
tar.gz sur le site de l'éditeur et te l'installer là où je l'ai mis,
l'ebuild ne fait rien de plus.
(j'ai testé, avec le même résultat)





On va dire que c'est plus propre de cette manière, Gentoo y retrouve
ces petits au moins ;)


Ca fait *vraiment* longtemps que ce desktop "dort" et manque de mises
a jour, genre un an, et encore c'était déjà fait en trainant la patte.
Je me demande si c'est sans espoir, j'ai encore les packages suivants
d'installés :


gcc
Latest version available: 4.2.2
Latest version installed: 3.3.2-r5


glibc
Latest version available: 2.7
Latest version installed: 2.3.5-r2



dans le genre "je me suis bien mis dans la mouise", jh'éiste à tenter
des mises à jour là ...






Et ta version de firefox si c'est pas indiscret ?? ;)

Pour ma part j'avais eu ce soucis il y a longtemps (justement :)) et ça
c'est réglé avec les versions récentes de firefox et du plugin flash
version beta 9

Je crois que tu vas devoir tenter une mise à jour ou te passer du
flash, désolé ...

Bon courage !

Didier

����z����+�f��)�+-




j'avais un firefox 2.0.0.3 mais la tpoute dernière donne le même
résultat. (ceci étant dit, je suis un abruti de ne pas avoir commencé
par là de toute façon)

gcc 3.3->3.4 est en cours, je procède par étapes ...



et quand je vois ce que me sors revdep-rebuild ca fait peur ........ a
demain si la recompile est finie :-)

--
mailing list
Pascal Ronecker
Le #7801881
Pascal Ronecker wrote:
Pascal Ronecker wrote:

Didier Link wrote:


Le Thu, 08 Nov 2007 10:21:59 +0100,
Pascal Ronecker

Salut,



Salut,
Tout à fait, ça peut jouer. C'est pas tellement gcc qui va poser
problèmes mais binutils et peut-être la libc. Pourquoi ne pas faire
un emerge de flash ? Ca évite bien des problèmes....






c'est en principe vrai, mais pour ce paquet là, à part télécharger le
tar.gz sur le site de l'éditeur et te l'installer là où je l'ai mis,
l'ebuild ne fait rien de plus.
(j'ai testé, avec le même résultat)






On va dire que c'est plus propre de cette manière, Gentoo y retrouve
ces petits au moins ;)



Ca fait *vraiment* longtemps que ce desktop "dort" et manque de mises
a jour, genre un an, et encore c'était déjà fait en trainant la patte.
Je me demande si c'est sans espoir, j'ai encore les packages suivants
d'installés :


gcc
Latest version available: 4.2.2
Latest version installed: 3.3.2-r5


glibc
Latest version available: 2.7
Latest version installed: 2.3.5-r2



dans le genre "je me suis bien mis dans la mouise", jh'éiste à tenter
des mises à jour là ...







Et ta version de firefox si c'est pas indiscret ?? ;)

Pour ma part j'avais eu ce soucis il y a longtemps (justement :)) et ça
c'est réglé avec les versions récentes de firefox et du plugin flash
version beta 9

Je crois que tu vas devoir tenter une mise à jour ou te passer du
flash, désolé ...

Bon courage !

Didier

����z����+�f��)�+-





j'avais un firefox 2.0.0.3 mais la tpoute dernière donne le même
résultat. (ceci étant dit, je suis un abruti de ne pas avoir commencé
par là de toute façon)

gcc 3.3->3.4 est en cours, je procède par étapes ...




et quand je vois ce que me sors revdep-rebuild ca fait peur ........ a
demain si la recompile est finie :-)





Suite a probleme j ai remis a .. en ce moment.
Petite frayeur avec python (voir autre post, je l ai recompilé vite fait
a la main et installé en sauvage c est laid mais bon .. :-/)

voila, je pars en week end avec mon PC qui s'élance sur :

Emerging (1 of 185) ....


marchera pas ... :-D



--
mailing list
Publicité
Poster une réponse
Anonyme