[gentoo-user-fr] [useradd] groupe et mails

Le
youshe
Bonjour,

Cela fait environ une heure que je me casse la tête en cherchant comment par défaut :
- fixer le groupe non pas au nom d'utilisateur mais au groupe users
- faire que le fichier de mails ne soit pas /var/spool/mail/nom_user mais à /home/nom_user/.mail/system

J'aimerais que tout ceci puisse être créé avec la commande : useradd -m nom_user
Donc, en modifiant :
/etc/default/useradd
GROUP0 # gid: 100 correspond au groupe users
HOME=/home
INACTIVE=-1
EXPIRE=
SHELL=/bin/bash
SKEL=/etc/skel
CREATE_MAIL_SPOOL=yes
/etc/login.defs :
MAIL_FILE .mail/system
répertoire /etc/skel :
/etc/skel:
apache
/etc/skel/apache:
cgi-bin www
/etc/skel/apache/cgi-bin:
/etc/skel/apache/www:

Mais là, lorsque je crée mon user, j'ai un répertoire utilisateur dont le nom de groupe est fixé au nom de l'utilisateur, loggé en utilisateur (à l'aide de su -), groups ne renvoie pas users et /var/spool/mail/nom_utilisateur est créé.

Quelle est la solution ?

Merci,

Fred

--
gentoo-user-fr@gentoo.org mailing list
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
S
Le #7802071
Salut,
Le plus simple :)

useradd -m -g users nom_user

Voila
Le mercredi 10 octobre 2007 à 10:38 +0200, youshe a écrit :
Bonjour,

Cela fait environ une heure que je me casse la tête en cherchant comment par défaut :
- fixer le groupe non pas au nom d'utilisateur mais au groupe users
- faire que le fichier de mails ne soit pas /var/spool/mail/nom_user mais à /home/nom_user/.mail/system

J'aimerais que tout ceci puisse être créé avec la commande : useradd -m nom_user
Donc, en modifiant :
/etc/default/useradd
GROUP0 # gid: 100 correspond au groupe users
HOME=/home
INACTIVE=-1
EXPIRE > SHELL=/bin/bash
SKEL=/etc/skel
CREATE_MAIL_SPOOL=yes
/etc/login.defs :
MAIL_FILE .mail/system
répertoire /etc/skel :
/etc/skel:
apache
/etc/skel/apache:
cgi-bin www
/etc/skel/apache/cgi-bin:
/etc/skel/apache/www:

Mais là, lorsque je crée mon user, j'ai un répertoire utilisateur dont le nom de groupe est fixé au nom de l'utilisateur, loggé en utilisateur (à l'aide de su -), groups ne renvoie pas users et /var/spool/mail/nom_utilisateur est créé.

Quelle est la solution ?

Merci,

Fred




--
mailing list
youshe
Le #7802061
> Salut,
Le plus simple :)

useradd -m -g users nom_user

Voila



Yep, ça fonctionne, mais je ne comprend pas pourquoi le fichier /etc/default/adduser semble être ignoré.

Par contre, cela ne résoud pas le problème de /var/spool/mail/ :(

Fred
--
mailing list
S
Le #7802051
Re,
Tu utilise postfix?

Seb
Le mercredi 10 octobre 2007 à 10:49 +0200, youshe a écrit :
> Salut,
> Le plus simple :)
>
> useradd -m -g users nom_user
>
> Voila

Yep, ça fonctionne, mais je ne comprend pas pourquoi le fichier /etc/default/adduser semble être ignoré.

Par contre, cela ne résoud pas le problème de /var/spool/mail/ :(

Fred



--
mailing list
Publicité
Poster une réponse
Anonyme