Help formule SI ....

Le
Fr
Bonjour à tous,
je ne me souviens plus la syntaxe pour obtenir le résultat suivant.

Dans la cellule A1 j'ai: MARSEILLE - NICE
Je voudrai que s'affiche dans la cellule B2: NICE

Dans la cellule A2 j'ai: NICE - LYON
Je voudrai que s'affiche dans la cellule B2: LYON

Etc.

=SI(A1 c'est quoi la suite ;0))

Cordialement.
Fr0ncis
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
DanielCo
Le #26339412
Bonjour,

=STXT(A1;TROUVE(" - ";A1)+3;9^9)

Cordialement.
Daniel


Bonjour à tous,
je ne me souviens plus la syntaxe pour obtenir le résultat suivant....

Dans la cellule A1 j'ai: MARSEILLE - NICE
Je voudrai que s'affiche dans la cellule B2: NICE

Dans la cellule A2 j'ai: NICE - LYON
Je voudrai que s'affiche dans la cellule B2: LYON

Etc....

=SI(A1 ...... c'est quoi la suite ;0))

Cordialement....
Fr0ncis
Jacky
Le #26339411
Bonjour,

+une...;o)
=STXT(A1;CHERCHE("-";A1)+2;NBCAR(A1))

--
Salutations
JJ


""
Bonjour à tous,
je ne me souviens plus la syntaxe pour obtenir le résultat suivant....

Dans la cellule A1 j'ai: MARSEILLE - NICE
Je voudrai que s'affiche dans la cellule B2: NICE

Dans la cellule A2 j'ai: NICE - LYON
Je voudrai que s'affiche dans la cellule B2: LYON

Etc....

=SI(A1 ...... c'est quoi la suite ;0))

Cordialement....
Fr0ncis

Fr
Le #26339419
Le 16/02/2015 17:34, Jacky a écrit :
Bonjour,

+une...;o)
=STXT(A1;CHERCHE("-";A1)+2;NBCAR(A1))




Petit problème....
si la cellule A1 est vide , dans B1 s'affiche: #VALEUR!
Merci
Patrick
Le #26339418
Ajouer un si:

=SI(A1<>"";STXT(A1;TROUVE(" - ";A1)+3;9^9);"")


P.


""
Le 16/02/2015 17:34, Jacky a écrit :
Bonjour,

+une...;o)
=STXT(A1;CHERCHE("-";A1)+2;NBCAR(A1))




Petit problème....
si la cellule A1 est vide , dans B1 s'affiche: #VALEUR!
Merci





---
L'absence de virus dans ce courrier electronique a ete verifiee par le logiciel antivirus Avast.
http://www.avast.com
Fr
Le #26339417
Le 16/02/2015 17:34, Jacky a écrit :
Bonjour,

+une...;o)
=STXT(A1;CHERCHE("-";A1)+2;NBCAR(A1))





J' trouvé....
=SI(A1="";"";STXT(A1;CHERCHE("-";A1)+2;NBCAR(A1)))


Merci
Jacky
Le #26339416
J' trouvé....



Clap...clap..clap
;o)))

--
Salutations
JJ


""
Le 16/02/2015 17:34, Jacky a écrit :
Bonjour,

+une...;o)
=STXT(A1;CHERCHE("-";A1)+2;NBCAR(A1))





J' trouvé....
=SI(A1="";"";STXT(A1;CHERCHE("-";A1)+2;NBCAR(A1)))


Merci
DanielCo
Le #26339442
Le 16/02/2015 17:34, Jacky a écrit :
Bonjour,

+une...;o)
=STXT(A1;CHERCHE("-";A1)+2;NBCAR(A1))




Petit problème....
si la cellule A1 est vide , dans B1 s'affiche: #VALEUR!
Merci



C'est le cas avec toutes les formules. Il y a un tas de raisons qui
peuvent planter la formule :
- A1 estvide
- A1 contient une valeur d'erreur
- A1 ne contient pas " - "
- A1 contient un espace de trop : " - "
- A1 contient une référence à la cellule contenant la formule...
Daniel
Jacquouille
Le #26339450
pffft on devrait supprimer cette cellule A1. Elle ne cause que problèmes.

Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
"DanielCo" a écrit dans le message de groupe de discussion :
mbtf8h$frl$

Le 16/02/2015 17:34, Jacky a écrit :
Bonjour,

+une...;o)
=STXT(A1;CHERCHE("-";A1)+2;NBCAR(A1))




Petit problème....
si la cellule A1 est vide , dans B1 s'affiche: #VALEUR!
Merci



C'est le cas avec toutes les formules. Il y a un tas de raisons qui
peuvent planter la formule :
- A1 estvide
- A1 contient une valeur d'erreur
- A1 ne contient pas " - "
- A1 contient un espace de trop : " - "
- A1 contient une référence à la cellule contenant la formule...
Daniel


---
L'absence de virus dans ce courrier électronique a été vérifiée par le logiciel antivirus Avast.
http://www.avast.com
DanielCo
Le #26339449
;-)))
Daniel


pffft on devrait supprimer cette cellule A1. Elle ne cause que problèmes.

Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
"DanielCo" a écrit dans le message de groupe de discussion :
mbtf8h$frl$

Le 16/02/2015 17:34, Jacky a écrit :
Bonjour,

+une...;o)
=STXT(A1;CHERCHE("-";A1)+2;NBCAR(A1))




Petit problème....
si la cellule A1 est vide , dans B1 s'affiche: #VALEUR!
Merci



C'est le cas avec toutes les formules. Il y a un tas de raisons qui
peuvent planter la formule :
- A1 estvide
- A1 contient une valeur d'erreur
- A1 ne contient pas " - "
- A1 contient un espace de trop : " - "
- A1 contient une référence à la cellule contenant la formule...
Daniel


---
L'absence de virus dans ce courrier électronique a été vérifiée par le
logiciel antivirus Avast.
http://www.avast.com
Publicité
Poster une réponse
Anonyme