[HPPA] Mise à jour et lbxproxy

Le
Hugolino
Salut,

Je suis en train de mettre à jour vers Etch une HP PA Risc (une
antiquité).

Mais la MAJ bute sur le paquet lbxproxy
# apt-get upgrade
Lecture des listes de paquets Fait
Construction de l'arbre des dépendances Fait
E: Le paquet lbxproxy doit être réinstallé, mais je ne parviens pas à
trouver son archive.
# apt-get dist-upgrade
Lecture des listes de paquets Fait
Construction de l'arbre des dépendances Fait
E: Le paquet lbxproxy doit être réinstallé, mais je ne parviens pas à
trouver son archive.
# apt-get remove --purge lbxproxy
Lecture des listes de paquets Fait
Construction de l'arbre des dépendances Fait
E: Le paquet lbxproxy doit être réinstallé, mais je ne parviens pas à
trouver son archive.

Donc je suis coincé. D'autant plus que si je cherche à télécharger ce
paquet pour l'installer via "dpkg -I", je tombe sur un paquet de Sarge,
je tombe là-dessus:
http://security.debian.org/debian-security/pool/updates/main/x/xfree86/
lbxproxy_4.3.0.dfsg.1-14sarge3_hppa.deb
clairement identifié comme faisant partie de Sarge
Et si le téléchargement du paquet marche, son installation semble
planter (je ne récupère pas le prompt, même après 3 heures)

N'y aurait-il point dans la salle un PA-RISCqueur pointu ou un
débianneux intégriste capable de me dire suoi faire ?

Merci

--
Unix is user friendly. It's just selective about who his friends are.
-+- Tollef Fog Heen -+-
Hugo (né il y a 1 356 132 664 secondes)
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
didier gaumet
Le #1883945
On Mon, 16 Apr 2007 00:43:23 +0200, Hugolino wrote:

Salut,

Je suis en train de mettre à jour vers Etch une HP PA Risc (une
antiquité).

Mais la MAJ bute sur le paquet lbxproxy
# apt-get upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
E: Le paquet lbxproxy doit être réinstallé, mais je ne parviens pas à
trouver son archive.
# apt-get dist-upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
E: Le paquet lbxproxy doit être réinstallé, mais je ne parviens pas à
trouver son archive.
# apt-get remove --purge lbxproxy
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
E: Le paquet lbxproxy doit être réinstallé, mais je ne parviens pas à
trouver son archive.

Donc je suis coincé. D'autant plus que si je cherche à télécharger ce
paquet pour l'installer via "dpkg -I", je tombe sur un paquet de Sarge,
je tombe là-dessus:
http://security.debian.org/debian-security/pool/updates/main/x/xfree86/
lbxproxy_4.3.0.dfsg.1-14sarge3_hppa.deb
clairement identifié comme faisant partie de Sarge...
Et si le téléchargement du paquet marche, son installation semble
planter (je ne récupère pas le prompt, même après 3 heures)

N'y aurait-il point dans la salle un PA-RISCqueur pointu ou un
débianneux intégriste capable de me dire suoi faire ?

Merci



Bonjour,

je ne suis ni PA-RISCqueur pointu ni un débianneux intégriste mais je
réponds quand même ;-)

J'ai retrouvé sur le net un gars qui se plaint de la même chose que toi
sur Ubuntu: le paquet en question a disparu des versions récentes de ces
distros.

Ceci dit comme dans ton message
parles d'une utilisation en serveur, tu n'as pas à mon sens aucun besoin de
ce paquet (lbxproxy) : c'est un truc pour compresser le flux d'infos
transmis entre un client X et un serveur X distant dans le cas d'une
liaison bas-débit. Donc désinstalle-le et ça devrait rouler.

didier gaumet
Le #1883944
On Mon, 16 Apr 2007 07:49:27 +0000, didier gaumet wrote:

tu n'as pas à mon sens aucun besoin de


"tu n'as à mon sens aucun besoin de": pfoouuuu, pas réveillé ...

Hugolino
Le #1883940
Le 16 Apr 2007 07:52:02 GMT, didier gaumet a écrit:
On Mon, 16 Apr 2007 07:49:27 +0000, didier gaumet wrote:

tu n'as pas à mon sens aucun besoin de


"tu n'as à mon sens aucun besoin de": pfoouuuu, pas réveillé ...


Pas grave :)
Comme je disais dans le post initial:
# apt-get remove --purge lbxproxy
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
E: Le paquet lbxproxy doit être réinstallé, mais je ne parviens pas à
trouver son archive.



Donc, je n'arrive même pas à le désinstaller

Merci tout de même de ta réponse


--
personne n'a un zipper suffisament puissant pour comprimer un con en 4
ligne pour le GNU ?
parce que celui la, pour ses oeuvres complétes faut un forum dédié !
-+- JFP in neuneu.ctw.cc - Si le con presse, zippé des prunes-+-


didier gaumet
Le #1883936
On Mon, 16 Apr 2007 12:27:42 +0200, Hugolino wrote:

Pas grave :)
Comme je disais dans le post initial:
# apt-get remove --purge lbxproxy
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
E: Le paquet lbxproxy doit être réinstallé, mais je ne parviens pas à
trouver son archive.



Donc, je n'arrive même pas à le désinstaller

Merci tout de même de ta réponse


Désolé, j'avais lu en diagonale.
Si le paquet est effectivement encore là, tu peux tenter un apt-get -f
remove, sinon plus radical : un dpkg --remove.
Si ça récalcitre: dpkg --purge --force-remove-reinstreeq le paquet.
Mais de toutes façons, une fois le paquet désinstallé, apt-get cherchera à
le réinstaller (ce qui est impossible car le paquet n'existe pas dans
Etch). Il faut donc trouver le paquet qui "dépend de" ou "recommande"
lbxproxy.

:~$ apt-cache search lbx
libxext-dev - X11 miscellaneous extensions library (development headers)
libxext6 - X11 miscellaneous extension library
libxext6-dbg - X11 miscellaneous extensions library (debug package)
xspecs - X protocol, extension, and library technical specifications

j'ai tapé ça sous Etch: à mon avis tu désinstalles tout ça et ça devrait
marcher. Au pire tu désinstalles tout X (tu n'en as pas vraiment besoin
sur un serveur).



Hugolino
Le #1883920
Le 16 Apr 2007 11:03:58 GMT, didier gaumet a écrit:
Si le paquet est effectivement encore là, tu peux tenter un apt-get -f
remove, sinon plus radical : un dpkg --remove.
Si ça récalcitre: dpkg --purge --force-remove-reinstreeq le paquet.


# dpkg --purge --force-remove-reinstreq lbxproxy
dpkg - avertissement, problème contourné à cause de --force :
Le paquet est dans un état incohérent - vous devriez
le réinstaller avant d'essayer de le supprimer.
(Lecture de la base de données... 39681 fichiers et répertoires déjà
installés.)
Suppression de lbxproxy ...
dpkg (sous-processus) : impossible d'exécuter post-removal script:
Erreur de format pour exec()
dpkg : erreur de traitement de lbxproxy (--purge) :
le sous-processus post-removal script a retourné une erreur de sortie
d'état 2
Des erreurs ont été rencontrées pendant l'exécution :
lbxproxy


Mais de toutes façons, une fois le paquet désinstallé, apt-get cherchera à
le réinstaller (ce qui est impossible car le paquet n'existe pas dans
Etch). Il faut donc trouver le paquet qui "dépend de" ou "recommande"
lbxproxy.

:~$ apt-cache search lbx
libxext-dev - X11 miscellaneous extensions library (development headers)
libxext6 - X11 miscellaneous extension library
libxext6-dbg - X11 miscellaneous extensions library (debug package)
xspecs - X protocol, extension, and library technical specifications


# apt-get remove --purge libxext6
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
E: Le paquet lbxproxy doit être réinstallé, mais je ne parviens pas à
trouver son archive.

'tain. Quand ça veut pas...

Merci de ton aide


j'ai tapé ça sous Etch: à mon avis tu désinstalles tout ça et ça devrait
marcher. Au pire tu désinstalles tout X (tu n'en as pas vraiment besoin
sur un serveur).


Oui

--
je suis en train de pouffiner ma conf sous SUSE (distrib intéressante.... :-)
et j'envisage de tester ensuite laRH 6.0, juste pour voir...
-+- OP in GLP : bien pouffiner sa conf ou le contraire -+-
Hugo (né il y a 1 356 175 796 secondes)

didier gaumet
Le #1883919
On Mon, 16 Apr 2007 13:35:24 +0200, Hugolino wrote:

[...]
'tain. Quand ça veut pas...
[...]



tu peux essayer un dpkg --audit qui te donnera une marche à suivre pour
corriger le problèmes.
tu peux aussi recommencer le dpkg --purge --force-remove-reinstreeq en
ajoutant l'option --auto-deconfigure qui devrait remettre d'aplomb les
paquets qui dépendent du paquet.

désolé, je n'ai pas d'autres suggestions.

Hugolino
Le #1889782
Le 16 Apr 2007 12:01:42 GMT, didier gaumet a écrit:
On Mon, 16 Apr 2007 13:35:24 +0200, Hugolino wrote:

[...]
'tain. Quand ça veut pas...
[...]



tu peux essayer un dpkg --audit qui te donnera une marche à suivre pour
corriger le problèmes.
tu peux aussi recommencer le dpkg --purge --force-remove-reinstreeq en
ajoutant l'option --auto-deconfigure qui devrait remettre d'aplomb les
paquets qui dépendent du paquet.

désolé, je n'ai pas d'autres suggestions.


En fait il y a un truc que je n'ai pas dit (ça ne me semblait pas
important), quasi-systématiquement, pendant que je tente ces manips de
mise à jour, j'ai des erreurs sur le disque. Et je crois bien qu'il est
mort, il a 10 ans.

Merci pour ton aide en tout cas.

--
<JX> je vais boire une adelscott
<CleeK> jx : pareil pour moi
<JX> et comme il ne faut JAMAIS boire le ventre vide
<JX> je vais manger une Guinness avec


didier gaumet
Le #1889780
On Tue, 17 Apr 2007 19:19:57 +0200, Hugolino wrote:

En fait il y a un truc que je n'ai pas dit (ça ne me semblait pas
important), quasi-systématiquement, pendant que je tente ces manips de
mise à jour, j'ai des erreurs sur le disque. Et je crois bien qu'il est
mort, il a 10 ans.

Merci pour ton aide en tout cas.


Si tu ne l'as pas déjà fait, tu peux faire lancer un badblocks sur chacune
de tes partitions démontées pour vérifier si il y a des blocs défectueux.

Publicité
Poster une réponse
Anonyme