.htaccess qui ne fonctionne plus

Le
Goldy
Bonjour,

Je viens de découvrir aujourd'hui que les .htaccess que j'avais mis en
place sur certain dossiers ne fonctionne plus sous ma lenny.

Je suis incapable de dire depuis quand cela ne fonctionne plus, mais
j'aimerais bien savoir pourquoi.

Qu'est-ce qui aurait pu changer dans la configuration pour les .htaccess
soient ignorés de la sorte ?

J'ai vérifié les fichiers de mot de passe associés au .htaccess et ils
n'ont pas bougés, ils sont comme je les avais fait lorsque ça marchait.

Je pense que je vais préférer gérer mes accès par php, c'est chaud de
voir que sur une installation stable ce genre de truc puisse être cassé
si facilement moi qui pensait ce type de protection sécurisé.

Merci d'avance si vous pouvez m'éclairer.

Christophe

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/4C7E832C.7060508@goldenfish.info
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Dominique Asselineau
Le #22531251
Goldy wrote on Wed, Sep 01, 2010 at 06:45:32PM +0200
Bonjour,

Je viens de découvrir aujourd'hui que les .htaccess que j'avais mis en
place sur certain dossiers ne fonctionne plus sous ma lenny.

Je suis incapable de dire depuis quand cela ne fonctionne plus, mais
j'aimerais bien savoir pourquoi.

Qu'est-ce qui aurait pu changer dans la configuration pour les .htaccess
soient ignorés de la sorte ?



À part que les fichiers .htaccess ne soient pas autorisés, je ne vois pas
d'autre chose, sinon ça partirait en erreur 500.


J'ai vérifié les fichiers de mot de passe associés au .htaccess et ils
n'ont pas bougés, ils sont comme je les avais fait lorsque ça marchait.



La config principale, au niveau du serveur, aurait pu bouger.


Je pense que je vais préférer gérer mes accès par php,



Les défauts de config sont plus probables.

c'est chaud de
voir que sur une installation stable ce genre de truc puisse être cassé
si facilement... moi qui pensait ce type de protection sécurisé.



Perso, je le pense toujours. comme dit plus haut, un défaut de
config part en erreur 500, donc rien ne peut aller chez le client,
aucun message trop bavard en particulier. C'est bien ce qu'il y a de
plus sûr...

Dominique
--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Goldy
Le #22531461
Le 01/09/2010 19:15, Dominique Asselineau a écrit :
Goldy wrote on Wed, Sep 01, 2010 at 06:45:32PM +0200
Bonjour,

Je viens de découvrir aujourd'hui que les .htaccess que j'avais mis en
place sur certain dossiers ne fonctionne plus sous ma lenny.

Je suis incapable de dire depuis quand cela ne fonctionne plus, mais
j'aimerais bien savoir pourquoi.

Qu'est-ce qui aurait pu changer dans la configuration pour les .htaccess
soient ignorés de la sorte ?



À part que les fichiers .htaccess ne soient pas autorisés, je ne vois pas
d'autre chose, sinon ça partirait en erreur 500.


J'ai vérifié les fichiers de mot de passe associés au .htaccess et ils
n'ont pas bougés, ils sont comme je les avais fait lorsque ça marchait.



La config principale, au niveau du serveur, aurait pu bouger.


Je pense que je vais préférer gérer mes accès par php,



Les défauts de config sont plus probables.

c'est chaud de
voir que sur une installation stable ce genre de truc puisse être cassé
si facilement... moi qui pensait ce type de protection sécurisé.



Perso, je le pense toujours. comme dit plus haut, un défaut de
config part en erreur 500, donc rien ne peut aller chez le client,
aucun message trop bavard en particulier. C'est bien ce qu'il y a de
plus sûr...

Dominique
--




Effectivement, j'avais associé ces dossiers à un domaine et j'avais tout
simplement oublié de mettre AllowOverride AuthConfig dans le fichier de
conf...

Et le pire c'est que ça fait plus d'un mois et je m'en étais pas rendu
compte. Je suis une vrai brèle en sécurité...

Va vraiment falloir que j'achète un bouquin sur apache à potasser.

Merci pour la réponse en tout cas.

Christophe

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Dominique Asselineau
Le #22531441
Goldy wrote on Wed, Sep 01, 2010 at 07:50:07PM +0200
Le 01/09/2010 19:15, Dominique Asselineau a écrit :
> Goldy wrote on Wed, Sep 01, 2010 at 06:45:32PM +0200
>> Bonjour,
>>
>> Je viens de découvrir aujourd'hui que les .htaccess que j'avais mis en
>> place sur certain dossiers ne fonctionne plus sous ma lenny.
>>
>> Je suis incapable de dire depuis quand cela ne fonctionne plus, mais
>> j'aimerais bien savoir pourquoi.
>>
>> Qu'est-ce qui aurait pu changer dans la configuration pour les .htaccess
>> soient ignorés de la sorte ?
>
> À part que les fichiers .htaccess ne soient pas autorisés, je ne vois pas
> d'autre chose, sinon ça partirait en erreur 500.
>
>>
>> J'ai vérifié les fichiers de mot de passe associés au .htaccess et ils
>> n'ont pas bougés, ils sont comme je les avais fait lorsque ça marchait.
>
> La config principale, au niveau du serveur, aurait pu bouger.
>
>>
>> Je pense que je vais préférer gérer mes accès par php,
>
> Les défauts de config sont plus probables.
>
>> c'est chaud de
>> voir que sur une installation stable ce genre de truc puisse être cassé
>> si facilement... moi qui pensait ce type de protection sécurisé.
>
> Perso, je le pense toujours. comme dit plus haut, un défaut de
> config part en erreur 500, donc rien ne peut aller chez le client,
> aucun message trop bavard en particulier. C'est bien ce qu'il y a de
> plus sûr...
>
> Dominique
> --
>

Effectivement, j'avais associé ces dossiers à un domaine et j'avais tout
simplement oublié de mettre AllowOverride AuthConfig dans le fichier de
conf...



Pour ce genre de chose, un copier-coller de config suffit déjà à ne
pas oublier ce qui marche et comment. Et ensuite affiner.


Et le pire c'est que ça fait plus d'un mois et je m'en étais pas rendu
compte. Je suis une vrai brèle en sécurité...



Si on veut vraiment être pointu en matière de sécurité, il faut écrire
des crons qui testent régulièrement les connexions et qui vérifient
que ça ne passe pas trop facilement.


Va vraiment falloir que j'achète un bouquin sur apache à potasser.



La doc d'Apache aide déjà pas mal.

Dominique

--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme