sur IE6, site passe pas chez moi et qui passe chez 1 pote...

Le
METIS
Bonjour,
pour un "client", je fais un p'tit site classique 3 colonnes
CSS, header, footer, le truc de base.
L'hébergeur change de serveur
Depuis, chez moi, les colonnes sont les unes au dessus des
autres avec IE6 mais marchent normalement dans FireFox!!
Chez ce "client", le site est normal dans tous les cas
Plus rigolo, chez moi, dans IE6, le site est normal avec
l'adresse de l'ancien serveur qui fonctionne encore et pas
normal avec la nouvelle adresse..!!!

Quelle peut être cette supercherie ??

(cache vidé et c'est la première fois que je vois un truc
comme ça)
(je ne peux pas montrer le site pour le moment)

--
<|[;o)) METIS
http://www.graphM.com
Remplacer wawamoo par ce qu'il faut
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
ASM
Le #22092451
En réponse à METIS qui écrivit, en date du : 3/09/07 19:01, le message
suivant :
Bonjour,
pour un "client", je fais un p'tit site classique 3 colonnes
CSS, header, footer, le truc de base.
L'hébergeur change de serveur...
Depuis, chez moi, les colonnes sont les unes au dessus des
autres avec IE6 mais marchent normalement dans FireFox!!
Chez ce "client", le site est normal dans tous les cas...
Plus rigolo, chez moi, dans IE6, le site est normal avec
l'adresse de l'ancien serveur qui fonctionne encore et pas
normal avec la nouvelle adresse..!!!

Quelle peut être cette supercherie ??



Il n'y a *certainement pas* la même chose des 2 cotés.
Il ne peut il y avoir de supercherie.

Et ce n'est sans doute pas la faute des serveurs puisque tu n'as pas
évoqué PHP
METIS
Le #22092441
ASM wrote:
Il n'y a *certainement pas* la même chose des 2 cotés.
Il ne peut il y avoir de supercherie.



Bé si puisque moi, je n'ai rien changé.
C'est le même site qui est en migration et il est encore
accessible sur les 2 adresses...

Et ce n'est sans doute pas la faute des serveurs puisque
tu n'as pas évoqué PHP



Oui, il y a du PHP...
En fait, je devrais neutraliser les parties en PHP une par
une pour voir si la chose se rétablit?

--
<|[;o)) METIS
http://www.graphM.com
Remplacer wawamoo par ce qu'il faut...
Pierre Goiffon
Le #22092431
METIS wrote:
pour un "client", je fais un p'tit site classique 3 colonnes
CSS, header, footer, le truc de base.
L'hébergeur change de serveur...
Depuis, chez moi, les colonnes sont les unes au dessus des
autres avec IE6 mais marchent normalement dans FireFox!!
Chez ce "client", le site est normal dans tous les cas...
Plus rigolo, chez moi, dans IE6, le site est normal avec
l'adresse de l'ancien serveur qui fonctionne encore et pas
normal avec la nouvelle adresse..!!!

Quelle peut être cette supercherie ??

(cache vidé et c'est la première fois que je vois un truc
comme ça)
(je ne peux pas montrer le site pour le moment)



Il est quasi impossible d'apporter une réponse sans pouvoir accéder aux
2 adresses, anciennes et nouvelles.

Quelques idées en vrac :
- un fichier spécifique IE qui n'a pas été copié d'un serveur à l'autre
- quelque part un lien absolu (vers une feuille de style par exemple)
que seul IE utiliserait
- le cache (sisi)
- l'ajout d'un entête automatiquement par le serveur
- une négociation de contenu quelconque
- ...
On peut supposer longtemps comme ça et ça n'avancera pas à grand chose.

Une dernière chose : installer la developer toolbar pour IE permettrait
sans doute de comprendre un peu mieux ce qu'il se passe.
METIS
Le #22092381
Pierre Goiffon wrote:
[...]
Une dernière chose : installer la developer toolbar pour
IE permettrait sans doute de comprendre un peu mieux ce
qu'il se passe.



==>Oui, plein de bonnes idées dont la dernière, la meilleur.
Je ne savais pas que cet accessoire existait aussi pour IE
(debugbar pour être juste ?).
Je teste !!

--
<|[;o)) METIS
http://www.graphM.com
Remplacer wawamoo par ce qu'il faut...
Pierre Goiffon
Le #22092371
METIS wrote:
Une dernière chose : installer la developer toolbar pour
IE permettrait sans doute de comprendre un peu mieux ce
qu'il se passe.



Je ne savais pas que cet accessoire existait aussi pour IE
(debugbar pour être juste ?).



Microsoft a fini par développer un équivalent (à mon sens bien moins
complet)
Voir :
METIS
Le #22092351
Pierre Goiffon wrote:
METIS wrote:
Une dernière chose : installer la developer toolbar pour
IE permettrait sans doute de comprendre un peu mieux ce
qu'il se passe.



Je ne savais pas que cet accessoire existait aussi pour
IE (debugbar pour être juste ?).



Microsoft a fini par développer un équivalent (à mon sens
bien moins complet)
Voir :



Moins complet que quoi ?
J'ai commencé par checher "toolbar", il y en a des caisses
et beaucoup de search-machin Google et autres...
Il y a aussi une toolbar payante 29$, me rappelle plus du
nom.

--
<|[;o)) METIS
http://www.graphM.com
Remplacer wawamoo par ce qu'il faut...
Pierre Goiffon
Le #22092321
METIS wrote:
Une dernière chose : installer la developer toolbar pour
IE


Je ne savais pas que cet accessoire existait aussi pour
IE (debugbar pour être juste ?).


Microsoft a fini par développer un équivalent (à mon sens
bien moins complet)
Voir :



Moins complet que quoi ?



Oh pardon, en lisant votre message initial ("je ne savais pas que cet
accessoire existait aussi pour IE") je pensais qu'il était clair que
vous faisiez référence à la Web developper toolbar, extension Firefox
(http://chrispederick.com/work/web-developer/) : la toolbar de Microsoft
en est une adaptation directe pour tenter de garder un certain public
sous IE...

C'était donc l'original et la pale copie (c'est mon avis) que je comparais.
Publicité
Poster une réponse
Anonyme