IE8 : frappe de texte lente !

Le
Albédo
À peine résolu (?) le problème d'affichage de la barre des menus et des barres
d'icones, voilà que je découvre un autre pain : dans la fenêtre de saisie de
texte d'un forum que je fréquente régulièrement, la saisie de texte est devenue
extrêmement lente ; je tape à la vitesse habituelle, mais les caractères
apparaissent avec plusieurs secondes de retard
Une idée, quelqu'un, par pitié (autre que désinstaller cette saloperie,
évidemment) ?
--
a.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
MCI
Le #19239961
Bonsoir !

J'ai ça sur certains forums, et, quelque soit le navigateur utilisé.
Dans la moitié des cas, le problème disparaît au bout de quelques
heures/jours.
Pour le restant, la lenteur est souvent due au "côté serveur". Entre les
pages en Javascript programmées avec les pieds (souvent avec des
librairies superposées sans réflexion), et l'usage abusif d'un PHP
écrasé par un nombre énorme de tags, de hits, d'images, d'éléments
divers, ET DE PUBLICITÉ.
Il peut y avoir aussi un problème de serveur. Nombreux sont ceux qui
ouvre un site avec des forums, sur un serveur mutualisé, qui peut
héberger des centaines, ou des milliers de serveurs Web ; et avec un
partage des SGBD qui ne tiennent pas la charge (SQL-lite, ou MySQL, par
exemple, pour ne pas les nommer).

Va tester là : http://ponx.fr la vitesse de saisie. Si tu trouves que
ça va assez vite, ce n'est pas ton navigateur qui est en cause, mais que
ça dépend du site en question.

@-salutations
--
Michel Claveau
Albédo
Le #19240571
"MCI" :
: (...) Va tester là : http://ponx.fr
: la vitesse de saisie. Si tu trouves que
: ça va assez vite, ce n'est pas ton navigateur
: qui est en cause, mais que ça dépend
: du site en question.

La coïncidence est curieuse, mais tu as raison, là-bas c'est au poil.
Merci. :-)
--
a.
MCI
Le #19240641
Re !

Pour infos, pour que ces ces forums soient très rapides, j'ai utilisé :
- un serveur sous Windows-2003-Server-Web-edition
- Cherrypy comme serveur Web
- CHATA comme SGBD
- Python comme langage de lien, créant dynamiquement les pages.
- Ponx comme librairie de fonctionnalités et interface avec l'OS.

Les pages sont volontairement sobres, avec du HTML statique (sans Ajax),
et avec très peu d'éléments syndiqués (pas d'images à aller chercher
ailleurs, pas de Javascript inclut, pas de publicité, pas de flash, pas
de PHP, pas de cookies ; rien qui ralentisse la connexion).

Dans mes tests, sur un serveur qui ne faisait que ça (ce qui n'est pas
le cas du serveur actuel), avec 1000 utilisateurs actifs simultanés,
chaque page était rendue en moins d'une seconde (hors vitesse de
connexion des internautes).

@-salutations
--
Michel Claveau



PS : le serveur Web peut jouer beaucoup. Le plus rapide que je
connaisse, c'est YAWS ; peu connu, il est capable de servir 80000
connexions simultanées avec une machine à 1 GHz, et 512 Mo de RAM.
Mais, il est écrit en Erlang, ce qui peut rebuter... (voir
http://www.sics.se/~joe/apachevsyaws.html)
Albédo
Le #19266871
Bon, donc, à part les thèmes sortie d'usine "XP" et "classique", à la moindre
modification que j'apporte, je retrouve le bug de la barre des menus et des
barres d'outils, cf. http://cjoint.com/?fcxx1n3PAd.
Or donc, sans moi, IE8 !
--
a.
Albédo
Le #19315981
J'ai désinstallé IE8 à cause du problème d'affichage des menus et des barres
d'outils, mais n'empêche, voici apparemment la solution au problème que je
rencontrais (trouvée sur le forum sur lequel j'avais le problème) : il fallait
passer par le bouton "Affichage de compatibilité" situé à côté du bouton
"Actualiser" ; ce bouton n'apparaît que lorsqu'on va sur certains sites web et
est censé corriger les problèmes de compatibilité inter-versions de MSIE.
--
a.
Bernard Lempel
Le #19316321
Bonjour,

J'essaierais de me souvenir de ce problème et de la solution que tu as
trouvé.
On ne sait jamais, cela pourrait s'avérer utile à plus d'un, dont moi.
:-)

A+.
Bernard Lempel
http://lempel.net

"Albédo"
J'ai désinstallé IE8 à cause du problème d'affichage des menus et des
barres d'outils, mais n'empêche, voici apparemment la solution au problème
que je rencontrais (trouvée sur le forum sur lequel j'avais le problème) :
il fallait passer par le bouton "Affichage de compatibilité" situé à côté
du bouton "Actualiser" ; ce bouton n'apparaît que lorsqu'on va sur
certains sites web et est censé corriger les problèmes de compatibilité
inter-versions de MSIE.
--
a.



Albédo
Le #19339291
"Bernard Lempel" :
J'essaierais de me souvenir de ce problème et de la solution que tu as trouvé.
On ne sait jamais, cela pourrait s'avérer utile à plus d'un, dont moi.
:-)



Et si tu vois passer la solution pour mon problème d'affichage de la barre de
menus et des barres d'outils, pense à poster, S.T.P. ! J'attends ça (même si
apparemment je suis le seul ici à connaître ce bug)...
--
a.
Bernard Lempel
Le #19349571
Bonjour,

J'ai encore fouillé dans mes documents sans succès.

Au revoir.
Bernard Lempel
http://lempel.net

"Albédo" %
"Bernard Lempel" :
J'essaierais de me souvenir de ce problème et de la solution que tu as
trouvé.
On ne sait jamais, cela pourrait s'avérer utile à plus d'un, dont moi.
:-)



Et si tu vois passer la solution pour mon problème d'affichage de la barre
de menus et des barres d'outils, pense à poster, S.T.P. ! J'attends ça
(même si apparemment je suis le seul ici à connaître ce bug)...
--
a.



Publicité
Poster une réponse
Anonyme