iGPU Skylake et Jessie

Le
Damien TOURDE
Bonjour,

J'ai un soucis avec le GPU Intel HD530 de mon CPU Skylake (i5 6500)
depuis que je suis passé en stable (fresh install)

Ce GPU est bien reconnu en testing/sid, et fonctionne pas mal, mais pas
en stable.


glxinfo me dit :

OpenGL vendor string: VMware, Inc.
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.5, 256 bits)
OpenGL version string: 3.0 Mesa 10.3.2


Pourtant le DRI2 a l'air de se lancer (mais en i965 ??) depuis que j'ai
installé la version BPO de libdrm-intel1.

cat /var/log/Xorg.0.log |grep DR
[ 7.749] (II) intel(0): [DRI2] Setup complete
[ 7.749] (II) intel(0): [DRI2] DRI driver: i965
[ 7.749] (II) intel(0): [DRI2] VDPAU driver: va_gl
[ 7.749] (II) intel(0): direct rendering: DRI2 enabled
[ 7.822] (II) GLX: Initialized DRISWRAST GL provider for screen 0


J'ai installé via les backports :

dpkg -l |awk '/^ii/ && $3 ~ /bpo[6-8]/ {print $2}'

docker.io
firmware-amd-graphics
firmware-linux
firmware-linux-nonfree
firmware-misc-nonfree
irqbalance
libdrm-intel1:amd64
libopenjfx-java
libopenjfx-jni
linux-base
linux-image-4.6.0-0.bpo.1-amd64
linux-image-amd64
openjdk-8-jre:amd64
openjdk-8-jre-headless:amd64
openjfx
xserver-xorg-video-intel


En gros j'ai testé simplement le kernel et xserver-xorg-video-intel,
puis peu à peu j'ai rajouté firmware-linux et misc-nonfree, et
libdrm-intel1, le tout sans succès jusque là.


Sur testing cela marchait directement, quel paquet aurais-je oublié à
votre avis ? Ou d'autres idées ?

Merci,
Damien
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
BOITEUX, Frederic
Le #26411202
Bonjour Damien,
Essaie d'installer le backport de Mesa 12 qui vient d'arriver dans les dépôts Debian, cela devrait aider. Quel noyau as-tu installé ? tu devrais également utiliser un 4.6 ou 4.7 (backport) pour que ta machine soit correctement gérée je pense…
Cdlt,
Fred.
This message contains information that may be privileged or confidential and is the property of the Capgemini Group. It is intended only for the person to whom it is addressed. If you are not the intended recipient, you are not authorized to read, print, retain, copy, disseminate, distribute, or use this message or any part thereof. If you receive this message in error, please notify the sender immediately and delete all copies of this message.
Damien TOURDE
Le #26411210
Bonjour Frédéric,
Quand tu parles de mesa, tu parles de quel paquet ?
Sinon pour le noyau je suis en 4.6 via les BPO.
Merci,
Damien
On 29/09/2016 17:55, BOITEUX, Frederic wrote:
Bonjour Damien,
Essaie d'installer le backport de Mesa 12 qui vient d'arriver dans les dépôts Debian, cela devrait aider. Quel noyau as-tu installé ? tu devrais également utiliser un 4.6 ou 4.7 (backport) pour que ta machine soit correctement gérée je pense…
Cdlt,
Fred.
This message contains information that may be privileged or confidential and is the property of the Capgemini Group. It is intended only for the person to whom it is addressed. If you are not the intended recipient, you are not authorized to read, print, retain, copy, disseminate, distribute, or use this message or any part thereof. If you receive this message in error, please notify the sender immediately and delete all copies of this message.
Damien TOURDE
Le #26411246
Bonjour,
J'ai installé le paquet libgl1-mesa-dri en jessie-backports et mon
glxinfo a une meilleure tronche :-)
:~# glxinfo |grep OpenGL
libGL error: pci id for fd 4: 8086:1912, driver (null)
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) HD Graphics 530 (Skylake GT2)
OpenGL core profile version string: 4.3 (Core Profile) Mesa 12.0.3
OpenGL core profile shading language version string: 4.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 12.0.3
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.1 Mesa 12.0.3
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10
OpenGL ES profile extensions:
En revanche, il y a un truc que je ne pige pas, en render CPU glxgears
tournait à 2500 fps, et maintenant, en render GPU, à 60 fps...
Merci beaucoup,
Damien

On 29/09/2016 18:53, Damien TOURDE wrote:
Bonjour Frédéric,
Quand tu parles de mesa, tu parles de quel paquet ?
Sinon pour le noyau je suis en 4.6 via les BPO.
Merci,
Damien
On 29/09/2016 17:55, BOITEUX, Frederic wrote:
Bonjour Damien,
Essaie d'installer le backport de Mesa 12 qui vient d'arriver dans
les dépôts Debian, cela devrait aider. Quel noyau as-tu installé ? tu
devrais également utiliser un 4.6 ou 4.7 (backport) pour que ta
machine soit correctement gérée je pense…
Cdlt,
Fred.
This message contains information that may be privileged or
confidential and is the property of the Capgemini Group. It is
intended only for the person to whom it is addressed. If you are not
the intended recipient, you are not authorized to read, print,
retain, copy, disseminate, distribute, or use this message or any
part thereof. If you receive this message in error, please notify the
sender immediately and delete all copies of this message.

Publicité
Poster une réponse
Anonyme