imagelist treeview

Le
aristophane24
Bonjour,
Ci-dessous voici un code de microsoft trouvé à cette adresse : http://support.microsoft.com/kb/184975/EN-US/
J'ai un problème sur mon propre treeview. Et c'est le même quand j'essaye d'utiliser ce code. Si je résous le problème avec ce code, je pourrai résoudre le mien.
Le navigateur m'affiche : L'imagelist doit être initialisée avant de pouvoir être utilisée.

<HTML>
<HEAD>
<TITLE>Treeview 6.0 With ImageList 6.0</TITLE>

<SCRIPT LANGUAGE="VBScript">
<!--

Option Explicit

Sub Window_OnLoad()
Dim newNode

'set TreeView1.ImageList = myImageList

Set newNode = TreeView1.Nodes.Add(,,"KEY10088","Test1")
newNode.expanded=true
newNode.Image=1

Set newNode = TreeView1.Nodes.Add("KEY10088",4,"KEY10089","Test2")
newNode.Tag = "10089"
newNode.Image=1

Set newNode = TreeView1.Nodes.Add("KEY10088",4,"KEY10090","Test3")
newNode.Tag = "10090"
newNode.Image=1

End Sub
-->
</SCRIPT>
</HEAD>
<BODY>



<OBJECT id=myImageList
style="LEFT: 0px; TOP: 0px" dataÚta:application/x-oleobject;base64,I38kLJGF0RGxagDA8Cg2KCFDNBIIAAAA7QMAAO0DAACAfuHmAgAFADIAAAAQABAA/wD/AP//QQAB782rAAAFAIFsqHdBAEEA/////////wBoeCIAAgAAAAEGAAAAQwBhAG0AZQByAGEAAAIAAAABAAAAbHQAAPYAAABCTfYAAAAAAAAAdgAAACgAAAAQAAAAEAAAAAEABAAAAAAAgAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAACAAACAAAAAgIAAgAAAAIAAgACAgAAAgICAAMDAwAAAAP8AAP8AAAD//wD/AAAA/wD/AP//AAD///8AiIiIiIiIiIiIiIiIiIiIiIiIiIiIiIiIiIiIcAeIiIiHAAAAAAAAeIB3AHd3AHcIgHcHd3dwdwiAdweHd3B3CIB3B/h3cHcIgP8Ad3cA/wiA//AAAA//CIAAAAAAAAAIiACHD/B4AIiIiIhwB4iIiIiIiIiIiIiIiIiIiIiIiIgCAAAAbHQAAOYBAABCTeYBAAAAAAAANgAAACgAAAAMAAAADAAAAAEAGAAAAAAAsAEAAMQOAADEDgAAAAAAAAAAAAD///////////////////8AAAAAAAAAAAD///////////////////////////////8AAAAAAAAAAAAAAAD///////////////////////////8AAAAAAAAAAAAAAAAAAAAAAAD///////////////////////8AAAAAAAAAAAAAAAAAAAAAAAAAAAD///////////////////8AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAD///////////8AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAD///////////8AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAD///////8AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAD///8AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAD///8AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAD///////////////////////////////////////////////////////////////////////////////////////////////8=
classid=clsid:2C247F23-8591-11D1-B16A-00C0F0283628>
</OBJECT>

<OBJECT ID="TreeView1" WIDTH0 HEIGHT0
CLASSID="CLSID:C74190B6-8589-11D1-B16A-00C0F0283628">
<PARAM NAME="_ExtentX" VALUE="2646">
<PARAM NAME="_ExtentY" VALUE="2646">
<PARAM NAME="_Version" VALUE="327682">
<PARAM NAME="Style" VALUE="7">
<PARAM NAME="Appearance" VALUE="1">
<PARAM NAME="ImageList" VALUE="myImageList">
</OBJECT>
</BODY>
</HTML>


Cordialement,
Nikos
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Driss HANIB
Le #17840531
salut aristophane24


initialise effectivement ton imagelist, en décochant l'apostrophe devant
'set TreeView1.ImageList = myImageList

et en changeant MyImageList

Driss

"aristophane24" news:
Bonjour,
Ci-dessous voici un code de microsoft trouvé à cette adresse :
http://support.microsoft.com/kb/184975/EN-US/
J'ai un problème sur mon propre treeview. Et c'est le même quand j'essaye
d'utiliser ce code. Si je résous le problème avec ce code, je pourrai
résoudre
le mien.
Le navigateur m'affiche : L'imagelist doit être initialisée avant de
pouvoir
être utilisée.

<HTML>
<HEAD>

<SCRIPT LANGUAGE="VBScript">
<!--

Option Explicit

Sub Window_OnLoad()
Dim newNode

'set TreeView1.ImageList = myImageList

Set newNode = TreeView1.Nodes.Add(,,"KEY10088","Test1")
newNode.expanded=true
newNode.Image=1

Set newNode = TreeView1.Nodes.Add("KEY10088",4,"KEY10089","Test2")
newNode.Tag = "10089"
newNode.Image=1

Set newNode = TreeView1.Nodes.Add("KEY10088",4,"KEY10090","Test3")
newNode.Tag = "10090"
newNode.Image=1

End Sub
-->
</SCRIPT>
</HEAD>
<BODY>



<OBJECT id=myImageList
style="LEFT: 0px; TOP: 0px"
dataÚta:application/x-oleobject;base64,I38kLJGF0RGxagDA8Cg2KCFDNBIIAAAA7QMAAO0DAACAfuHmAgAFADIAAAAQABAA/wD/AP//QQAB782rAAAFAIFsqHdBAEEA/////////wBoeCIAAgAAAAEGAAAAQwBhAG0AZQByAGEAAAIAAAABAAAAbHQAAPYAAABCTfYAAAAAAAAAdgAAACgAAAAQAAAAEAAAAAEABAAAAAAAgAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAACAAACAAAAAgIAAgAAAAIAAgACAgAAAgICAAMDAwAAAAP8AAP8AAAD//wD/AAAA/wD/AP//AAD///8AiIiIiIiIiIiIiIiIiIiIiIiIiIiIiIiIiIiIcAeIiIiHAAAAAAAAeIB3AHd3AHcIgHcHd3dwdwiAdweHd3B3CIB3B/h3cHcIgP8Ad3cA/wiA//AAAA//CIAAAAAAAAAIiACHD/B4AIiIiIhwB4iIiIiIiIiIiIiIiIiIiIiIiIgCAAAAbHQAAOYBAABCTeYBAAAAAAAANgAAACgAAAAMAAAADAAAAAEAGAAAAAAAsAEAAMQOAADEDgAAAAAAAAAAAAD///////////////////8AAAAAAAAAAAD///////////////////////////////8AAAAAAAAAAAAAAAD///////////////////////////8AAAAAAAAAAAAAAAAAAAAAAAD///////////////////////8AAAAAAAAAAAAAAAAAAAAAAAAAAAD///////////////////8AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAD///////////8AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAD///////////8AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAD///////8AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAD///8AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAD///8AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAD///////////////////////////////////////////////////////////////////////////////////////////////8 > classid=clsid:2C247F23-8591-11D1-B16A-00C0F0283628>
</OBJECT>

<OBJECT ID="TreeView1" WIDTH0 HEIGHT0
CLASSID="CLSID:C74190B6-8589-11D1-B16A-00C0F0283628">
<PARAM NAME="_ExtentX" VALUE="2646">
<PARAM NAME="_ExtentY" VALUE="2646">
<PARAM NAME="_Version" VALUE="327682">
<PARAM NAME="Style" VALUE="7">
<PARAM NAME="Appearance" VALUE="1">
<PARAM NAME="ImageList" VALUE="myImageList">
</OBJECT>
</BODY>
</HTML>


Cordialement,
Nikos


aristophane24
Le #17868801
Driss HANIB a écrit le 14/11/2008 à 13h15 :
salut aristophane24


initialise effectivement ton imagelist, en décochant l'apostrophe devant
'set TreeView1.ImageList = myImageList

et en changeant MyImageList

Driss

"aristophane24" a écrit
dans le message de
news:
Bonjour,
Ci-dessous voici un code de microsoft trouvé à cette adresse :
http://support.microsoft.com/kb/184975/EN-US/
J'ai un problème sur mon propre treeview. Et c'est le même quand
j'essaye
d'utiliser ce code. Si je résous le problème avec ce code, je
pourrai
résoudre
le mien.
Le navigateur m'affiche : L'imagelist doit être initialisée avant
de
pouvoir
être utilisée.

<HTML>
<HEAD>

<SCRIPT LANGUAGE="VBScript">
<!--

Option Explicit

Sub Window_OnLoad()
Dim newNode

'set TreeView1.ImageList = myImageList

Set newNode = TreeView1.Nodes.Add(,,"KEY10088","Test1")
newNode.expanded=true
newNode.Image=1

Set newNode =
TreeView1.Nodes.Add("KEY10088",4,"KEY10089","Test2")
newNode.Tag = "10089"
newNode.Image=1

Set newNode =
TreeView1.Nodes.Add("KEY10088",4,"KEY10090","Test3")
newNode.Tag = "10090"
newNode.Image=1

End Sub
-->
</SCRIPT>
</HEAD>
<BODY>



<OBJECT id=myImageList
style="LEFT: 0px; TOP: 0px"
dataÚta:application/x-oleobject;base64,I38kLJGF0RGxagDA8Cg2KCFDNBIIAAAA7QMAAO0DAACAfuHmAgAFADIAAAAQABAA/wD/AP//QQAB782rAAAFAIFsqHdBAEEA/////////wBoeCIAAgAAAAEGAAAAQwBhAG0AZQByAGEAAAIAAAABAAAAbHQAAPYAAABCTfYAAAAAAAAAdgAAACgAAAAQAAAAEAAAAAEABAAAAAAAgAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAACAAACAAAAAgIAAgAAAAIAAgACAgAAAgICAAMDAwAAAAP8AAP8AAAD//wD/AAAA/wD/AP//AAD///8AiIiIiIiIiIiIiIiIiIiIiIiIiIiIiIiIiIiIcAeIiIiHAAAAAAAAeIB3AHd3AHcIgHcHd3dwdwiAdweHd3B3CIB3B/h3cHcIgP8Ad3cA/wiA//AAAA//CIAAAAAAAAAIiACHD/B4AIiIiIhwB4iIiIiIiIiIiIiIiIiIiIiIiIgCAAAAbHQAAOYBAABCTeYBAAAAAAAANgAAACgAAAAMAAAADAAAAAEAGAAAAAAAsAEAAMQOAADEDgAAAAAAAAAAAAD///////////////////8AAAAAAAAAAAD///////////////////////////////8AAAAAAAAAAAAAAAD///////////////////////////8AAAAAAAAAAAAAAAAAAAAAAAD///////////////////////8AAAAAAAAAAAAAAAAAAAAAAAAAAAD///////////////////8AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAD///////////8AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAD///////////8AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAD///////8AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAD///8AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAD///8AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAD///////////////////////////////////////////////////////////////////////////////////////////////8
> classid=clsid:2C247F23-8591-11D1-B16A-00C0F0283628>
</OBJECT>

<OBJECT ID="TreeView1" WIDTH0 HEIGHT0
CLASSID="CLSID:C74190B6-8589-11D1-B16A-00C0F0283628">
<PARAM NAME="_ExtentX" VALUE="2646">
<PARAM NAME="_ExtentY" VALUE="2646">
<PARAM NAME="_Version" VALUE="327682">
<PARAM NAME="Style" VALUE="7">
<PARAM NAME="Appearance" VALUE="1">
<PARAM NAME="ImageList" VALUE="myImageList">
</OBJECT>
</BODY>
</HTML>


Cordialement,
Nikos





Bonjour,

Je te remercie pour ta réponse. J'ai bien décoché l'apostrophe mais ça ne marche pas.
Que veux-tu dire par changer Myimagelist ?

Cordialement,
Nikos
Driss HANIB
Le #17873231
"aristophane24" news: >
Je te remercie pour ta réponse. J'ai bien décoché l'apostrophe mais ça ne
marche pas.
Que veux-tu dire par changer Myimagelist ?

Cordialement,
Nikos



Salut Nikos

tu as mis dans ta feuille une ImageListe qui a un nom soit celui par défaut,
soit celui que tu as donné.
Il faut donc que tu mettes ce nom à la place de "Myimagelist "..
est-ce fait ?

Driss
Publicité
Poster une réponse
Anonyme