Impossible d'ajouter enregistrements.

Le
Thierry_
Bonjour,
Je suis confronté à ce problème: Impossible d'ajouter un enregistrement.
Voici la requête:

SELECT DISTINCTROW CMD.*, CLI.*
FROM CMD LEFT JOIN CLI ON CMD.NUM_CLI = CLI.num_cli
ORDER BY CMD.NUM_CMD;

Dans ma table CLI, num_cli est un numéro auto
Dans ma table CMD, NUM_CLI est entier long
La relation est: afficher tous les éléments de la table CMD et
seulementCLI

Les flèches de défilement sont fonctionnelles SAUF celle avec une * supposée
ajouiter un nouvel enregistrement dans la table CMD, qui est grisée.

Ce doit être une bêtise, mais je ne trouve pas.
Merci pour votre aide précieuse

Thierry
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Thierry_
Le #20000621
J'ai oublié de préciser : Access 2003, à jour


SELECT DISTINCTROW CMD.*, CLI.*
FROM CMD LEFT JOIN CLI ON CMD.NUM_CLI = CLI.num_cli
ORDER BY CMD.NUM_CMD;

Dans ma table CLI, num_cli est un numéro auto
Dans ma table CMD, NUM_CLI est entier long
La relation est: afficher tous les éléments de la table CMD et
seulement...CLI

Les flèches de défilement sont fonctionnelles SAUF celle avec une *
(supposée ajouter un nouvel enregistrement dans la table CMD), qui est
grisée.

Ce doit être une bêtise, mais je ne trouve pas.
Merci pour votre aide précieuse

Thierry



Thierry_
Le #20002841
Trouvé !
Ca se passait dans ma table CLI. Je l'ai remarqué parceque toutes les
requêtes faisant appel à la table CLI présentaien la même anomalie.
Je l'ai exportée en Excel, CLI.XLS, supprimé/renommé la table CLI en CLI_BAD
Puis enfin importé ma table CLI.XLS
Et ça marche ! grand soulagement.

J'avais au préalable tenté d'importer tous les objets dans une nouvelle BDD,
mais sans succès.

Thierry

"Thierry_" %
Bonjour,
Je suis confronté à ce problème: Impossible d'ajouter un enregistrement.
Voici la requête:

SELECT DISTINCTROW CMD.*, CLI.*
FROM CMD LEFT JOIN CLI ON CMD.NUM_CLI = CLI.num_cli
ORDER BY CMD.NUM_CMD;

Dans ma table CLI, num_cli est un numéro auto
Dans ma table CMD, NUM_CLI est entier long
La relation est: afficher tous les éléments de la table CMD et
seulement...CLI

Les flèches de défilement sont fonctionnelles SAUF celle avec une *
supposée ajouiter un nouvel enregistrement dans la table CMD, qui est
grisée.

Ce doit être une bêtise, mais je ne trouve pas.
Merci pour votre aide précieuse

Thierry



Publicité
Poster une réponse
Anonyme