Impossible d'installer Codec

Le
Guy DETIENNE
Bonjour à tous,

J’ai un problème devant lequel je suis démuni et ce n’est pas faute d’avoir
cherché.
Depuis peu, il m’est impossible de lire des flux vidéo, que ce soit un DVD,
DivX, AVI ou autres.

Je l’ai remarqué en lançant PowerDVD 7. Lorsque j’ai voulu visionner un DVD
j’ai eu le message « Classe non enregistrée ».

J’ai dans un premier temps réinstallé PowerDVD. Sans succès.
J'ai remarqué aussi que Media Player ne sait plus rien lire, idem pour
DVD-Shrink et Nero Recode. Je suppose que tous les logiciels utilisant les
codec communs sont dans le même cas.

J’ai alors téléchargé les derniers Codec de K-Lite et ai installé le tout.
Lors de l’installation j’ai eu quelques messages me disant que certains
fichiers avec l’extension ‘ax’ (fichiers style : divxdec.ax, xvid.ax,…)
n’avaient pu être enregistrés, certaines DLL aussi.

J’ai donc décidé de désinstaller l’ancien package de Codec et là certains
messages me disaient qu’il était impossible de ‘désenregistrer’ les mêmes
fichiers…

J’ai lancé Codec-Sniper afin de visualiser l’état de mes Codec. Et
bizarrement aucun des Codec posant problème lors de l’installation n’étaient
présents dans la liste.
J’en conclu donc que ceux-ci ne sont pas installés et qu’il ne m’est pas
possible de les installer non plus. Pourtant ce sont les codec standards
pour lire du DivX, Mpeg2, …

J’ai alors tenté de faire tout cela en mode sans échec. Sans succès, mêmes
messages.
J’ai alors viré tous les fichiers .ax et DLL incriminés et ai effacé toutes
les entrées (CLSID) dans la base de registres.

J’ai essayé à nouveau d’installer les Codec, et pas de chance… nouvel échec,
mêmes messages.

J’ai aussi réinstallé DirectX sachant que DirectShow inclus ses Codec,
encore un échec. J’ai réinstallé le SP2 de XP. Et… Rien du tout.
L’installation des Codec reste impossible !

Ceci dit je peux toujours utiliser le très bon lecteur VLC Media Player qui
lui utilise ses propres Codec.

En cherchant sur le net, je ne trouve rien correspondant à mon cas.
Cela serait étrange que je sois le seul ayant ce problème !

Si la dernière chose à faire est de réinstaller mon système, cela confortera
mon idée que Windows est réellement un OS de m….. Mais cela n’engage que moi
;O)

Merci à tous.

Guy
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Coucou à toutes et à tous
Le #1262312
Bonjour !

Auriez-vous installé Net. Framework 3.0 ? Si oui, essayez de le désinstaller
pour voir si les choses s'améliorent.

--
Cordialement

=========== Jean-Jacques V.
M.V.P. Microsoft
Guy DETIENNE
Le #1262311
Bonjour,

En effet, j'ai installé il y a peu Visual Studio 2005.
Ceci dit, il me semble que ce n'est pas la framework 3.0 qui est installée
avec VS 2005 mais la 2.0.
Je tenterai l'aventure ce soir.. Je croise le doigts !
Mais il me serait très contraignant de devoir me passer de VS 2005 pour
pouvoir lire mes fichiers vidéo...

Merci pour la piste.

Guy



Bonjour !

Auriez-vous installé Net. Framework 3.0 ? Si oui, essayez de le désinstaller
pour voir si les choses s'améliorent.

--
Cordialement

=========== > Jean-Jacques V.
M.V.P. Microsoft





user
Le #1262267
Le 05/24/2007 11:57 AM, Guy DETIENNE a tapoté avec ses mimines :
Bonjour,

En effet, j'ai installé il y a peu Visual Studio 2005.
Ceci dit, il me semble que ce n'est pas la framework 3.0 qui est installée
avec VS 2005 mais la 2.0.
Je tenterai l'aventure ce soir.. Je croise le doigts !
Mais il me serait très contraignant de devoir me passer de VS 2005 pour
pouvoir lire mes fichiers vidéo...

Merci pour la piste.

Guy



Bonjour !

Auriez-vous installé Net. Framework 3.0 ? Si oui, essayez de le désinstaller
pour voir si les choses s'améliorent.

--
Cordialement

=========== >> Jean-Jacques V.
M.V.P. Microsoft



Bonjour,


essayez de lire vos vidéos avec VLC (excellent freeware qui contient ses
propres codecs)

Tenez-nous au courant


Guy DETIENNE
Le #1262092
Bonjour,

Je reviens avec mon problème.
En fai,t je n'avais pas installé VS2005 sur ma machine, j'ai confondu avec
celle de mon boulot...
Je n'aivais que VB 2005 Express avec le Framework 2. Soit.
Ceci dit, j'ai de manière hasardeuse réglé mon problème. Temporairement
peut-être ?

Vu que l'enregistrement dans la registry bloquait, j'ai téléchargé Regmon
afin de sniffer ce qui se passait lors de l'accès au registre.
Et bizzarement lorsque j'ai installé K-Lite codec avec en arrière plan
Regmon sniffant le tout, l'enregistrement des Codec s'est passé sans
problème... Je n'y comprends rien, d'autant plus que j'ai tenté
l'installation 2 minutes plus tôt sans Regmon et sans succès ! Regmon
aurait-il un effet bénéfique sur la base des registres ?

Voilà... Je craignais devoir réinstaller WinXp, moi voilà sans doute avec
un peu de sursis.
Une fois de plus, je règle un problème sans comprendre la vraie raison.

Encore merci.

Guy




"Coucou à toutes et à tous" message de news: %
Bonjour !

Auriez-vous installé Net. Framework 3.0 ? Si oui, essayez de le
désinstaller pour voir si les choses s'améliorent.

--
Cordialement

=========== > Jean-Jacques V.
M.V.P. Microsoft



Publicité
Poster une réponse
Anonyme