Impossible de monter un disque USB après week-end

Le
Julien
Bonjour a tous,

J'ai un problème monter mon disque externe USB. La semaine dernière, il
se montait bien, ligne correcte dans fstab /dev/disk/by-UUID/. Je
l'ai éteint ce week-end. Je le rebranche sur la même machine : plus de
"device" dans /dev/disk/by-UUID/ correspondant à mon disque. J'ai les
erreurs suivantes sur la console texte (Ctrl+Alt+F1) :

usb 3-3.1 : unable to read config index 0 descriptor/start : -75
usb 3-3.1 : chopping to 0 configs
usb 3-3.1 : ep0 maxpacket = 16
usb 3-3.1 : device descriptor read/64, error -32
usb 3-3.1 : device not accepting address 59, error -32
.
hub 3-3:1.0 : unable to enumerate USB device on port 1

can't set config #1, error -71

Cette série d'erreur apparaisse en boucle toute les 10 sec environ. J'ai
monté le disque sur un système *payant* ça fonctionne. Je l'ai monté sur
une autre machine même distrib même noyau ça fonctionne.

J'ai eu le même pb avec un téléphone avec prise USB au début plus de
montage possible sous Debian mais ça fonctionnait sur MAC OSX et au
retour de vacances plus de connexion possible sur le mac même genre
d'erreur device descriptor read/64, error -32.

Je pense que je ne doit pas être le seul à avoir ce pb ! pourtant Google
n'est pas très explicite la dessus. Si quelqu'un a une idée !

Distrib Lenny, noyau 2.6.26-2-amd64, tous les paquets à jour.

Merci d'avance,
Julien.


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Julien
Le #20203261
Un "rmmod ehci_hcd" règle le problème, mais à quoi sert ce module
alors ? est-ce "dangeureux" de le blacklister ?

Julien

Le mardi 22 septembre 2009 à 16:53 +0200, Julien a écrit :
Bonjour a tous,

J'ai un problème monter mon disque externe USB. La semaine dernière, il
se montait bien, ligne correcte dans fstab /dev/disk/by-UUID/.... Je
l'ai éteint ce week-end. Je le rebranche sur la même machine : plus de
"device" dans /dev/disk/by-UUID/ correspondant à mon disque. J'ai les
erreurs suivantes sur la console texte (Ctrl+Alt+F1) :

usb 3-3.1 : unable to read config index 0 descriptor/start : -75
usb 3-3.1 : chopping to 0 configs
usb 3-3.1 : ep0 maxpacket = 16
usb 3-3.1 : device descriptor read/64, error -32
usb 3-3.1 : device not accepting address 59, error -32
....
hub 3-3:1.0 : unable to enumerate USB device on port 1
...
can't set config #1, error -71

Cette série d'erreur apparaisse en boucle toute les 10 sec environ. J'ai
monté le disque sur un système *payant* ça fonctionne. Je l'ai monté sur
une autre machine même distrib même noyau ça fonctionne.

J'ai eu le même pb avec un téléphone avec prise USB au début plus de
montage possible sous Debian mais ça fonctionnait sur MAC OSX et au
retour de vacances plus de connexion possible sur le mac même genre
d'erreur device descriptor read/64, error -32.

Je pense que je ne doit pas être le seul à avoir ce pb ! pourtant Google
n'est pas très explicite la dessus. Si quelqu'un a une idée !

Distrib Lenny, noyau 2.6.26-2-amd64, tous les paquets à jour.

Merci d'avance,
Julien.





--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Jean-Yves F. Barbier
Le #20203331
Julien a écrit :
Un "rmmod ehci_hcd" règle le problème, mais à quoi sert ce module
alors ? est-ce "dangeureux" de le blacklister ?



c'est la partie du driver qui prend en compte l'USB 2.0, donc sans,
tu n'as que du 1.1

--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Sylvain Sauvage
Le #20203641
’lut,

Julien, mardi 22 septembre 2009, 17:36:02 CEST

Un "rmmod ehci_hcd" règle le problème,



Hmm, plutôt « contourné » que « r ésolu » donc.

mais à quoi sert ce module
alors ? est-ce "dangeureux" de le blacklister ?



ehci = USB 2.0
uhci|ohci = USB 1.0/1.1 (u|o suivant fabricant)

Sans ehci_hcd, tu passes en FullSpeed (12 Mb/s) au lieu
d’utiliser le HighSpeed (480 Mb/s).
(USB 3.0 apporte SuperSpeed (4,8 Gb/s). Oui, la facilité de
confusion est à dessein…)

En comparaison, le SATA 2, c’est 3 Gb/s.

Toutes ces valeurs sont théoriques. En pratique, tu peux
diviser en gros par trois (et donc par 24 pour l’avoir en
octets et tu peux enlever 5 % pour le passage en Mibi…) :
— hdparm te dira ~120 Mo/s (≈ 1 Gb/s) pour u n disque SATA 2 ;
— tu auras 20-30 Mo/s en USB 2.0 ;
— et ~1 Mo/s avec le vent dans le dos en USB 1.1.

Donc pas dangereux mais gênant. (Je crois qu’il y a la
possibilité de désactiver le ehci sur certains ports…)

Sinon, tu as essayé différents câbles ou connecteurs ?

--
Sylvain Sauvage

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Publicité
Poster une réponse
Anonyme