Imprimante usb qui n'est plus reconnue

Le
Christophe Raverdy
Bonjour

J'utilise Ubuntu 9.04 et j'effectue régulièrement les mises à jour de
sécurité.

De mémoire, il me semble avoir procédé récemment à une mise à jour
concernant CUPS.

Hier j'ai voulu imprimer : Tout semble ok (dans le meilleur des cas)
mais rien ne sort (j'ai une samsung CPL-300).

Le problème semble tourner autour d'une question d'authentification.

Avez-vous des suggestions pour que je puisse localiser précisément le
problème et:ou le résoudre ?
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Christophe Raverdy
Le #20020691
Bonjour.

Sergio a écrit :

Un tour vers le serveur CUPS http://localhost:631/ ? (quand il demande
un mot de passe : login/pass d'un utilisateur ayant les droits
d'administrer les imprimantes).



Merci pour l'adresse du serveur. J'en ai profité pour m'autoriser à
accéder à l'imprimante (c'est du moins ce que j'ai demandé).


Sinon, pas remarqué de problèmes chez moi (CLP-300 et Ubuntu 9.04 à jour).




A l'arrivée j'obtiens :

"Unable to open device
"hal:///org/freedesktop/Hal/devices/usb_device_4e8_3272_3Y21BAHP822128F__if0_printer_noserial":
Permission denied"


Les logs donnent :


D [30/Aug/2009:20:06:44 +0200] cupsdAcceptClient: 8 from localhost (Domain)
D [30/Aug/2009:20:06:44 +0200] Report: clients=1
D [30/Aug/2009:20:06:44 +0200] Report: jobs=1
D [30/Aug/2009:20:06:44 +0200] Report: jobs-active=0
D [30/Aug/2009:20:06:44 +0200] Report: printers=2
D [30/Aug/2009:20:06:44 +0200] Report: printers-implicit=0
D [30/Aug/2009:20:06:44 +0200] Report: stringpool-string-countr2
D [30/Aug/2009:20:06:44 +0200] Report: stringpool-alloc-bytes’88
D [30/Aug/2009:20:06:44 +0200] Report: stringpool-total-bytes568
D [30/Aug/2009:20:06:44 +0200] cupsdReadClient: 8 POST / HTTP/1.1
D [30/Aug/2009:20:06:44 +0200] cupsdAuthorize: No authentication data
provided.
D [30/Aug/2009:20:06:44 +0200] CUPS-Get-Printers
D [30/Aug/2009:20:06:44 +0200] cupsdProcessIPPRequest: 8 status_code=0
(successful-ok)
D [30/Aug/2009:20:06:44 +0200] cupsdReadClient: 8 POST / HTTP/1.1
D [30/Aug/2009:20:06:44 +0200] cupsdAuthorize: No authentication data
provided.
D [30/Aug/2009:20:06:44 +0200] CUPS-Get-Classes
D [30/Aug/2009:20:06:44 +0200] cupsdProcessIPPRequest: 8 status_code=0
(successful-ok)
D [30/Aug/2009:20:06:44 +0200] cupsdReadClient: 8 POST / HTTP/1.1
D [30/Aug/2009:20:06:44 +0200] cupsdAuthorize: No authentication data
provided.
D [30/Aug/2009:20:06:44 +0200] CUPS-Get-Default
D [30/Aug/2009:20:06:44 +0200] CUPS-Get-Default client-error-not-found:
No default printer
D [30/Aug/2009:20:06:44 +0200] cupsdProcessIPPRequest: 8
(client-error-not-found)
D [30/Aug/2009:20:06:44 +0200] cupsdCloseClient: 8
D [30/Aug/2009:20:06:58 +0200] cupsdAcceptClient: 8 from localhost:631
(IPv4)
D [30/Aug/2009:20:06:58 +0200] cupsdReadClient: 8 GET
/admin/log/error_log HTTP/1.1
D [30/Aug/2009:20:06:58 +0200] cupsdAuthorize: Authorized as christophe
using Basic
Patrick Lamaizière
Le #20021981
Christophe Raverdy :

A l'arrivée j'obtiens :

"Unable to open device
"hal:///org/freedesktop/Hal/devices/usb_device_4e8_3272_3Y21BAHP822128F__if0_printer_noserial":
Permission denied"


Les logs donnent :



Je chercherais du coté de PolicyKit, visiblement cups ne soumet même pas
le job à l'imprimante

Un rapide coup de google donne ça, j'imagine qu'il doit y avoir
l'équivalent avec Ubuntu
http://cyberelk.net/tim/2009/08/11/policykit-and-printing/
Christophe Raverdy
Le #20030131
Patrick Lamaizière a écrit :

Je chercherais du coté de PolicyKit, visiblement cups ne soumet même pas
le job à l'imprimante

Un rapide coup de google donne ça, j'imagine qu'il doit y avoir
l'équivalent avec Ubuntu
http://cyberelk.net/tim/2009/08/11/policykit-and-printing/




J'ai lu, testé, et fait des recherches complémentaires mais rien n'y fait

Les logs pour la dernière tentative d'impression de page de test me
donnent entre autres :


D [01/Sep/2009:08:59:37 +0200] [Job 122]
argv[6]="/var/spool/cups/d00122-001"

:/var$ sudo ls -al /var/spool/cups/d00122-001
ls: ne peut accéder /var/spool/cups/d00122-001: Aucun fichier ou dossier
de ce type

Par contre :en remontant d'un cran je trouve :

:/var$ sudo ls -al /var/spool/cups/

total 60
drwx--x--- 3 root nogroup 4096 2009-09-01 08:59 .
drwxr-xr-x 10 root root 4096 2009-08-29 22:58 ..
[...]
-rw------- 1 root nogroup 874 2009-08-31 19:59 c00118
-rw------- 1 root nogroup 868 2009-09-01 08:40 c00119
-rw------- 1 root nogroup 719 2009-09-01 08:41 c00120
-rw------- 1 root nogroup 719 2009-09-01 08:42 c00121
-rw------- 1 root nogroup 714 2009-09-01 08:59 c00122
drwxrwx--T 2 root nogroup 4096 2009-09-01 08:59 tmp


Je trouve également par la suite :

=============================================== D [01/Sep/2009:08:59:37 +0200] [Job 122]
D [01/Sep/2009:08:59:37 +0200] [Job 122] LPGETSTATUS returned a port
status of 90...
W [01/Sep/2009:08:59:37 +0200] [Job 122] Printer fault!
I [01/Sep/2009:08:59:37 +0200] Saving subscriptions.conf...
D [01/Sep/2009:08:59:37 +0200] cupsdCloseClient: 11
D [01/Sep/2009:08:59:37 +0200] [CGI] lang="fr.UTF8", locale="/fr"...
D [01/Sep/2009:08:59:37 +0200] PID 7026
(/usr/lib/cups/cgi-bin/printers.cgi) exited with no errors.

[...]


Les informations reprises ci-dessus vous disent-elles quelque chose ?
Christophe Raverdy
Le #20040491
Christophe Raverdy a écrit :
Patrick Lamaizière a écrit :

Je chercherais du coté de PolicyKit, visiblement cups ne soumet même pas
le job à l'imprimante

Un rapide coup de google donne ça, j'imagine qu'il doit y avoir
l'équivalent avec Ubuntu
http://cyberelk.net/tim/2009/08/11/policykit-and-printing/




J'ai lu, testé, et fait des recherches complémentaires mais rien n'y fait




[...]

J'y ai été à la barbare : suppression de tous les packages "CUPS",
réinstallation via la console de CUPS ainsi que de GNOME.

J'ai également enlevé une feuille de papier (bourrage), ce qui était
sans doute le problème principal.

Donc, problème réglé.
Publicité
Poster une réponse
Anonyme