Inclure nom d'onglets dans formule

Le
PLG
Bonsoir à toutes et à tous

J'ai 12 onglets avec comme nom Janvier, février..
J'ai un onglet Récap
Sur la page Récap, j'ai 2 cellules ( A1 et B1 ) avec une liste déroulante (
validation ) reprenant les mois de l'année, orthographiés comme les onglets.
Le 1er choix c'est (A1) de : et le second (B1) à :
Ce sont donc 2 mois qui vont s'afficher. Ex : de Février à Juin
J'entre cette formule =SOMME(Février:Juin!F3:F6)
C'est maintenant que vous entrez en action.
Je souhaiterais que les mois que j'entre dans ma formule soient ceux choisis
en A1 et B1 donc que ce soit automatique quelque soient les mois choisis
en A1 et B1.
Un truc avec ADRESSE INDIRECT. avec des "" bref je sais pas.
Merci d'avance à mon sauveur.
Pat
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JB
Le #20711591
Bonjour,

http://boisgontierjacques.free.fr/pages_site/sommeprod3D.htm#S3DMoisDebFin

=SOMMEPROD(SOMME.SI(INDIRECT(TEXTE(DATE(2006;LIGNE(INDIRECT(MOIS
("1/"&B2)&":"&
MOIS("1/"&B3)));1);"mmmm")&"!A1:A10");">0"))

JB
http://boisgontierjacques.free.fr

On 6 déc, 21:03, PLG
Bonsoir à toutes et à tous

J'ai 12 onglets avec comme nom Janvier, février.....
J'ai un onglet Récap
Sur la page Récap, j'ai 2 cellules ( A1 et B1 ) avec une liste déroul ante (
validation ) reprenant les mois de l'année, orthographiés comme les o nglets.
Le 1er choix c'est   (A1)  de :    et le second (B1)    à :
Ce sont donc 2 mois qui vont s'afficher. Ex : de Février à  Juin
J'entre cette formule  =SOMME(Février:Juin!F3:F6)
C'est maintenant que vous entrez en action....
Je souhaiterais que les mois que j'entre dans ma formule soient ceux choi sis
en A1 et B1... donc que ce soit automatique quelque soient les mois chois is
en A1 et B1.
Un truc avec ADRESSE... INDIRECT.... avec des ""... bref... je sais pas.
Merci d'avance à mon sauveur.
Pat


PLG
Le #20715931
Bonjour et merci Maître...!
Je connais votre site et m'y réfère souvent....!!
Là j'avais pas vu.

Encore merci et bonne soirée

"JB" wrote:

Bonjour,

http://boisgontierjacques.free.fr/pages_site/sommeprod3D.htm#S3DMoisDebFin

=SOMMEPROD(SOMME.SI(INDIRECT(TEXTE(DATE(2006;LIGNE(INDIRECT(MOIS
("1/"&B2)&":"&
MOIS("1/"&B3)));1);"mmmm")&"!A1:A10");">0"))

JB
http://boisgontierjacques.free.fr

On 6 déc, 21:03, PLG > Bonsoir à toutes et à tous
>
> J'ai 12 onglets avec comme nom Janvier, février.....
> J'ai un onglet Récap
> Sur la page Récap, j'ai 2 cellules ( A1 et B1 ) avec une liste déroulante (
> validation ) reprenant les mois de l'année, orthographiés comme les onglets.
> Le 1er choix c'est (A1) de : et le second (B1) à :
> Ce sont donc 2 mois qui vont s'afficher. Ex : de Février à Juin
> J'entre cette formule =SOMME(Février:Juin!F3:F6)
> C'est maintenant que vous entrez en action....
> Je souhaiterais que les mois que j'entre dans ma formule soient ceux choisis
> en A1 et B1... donc que ce soit automatique quelque soient les mois choisis
> en A1 et B1.
> Un truc avec ADRESSE... INDIRECT.... avec des ""... bref... je sais pas.
> Merci d'avance à mon sauveur.
> Pat

.



Publicité
Poster une réponse
Anonyme