index equiv avec 2 valeurs

Le
yannick1988 Hors ligne
Bonjour,

je voudrais faire une recherche sur 2 critères. J'ai essayé mais je n'arrive pas avec la fonction index equiv.

j'ai un tableau avec A7:A43 les bornes inférieures
B7:B43 les bornes supérieures
C7:C43 les valeurs qui doivent être renvoyée en fct de la catégorie

dans la cellule A2 j'encode une valeur

je voudrais obtenir la valeur située dans C7:C43 pour laquelle A2 est plus grand que la colonne B, et plus petit que la colonne C.


exemple
valeur encodée: 2000

min max valeur
500 1500 20
1500 2500 30
2500 3500 40

je voudrais dc obtenir le résultat 30.

Voilà j'espère que c'est compréhensible
Merci de votre aide.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
ThierryP
Le #23375851
Bonjour,

Ceci devrait le faire : =SOMMEPROD((A2>A7:A43)*(A2<B7:B43)*C7:C43)

ThierryP


On 18 mai, 11:29, yannick1988
Bonjour,

je voudrais faire une recherche sur 2 critères. J'ai essayé mais je n 'arrive
pas avec la fonction index equiv.

j'ai un tableau avec A7:A43 les bornes inférieures
B7:B43 les bornes supérieures
C7:C43 les valeurs qui doivent être renvoyée en fct de la catégorie

dans la cellule A2 j'encode une valeur

je voudrais obtenir la valeur située dans C7:C43 pour laquelle A2 est p lus
grand que la colonne B, et plus petit que la colonne C.

exemple
valeur encodée: 2000

min max valeur
500 1500 20
1500 2500 30
2500 3500 40

je voudrais dc obtenir le résultat 30.

Voilà j'espère que c'est compréhensible
Merci de votre aide.
Publicité
Poster une réponse
Anonyme