Indirect onglet

Le
Tibert
Bonjour à tous
Pouvez-vous me dire ce qui ne va pas dans ma formule, les feuilles
sont nommées par la cellule (B1) par le code ci-dessous.
Dans la feuille « Reduction » j’ai bien mis au format « mmmaa »
Fichier ci-joint pour une meilleure compréhension

http://cjoint.com/?3BDs0Pru2GC

Bonne soirée à vous

*********************************************
Private Sub Worksheet_Change(ByVal Target As Range)
If Target.Address = "$B$1" Then
ActiveSheet.Name = Format([B1], "mmmyy")
End If
End Sub
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
MichD
Le #24289061
Bonjour,

Si tu tapes ceci dans une cellule :
=INDIRECT("A2") cela retourne 40909 qui est la valeur numérique de la date.
Tu n'as pas de feuille qui porte ce nom.

Si tu passes le contenu A2 au format "Texte", cela fonctionnera...



MichD
------------------------------------------
"Tibert" a écrit dans le message de groupe de discussion :


Bonjour à tous
Pouvez-vous me dire ce qui ne va pas dans ma formule, les feuilles
sont nommées par la cellule (B1) par le code ci-dessous.
Dans la feuille « Reduction » j’ai bien mis au format « mmmaa »
Fichier ci-joint pour une meilleure compréhension

http://cjoint.com/?3BDs0Pru2GC

Bonne soirée à vous

*********************************************
Private Sub Worksheet_Change(ByVal Target As Range)
If Target.Address = "$B$1" Then
ActiveSheet.Name = Format([B1], "mmmyy")
End If
End Sub
Tibert
Le #24289161
Bonsoir "MichD"
merci pour tes explications, je pensé qu'on pouvez interpréter une
formule qui aurais pris compte du format

Bonne soirée

On 29 fév, 19:58, "MichD"
Bonjour,

Si tu tapes ceci dans une cellule :
=INDIRECT("A2") cela retourne 40909 qui est la valeur numérique de la date.
Tu n'as pas de feuille qui porte ce nom.

Si tu passes le contenu A2 au format "Texte", cela fonctionnera...

MichD
------------------------------------------
"Tibert"  a écrit dans le message de groupe de discussion :


Bonjour à tous
Pouvez-vous me dire ce qui ne va pas dans ma formule, les feuilles
sont nommées par la cellule (B1) par le code ci-dessous.
Dans la feuille « Reduction » j’ai bien mis au format « mmmaa »
Fichier ci-joint pour une meilleure compréhension

http://cjoint.com/?3BDs0Pru2GC

Bonne soirée à vous

*********************************************
Private Sub Worksheet_Change(ByVal Target As Range)
    If Target.Address = "$B$1" Then
        ActiveSheet.Name = Format([B1], "mmmyy")
   End If
End Sub
Jacky
Le #24289221
Bonsoir,

En gardant les dates...
En B2
=SI(ESTERR(INDIRECT(TEXTE(A2;"mmmaa")&"!H42"));"";INDIRECT(TEXTE(A2;"mmmaa")&"!H42"))

--
Salutations
JJ


"Tibert"
Bonjour à tous
Pouvez-vous me dire ce qui ne va pas dans ma formule, les feuilles
sont nommées par la cellule (B1) par le code ci-dessous.
Dans la feuille « Reduction » j’ai bien mis au format « mmmaa »
Fichier ci-joint pour une meilleure compréhension

http://cjoint.com/?3BDs0Pru2GC

Bonne soirée à vous

*********************************************
Private Sub Worksheet_Change(ByVal Target As Range)
If Target.Address = "$B$1" Then
ActiveSheet.Name = Format([B1], "mmmyy")
End If
End Sub
Tibert
Le #24289351
Bonsoir "Jacky"

Merci pour ta réponse c'est exactement sa que je voulais !

Bonne soirée

On 29 fév, 21:08, "Jacky"
Bonsoir,

En gardant les dates...
En B2
=SI(ESTERR(INDIRECT(TEXTE(A2;"mmmaa")&"!H42"));"";INDIRECT(TEXTE(A2;"mm maa" )&"!H42"))

--
Salutations
JJ

"Tibert"
Bonjour à tous
Pouvez-vous me dire ce qui ne va pas dans ma formule, les feuilles
sont nommées par la cellule (B1) par le code ci-dessous.
Dans la feuille « Reduction » j’ai bien mis au format « mmmaa »
Fichier ci-joint pour une meilleure compréhension

http://cjoint.com/?3BDs0Pru2GC

Bonne soirée à vous

*********************************************
Private Sub Worksheet_Change(ByVal Target As Range)
    If Target.Address = "$B$1" Then
        ActiveSheet.Name = Format([B1], "mmmyy")
   End If
End Sub
Publicité
Poster une réponse
Anonyme