[Info] Influence de la désactivation de l'UAC sur certains programmes

Le
aski
Bonjour,

Je ne réussissais pas à faire fonctionner Paint Shop Pro X sur Vista
après avoir installé tous les patchs.
J'ai constaté que ce dysfonctionnement était dû à la désactivation de
l'UAC.
Je l'ai réactivée et tout fonctionne normalement normalement.

--
Cordialement
Aski

AntiSpamEdit (ASE) - XtractOE et XtractWM - K9 en français
http://dechily.org/downloads.htm
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Azo4
Le #195100
bonjour

je n'ai pas se pb avec la vertsion XI ...

amitiés

--
Serge CENCI
MVP MS Windows
https://mvp.support.microsoft.com/profile/Serge.Cenci

"aski" news:
Bonjour,

Je ne réussissais pas à faire fonctionner Paint Shop Pro X sur Vista après
avoir installé tous les patchs.
J'ai constaté que ce dysfonctionnement était dû à la désactivation de
l'UAC.
Je l'ai réactivée et tout fonctionne normalement normalement.

--
Cordialement
Aski

AntiSpamEdit (ASE) - XtractOE et XtractWM - K9 en français
http://dechily.org/downloads.htm




galida
Le #195097
Salut.
Il n'y a pas que les voies de Dieu qui sont impénétrables.
--
Daniel - galida
aski
Le #195096
Bonjour Azo4, tu as écrit le 18/01/2008 :

bonjour

je n'ai pas se pb avec la vertsion XI ...

amitiés


C'est un peu cher comme solution.
Je suis très déçu. :-(

--
Cordialement
Aski

AntiSpamEdit (ASE) - XtractOE et XtractWM - K9 en français
http://dechily.org/downloads.htm

P
Le #195094
Bonjour,

Je ne réussissais pas à faire fonctionner Paint Shop Pro X sur Vista après
avoir installé tous les patchs.
J'ai constaté que ce dysfonctionnement était dû à la désactivation de l'UAC.
Je l'ai réactivée et tout fonctionne normalement normalement.


J'ai eu un pb similaire avec conjugaison. UAC désactivé au moment de
l'installation = pas de fonctionnement correct, UAC activé et nouvelle
installation = OK !

--
Bien cordialement, Georges
Aide toi le ciel t'aidera : http://papynet.mvps.org/Forums.htm
Pour prendre contact : http://minilien.com/?1xjHkMIEp0
Pages XP : http://papynet.mvps.org/XP/XP.htm Vista :
http://papynet.mvps.org/Vista/Vista.htm

Jean-Claude BELLAMY
Le #195092
"aski" news:
Bonjour,

Je ne réussissais pas à faire fonctionner Paint Shop Pro X sur Vista après
avoir installé tous les patchs.
J'ai constaté que ce dysfonctionnement était dû à la désactivation de
l'UAC.
Je l'ai réactivée et tout fonctionne normalement normalement.


Je vis depuis toujours avec UAC désactivé, et je n'ai eu AUCUN problème pour
installer et faire fonctionner PSP X, y compris avec tous ses patchs
(actuellement version 10.10) !



--
May the Force be with You!
La Connaissance s'accroît quand on la partage
----------------------------------------------------------
Jean-Claude BELLAMY [MVP] - http://www.bellamyjc.org

P
Le #195040


Je vis depuis toujours avec UAC désactivé, et je n'ai eu AUCUN problème pour
installer et faire fonctionner PSP X, y compris avec tous ses patchs
(actuellement version 10.10) !


Rappelles toi que sur mon pb de "conjugaison" tu as séché tout comme
moi !

--
Bien cordialement, Georges
Aide toi le ciel t'aidera : http://papynet.mvps.org/Forums.htm
Pour prendre contact : http://minilien.com/?1xjHkMIEp0
Pages XP : http://papynet.mvps.org/XP/XP.htm Vista :
http://papynet.mvps.org/Vista/Vista.htm

aski
Le #195035
Bonjour Jean-Claude BELLAMY, tu as écrit le 18/01/2008 :

Je vis depuis toujours avec UAC désactivé, et je n'ai eu AUCUN problème pour
installer et faire fonctionner PSP X, y compris avec tous ses patchs
(actuellement version 10.10) !


Hier
Avant d'écrire ce message, j'ai désinstallé, redémarré, réinstallé le
logiciel, appliqué tous les patchs (1, 2, 3, 10) avec UAC désactivée.
J'ai eu droit avec la très enrichissante fenêtre de Windows :
"Paint Shop Pro X a cessé de fonctionner" (je passe les autres
commentaires inutiles).
J'ai réactivé l'UAC et PSP s'est lancé correctement.

Aujourd'hui
J'ai de nouveau désactivé l'UAC pour constater le même échec au
lancement.
Avant le message de Windows, la fenêtre de PSP indique "Initialisation
du gestionnaire de commande".
Pour davantage de billes je fais une copie du compte-rendu d'erreur de
l'observateur d'évènements.

Application défaillante Paint Shop Pro X.exe, version 10.1.0.0,
horodatage 0x45d6d3f3, module défaillant Secur32.dll, version
6.0.6000.16386, horodatage 0x4549bdd2, code d’exception 0xc0000005,
décalage d’erreur 0x000021f4, ID du processus 0x1544, heure de début de
l’application 0x01c859bc3d8afaf1.

--
Cordialement
Aski

AntiSpamEdit (ASE) - XtractOE et XtractWM - K9 en français
http://dechily.org/downloads.htm

Jean-Claude BELLAMY
Le #194919
"aski" news:
Bonjour Jean-Claude BELLAMY, tu as écrit le 18/01/2008 :

Je vis depuis toujours avec UAC désactivé, et je n'ai eu AUCUN problème
pour installer et faire fonctionner PSP X, y compris avec tous ses patchs
(actuellement version 10.10) !


Hier
Avant d'écrire ce message, j'ai désinstallé, redémarré, réinstallé le
logiciel, appliqué tous les patchs (1, 2, 3, 10) avec UAC désactivée.
J'ai eu droit avec la très enrichissante fenêtre de Windows :
"Paint Shop Pro X a cessé de fonctionner" (je passe les autres
commentaires inutiles).
J'ai réactivé l'UAC et PSP s'est lancé correctement.

Aujourd'hui
J'ai de nouveau désactivé l'UAC pour constater le même échec au lancement.
Avant le message de Windows, la fenêtre de PSP indique "Initialisation du
gestionnaire de commande".
Pour davantage de billes je fais une copie du compte-rendu d'erreur de
l'observateur d'évènements.



Je n'ai pas mis ta parole en doute, mais seulement la conclusion, à savoir
"UAC désactivé" -> plantage

Si on refléchit un peu, çà devrait plutôt être l'inverse qui se produise, vu
les restrictions entrainées par l'UAC.

Idem pour le problème de "Conjugaison" soulevé par Georges Bailly ()

Je n'ai pas tout "épluché", mais AMHA le pb se situe du côté de la
VIRTUALISATION.

Avec UAC activé, la virtualisation l'est également, sauf si on l'a
désactivée volontairement en donnant la valeur 0 à l'entrée
HKLMSOFTWAREMicrosoftWindowsCurrentVersionPoliciesSystemEnableVirtualization
(elle vaut 1 par défaut)

Je rappelle que la virtualisation permet à une application lancée sous un
compte standard de ne pas générer d'erreur si elle tente d'écrire dans des
dossiers ou clefs interdits en écriture (p.ex. %programfiles%, HKLM, ...).
Ainsi une écriture de fichier dans %programfiles% se fera en réalité dans
%LOCALAPPDATA%VirtualStore.

Mais si la virtualisation est désactivée (parce que UAC est désactivé
p.ex.), et si on tente d'écrire dans %programfiles% alors qu'on n'a pas
modifié les droits sur ce dossier, il va y avoir plantage !

La désactivation d'UAC entraine donc un plantage MAIS UNIQUEMENT parce qu'il
y a toute une usine à gaz derrière (la virtualisation) ! ;-)

--
May the Force be with You!
La Connaissance s'accroît quand on la partage
----------------------------------------------------------
Jean-Claude BELLAMY [MVP] - http://www.bellamyjc.org


Exelmans
Le #194916
"Jean-Claude BELLAMY" >
- - - -
Je n'ai pas tout "épluché", mais AMHA le pb se situe du côté de
la VIRTUALISATION.

Avec UAC activé, la virtualisation l'est également, sauf si on
l'a désactivée volontairement en donnant la valeur 0 à l'entrée

HKLMSOFTWAREMicrosoftWindowsCurrentVersionPoliciesSystemEnableVirtualization
(elle vaut 1 par défaut)

- - - -


Rien ne semble empêcher de désactiver l'UAC en laissant la
Virtualisation activer !
C'est comme ça chez moi, mais je n'ai aucun des 2 logiciels cités
pour conclure !


--
Ex.

aski
Le #194914
Bonjour Jean-Claude BELLAMY, tu as écrit le 18/01/2008 :

Je n'ai pas mis ta parole en doute,


Moi non plus. :o)


mais seulement la conclusion, à savoir
"UAC désactivé" -> plantage


Cette conclusion est vraie sur PSP X chez moi.

Si on refléchit un peu, çà devrait plutôt être l'inverse qui se produise, vu
les restrictions entrainées par l'UAC.


Je suis bien d'accord avec toi.
Ceci signifie que quelque chose est différent du standard de
configuration chez toi et chez moi, chez toi ou chez moi.
Je n'ai malheureusement de Vista vierge pour faire le test sur une
machine virtuelle.
Je pense quand même que PSP X a besoin (chez moi) d'un fichier auquel
il ne peut accéder lorsque l'UAC est désactivée.

--
Cordialement
Aski

AntiSpamEdit (ASE) - XtractOE et XtractWM - K9 en français
http://dechily.org/downloads.htm

Publicité
Poster une réponse
Anonyme