Install compiz-fusion-kde

Le
M. ROUIN Bernard
Bonjour à tous,
Je viens d'installer une Débian Etch stable et je souhaiterai avoir
Compiz-fusion pour Kde.
Mais je n'arrive pas à l'installer malgrés de multiples recherches sur =
le
toile. Aucun des paquets mentionnés ne veux s'installer séparémment.

Les messages de la konsole :
debian:/home/bernard01# apt-get install compiz-fusion-kde
Lecture des listes de paquets Fait
Construction de l'arbre des dépendances Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
Puisque vous n'avez demandé qu'une seule opération, le paquet n'est
probablement pas installable et vous devriez envoyer un rapport de bogue.
L'information suivante devrait vous aider à résoudre la situation :
Les paquets suivants contiennent des dépendances non satisfaites :
compiz-fusion-kde: Dépend: compiz-core (>= 0.7.3) mais ne sera pas in=
stallé
Dépend: compiz-plugins (>= 0.7.3) mais ne sera pas=

installé
Dépend: compiz-kde (>= 0.7.3) mais ne sera pas ins=
tallé
Dépend: libdecoration0 (>= 0.7.3) mais ne sera pas=

installé
Dépend: libcompizconfig0 (>= 0.7.3) mais ne sera p=
as
installé
Dépend: compizconfig-backend-kconfig (>= 0.7.3) ma=
is ne
sera pas installé
Dépend: python-compizconfig (>= 0.7.3) mais ne ser=
a pas
installé
Dépend: compizconfig-settings-manager (>= 0.7.3) m=
ais ne
sera pas installé
Dépend: compiz-fusion-bcop (>= 0.7.3) mais ne sera=
pas
installé

Mon source.list :
deb http://ftp.fr.debian.org/debian/ etch main
deb-src http://ftp.fr.debian.org/debian/ etch main
## security
deb http://security.debian.org/ etch/updates main contrib non-free
deb-src http://security.debian.org/ etch/updates main contrib non-free
# non free
deb http://ftp.fr.debian.org/debian/ stable main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ stable main contrib non-free
# multimedia
deb http://www.debian-multimedia.org etch main
#Compiz-fusion
deb http://download.tuxfamily.org/shames/debian-sid/desktopfx/unstable/ ./ =


Certains y sont arrivés, donc c'est possible. Ma carte graphique est une =
ATI
Radeon 9800SE correctement pris en charge par le systéme.
Qu'est ce qui ne va pas ? Vos aides et conseils me seraient d'un grand
secours. Bien entendue si vous avez besoin de renseignements
supplementaires
Merci d'avance.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Hugues Larrive
Le #9678191
This is an OpenPGP/MIME signed message (RFC 2440 and 3156)
--------------enig32C6FDE612FADEACA7E4FD3D
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

M. ROUIN Bernard a écrit :
Bonjour à tous,
Je viens d'installer une Débian Etch stable et je souhaiterai avoir
Compiz-fusion pour Kde.
Mais je n'arrive pas à l'installer malgrés de multiples recherches sur le
toile. Aucun des paquets mentionnés ne veux s'installer séparémme nt.

Les messages de la konsole :
debian:/home/bernard01# apt-get install compiz-fusion-kde
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
Puisque vous n'avez demandé qu'une seule opération, le paquet n'est
probablement pas installable et vous devriez envoyer un rapport de bogu e.
L'information suivante devrait vous aider à résoudre la situation :
Les paquets suivants contiennent des dépendances non satisfaites :
compiz-fusion-kde: Dépend: compiz-core (>= 0.7.3) mais ne sera pa s installé
Dépend: compiz-plugins (>= 0.7.3) mais ne sera pas
installé
Dépend: compiz-kde (>= 0.7.3) mais ne sera pas installé
Dépend: libdecoration0 (>= 0.7.3) mais ne sera pas
installé
Dépend: libcompizconfig0 (>= 0.7.3) mais ne se ra pas
installé
Dépend: compizconfig-backend-kconfig (>= 0.7.3 ) mais ne
sera pas installé
Dépend: python-compizconfig (>= 0.7.3) mais ne sera pas
installé
Dépend: compizconfig-settings-manager (>= 0.7. 3) mais ne
sera pas installé
Dépend: compiz-fusion-bcop (>= 0.7.3) mais ne sera pas
installé

Mon source.list :
deb http://ftp.fr.debian.org/debian/ etch main
deb-src http://ftp.fr.debian.org/debian/ etch main
## security
deb http://security.debian.org/ etch/updates main contrib non-free
deb-src http://security.debian.org/ etch/updates main contrib non-free
# non free
deb http://ftp.fr.debian.org/debian/ stable main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ stable main contrib non-free
# multimedia
deb http://www.debian-multimedia.org etch main
#Compiz-fusion
deb http://download.tuxfamily.org/shames/debian-sid/desktopfx/unstable/ ./

Certains y sont arrivés, donc c'est possible. Ma carte graphique est une ATI
Radeon 9800SE correctement pris en charge par le systéme.
Qu'est ce qui ne va pas ? Vos aides et conseils me seraient d'un grand
secours. Bien entendue si vous avez besoin de renseignements
supplementaires...
Merci d'avance.




Ce qui ne va pas c'est que tu est sous etch (stable) et que tu veux
installer des paquets prévu pour sid (unstable).
Tu devrais commencer par enlever la dernière ligne de ton source.list.
Si tu es sous gnome installes d'abord la version etch de compiz :
apt-get install compiz-gnome

Si tu es sous kde il y a une version pour etch dans backports :
deb http://www.backports.org/debian etch-backports main contrib non-free
deb-src http://www.backports.org/debian etch-backports main contrib non-f ree

apt-get update && apt-get install compiz-kde

L'installation devrait se faire sans problème.

Après tu modifie ton xorg.conf comme expliqué sur le site de
compiz-fusion, tu redémarres ou tu relances seulement le gestionnaire d e
session, et tu tapes "compiz --replace" dans un terminal (utilisateur)
pour voir ce qui se passe.

Personellement les effets de la vieille version de compiz dans etch me
suffisent, maintenant si tu en veux plus tu peux soit passer en lenny
(testing), soit essayer de rétro-porter compiz-fusion sur etch.

@+


--------------enig32C6FDE612FADEACA7E4FD3D
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFIH4l6NdTZuHWpgVIRAtWlAJ92ElonfztKsyBxqNKEstxd6Iu0hACbB7q2
ZGbmEisBgy4cJ4WfT7ZKXmI =/U9U
-----END PGP SIGNATURE-----

--------------enig32C6FDE612FADEACA7E4FD3D--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Bernard
Le #9677671
On Tuesday 06 May 2008 00:25:57 Hugues Larrive wrote:
M. ROUIN Bernard a écrit :
> Bonjour à tous,
> Je viens d'installer une Débian Etch stable et je souhaiterai avoir
> Compiz-fusion pour Kde.
> Mais je n'arrive pas à l'installer malgrés de multiples reche rches sur le
> toile. Aucun des paquets mentionnés ne veux s'installer sépar émment.
>
> Les messages de la konsole :
> debian:/home/bernard01# apt-get install compiz-fusion-kde
> Lecture des listes de paquets... Fait
> Construction de l'arbre des dépendances... Fait
> Certains paquets ne peuvent être installés. Ceci peut signifi er
> que vous avez demandé l'impossible, ou bien, si vous utilisez
> la distribution unstable, que certains paquets n'ont pas encore
> été créés ou ne sont pas sortis d'Incoming.
> Puisque vous n'avez demandé qu'une seule opération, le paquet n'est
> probablement pas installable et vous devriez envoyer un rapport de bogu e.
> L'information suivante devrait vous aider à résoudre la situa tion :
> Les paquets suivants contiennent des dépendances non satisfaites :
> compiz-fusion-kde: Dépend: compiz-core (>= 0.7.3) mais ne sera pas
> installé Dépend: compiz-plugins (>= 0.7.3) mais ne sera pas installé
> Dépend: compiz-kde (>= 0.7.3) mais ne sera pas
> installé Dépend: libdecoration0 (>= 0.7.3) mais ne sera pas installé
> Dépend: libcompizconfig0 (>= 0.7.3) mais ne sera pas
> installé
> Dépend: compizconfig-backend-kconfig (>= 0. 7.3) mais
> ne sera pas installé
> Dépend: python-compizconfig (>= 0.7.3) mais ne sera
> pas installé
> Dépend: compizconfig-settings-manager (>= 0 .7.3)
> mais ne sera pas installé
> Dépend: compiz-fusion-bcop (>= 0.7.3) mais ne sera
> pas installé
>
> Mon source.list :
> deb http://ftp.fr.debian.org/debian/ etch main
> deb-src http://ftp.fr.debian.org/debian/ etch main
> ## security
> deb http://security.debian.org/ etch/updates main contrib non-free
> deb-src http://security.debian.org/ etch/updates main contrib non-free
> # non free
> deb http://ftp.fr.debian.org/debian/ stable main contrib non-free
> deb-src http://ftp.fr.debian.org/debian/ stable main contrib non-free
> # multimedia
> deb http://www.debian-multimedia.org etch main
> #Compiz-fusion
> deb http://download.tuxfamily.org/shames/debian-sid/desktopfx/unstable/
> ./
>
> Certains y sont arrivés, donc c'est possible. Ma carte graphique e st une
> ATI Radeon 9800SE correctement pris en charge par le systéme.
> Qu'est ce qui ne va pas ? Vos aides et conseils me seraient d'un grand
> secours. Bien entendue si vous avez besoin de renseignements
> supplementaires...
> Merci d'avance.

Ce qui ne va pas c'est que tu est sous etch (stable) et que tu veux
installer des paquets prévu pour sid (unstable).
Tu devrais commencer par enlever la dernière ligne de ton source.lis t.
Si tu es sous gnome installes d'abord la version etch de compiz :
apt-get install compiz-gnome

Si tu es sous kde il y a une version pour etch dans backports :
deb http://www.backports.org/debian etch-backports main contrib non-free
deb-src http://www.backports.org/debian etch-backports main contrib
non-free

apt-get update && apt-get install compiz-kde

L'installation devrait se faire sans problème.

Après tu modifie ton xorg.conf comme expliqué sur le site de
compiz-fusion, tu redémarres ou tu relances seulement le gestionnair e de
session, et tu tapes "compiz --replace" dans un terminal (utilisateur)
pour voir ce qui se passe.

Personellement les effets de la vieille version de compiz dans etch me
suffisent, maintenant si tu en veux plus tu peux soit passer en lenny
(testing), soit essayer de rétro-porter compiz-fusion sur etch.

@+



J'ai modifié mon source.list comme tu l'as suggerré. Mais apparem ment il
manque une clé pour les deux lignes que tu m'as données. Et donc il n'en
tiens pas compte.
Tu n'aurrais pas cette clé par hasard ?

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
David Prévot
Le #9677661
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Bernard a écrit :
On Tuesday 06 May 2008 00:25:57 Hugues Larrive wrote:



[...]

Si tu es sous kde il y a une version pour etch dans backports :
deb http://www.backports.org/debian etch-backports main contrib non-free





[...]

J'ai modifié mon source.list comme tu l'as suggerré. Mais apparemment il
manque une clé pour les deux lignes que tu m'as données. Et donc il n'en
tiens pas compte.
Tu n'aurrais pas cette clé par hasard ?



# aptitude install debian-backports-keyring

D'après le lien « Instructions » [1] de la page d'accueil [2]...

[1] http://www.backports.org/dokuwiki/doku.php?id=instructions
[2] http://www.backports.org

Amicalement

David

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFIIfc/18/WetbTC/oRAuj2AJ0dydBprC/KfCo6rIC0Gb7P1NbylQCdH+UM
T0IVSMjyB1YV0dRS3UsMqCw =LSW3
-----END PGP SIGNATURE-----

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Bernard
Le #9677521
Le Tuesday 06 May 2008 00:25:57 Hugues Larrive, vous avez écrit :
M. ROUIN Bernard a écrit :
> Bonjour à tous,
> Je viens d'installer une Débian Etch stable et je souhaiterai avoir
> Compiz-fusion pour Kde.
> Mais je n'arrive pas à l'installer malgrés de multiples reche rches sur le
> toile. Aucun des paquets mentionnés ne veux s'installer sépar émment.
>
> Les messages de la konsole :
> debian:/home/bernard01# apt-get install compiz-fusion-kde
> Lecture des listes de paquets... Fait
> Construction de l'arbre des dépendances... Fait
> Certains paquets ne peuvent être installés. Ceci peut signifi er
> que vous avez demandé l'impossible, ou bien, si vous utilisez
> la distribution unstable, que certains paquets n'ont pas encore
> été créés ou ne sont pas sortis d'Incoming.
> Puisque vous n'avez demandé qu'une seule opération, le paquet n'est
> probablement pas installable et vous devriez envoyer un rapport de bogu e.
> L'information suivante devrait vous aider à résoudre la situa tion :
> Les paquets suivants contiennent des dépendances non satisfaites :
> compiz-fusion-kde: Dépend: compiz-core (>= 0.7.3) mais ne sera pas
> installé Dépend: compiz-plugins (>= 0.7.3) mais ne sera pas installé
> Dépend: compiz-kde (>= 0.7.3) mais ne sera pas
> installé Dépend: libdecoration0 (>= 0.7.3) mais ne sera pas installé
> Dépend: libcompizconfig0 (>= 0.7.3) mais ne sera pas
> installé
> Dépend: compizconfig-backend-kconfig (>= 0. 7.3) mais
> ne sera pas installé
> Dépend: python-compizconfig (>= 0.7.3) mais ne sera
> pas installé
> Dépend: compizconfig-settings-manager (>= 0 .7.3)
> mais ne sera pas installé
> Dépend: compiz-fusion-bcop (>= 0.7.3) mais ne sera
> pas installé
>
> Mon source.list :
> deb http://ftp.fr.debian.org/debian/ etch main
> deb-src http://ftp.fr.debian.org/debian/ etch main
> ## security
> deb http://security.debian.org/ etch/updates main contrib non-free
> deb-src http://security.debian.org/ etch/updates main contrib non-free
> # non free
> deb http://ftp.fr.debian.org/debian/ stable main contrib non-free
> deb-src http://ftp.fr.debian.org/debian/ stable main contrib non-free
> # multimedia
> deb http://www.debian-multimedia.org etch main
> #Compiz-fusion
> deb http://download.tuxfamily.org/shames/debian-sid/desktopfx/unstable/
> ./
>
> Certains y sont arrivés, donc c'est possible. Ma carte graphique e st une
> ATI Radeon 9800SE correctement pris en charge par le systéme.
> Qu'est ce qui ne va pas ? Vos aides et conseils me seraient d'un grand
> secours. Bien entendue si vous avez besoin de renseignements
> supplementaires...
> Merci d'avance.

Ce qui ne va pas c'est que tu est sous etch (stable) et que tu veux
installer des paquets prévu pour sid (unstable).
Tu devrais commencer par enlever la dernière ligne de ton source.lis t.
Si tu es sous gnome installes d'abord la version etch de compiz :
apt-get install compiz-gnome

Si tu es sous kde il y a une version pour etch dans backports :
deb http://www.backports.org/debian etch-backports main contrib non-free
deb-src http://www.backports.org/debian etch-backports main contrib
non-free

apt-get update && apt-get install compiz-kde

L'installation devrait se faire sans problème.

Après tu modifie ton xorg.conf comme expliqué sur le site de
compiz-fusion,


Le site est en anglais. Et moi et l'anglais...
Les différent sites consultés ne donnent que le rajout de la dern iére section,
que j'ai rajoutée mais sans succés.
Le drivers ati est installé et correctement configuré (enfin je c rois). Voir
la Konsole :

:~$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON 9800 SE
OpenGL version string: 2.1.7415 Release

:~$ glxinfo | grep "direct rendering"
direct rendering: Yes
:~$

Je poste mon xorg.conf, qu'est-ce que je doit modifier pour que les effets 3D
s'appliquent ?
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/X11R6/lib/X11/fonts/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi"
# path to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "fr"
Option "XkbVariant" "latin9"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
EndSection

Section "Device"
Identifier "ATI Technologies Inc R350 AH [Radeon 9800]"
Driver "fglrx"
BusID "PCI:1:0:0"
EndSection

Section "Monitor"
Identifier "HWP"
Option "DPMS"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "ATI Technologies Inc R350 AH [Radeon 9800]"
Monitor "HWP"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

Section "DRI"
Mode 0666
EndSection

Section "Extensions"
Option "Composite" "disable"
Option "RENDER" "Enable"
EndSection


tu redémarres ou tu relances seulement le gestionnaire de
session, et tu tapes "compiz --replace" dans un terminal (utilisateur)
pour voir ce qui se passe.


Ca me supprime le haut des fenêtres. La relance du serveurX me les rem ets.

Personellement les effets de la vieille version de compiz dans etch me
suffisent, maintenant si tu en veux plus tu peux soit passer en lenny
(testing), soit essayer de rétro-porter compiz-fusion sur etch.

@+


Merci d'avance pour vos conseils avisés.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme