Installation automatique de debian et partitionnement

Le
Jean Baptiste FAVRE
Bonjour la liste,

Après les questions metaphysiques sur Xen et LVM, me voilà en bute a un
autre souci:
J'essaye de réaliser une installation automatique de machine Xen sous
Debian via PXE avec un fichier preseed.
Tout va bien sauf le partitionnement de mon disque.

Je suis parti de là:
http://d-i.alioth.debian.org/manual/en.i386/apbs04.html#preseed-partman
et d'autres exemples glanés sur le net (notamment là: http://hands.com/)

Ce que je voudrais faire:
- Partitionnement assisté LVM
- Partition /home séparée

Au mieux, il ne prend pas en compte mes réglages, au pire un message
d'erreur apparaît à propos du nom de VG qui existe déjà.
Ceci m'étonne un peu dans la mesure où j'efface le "disque" à chaque fois.

Une piste ?
JB

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Gilles Mocellin
Le #17808861
--nextPart5588115.XqtMZHuNfS
Content-Type: text/plain;
charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

Le Tuesday 11 November 2008 12:28:17 Jean Baptiste FAVRE, vous avez écrit  :
Bonjour la liste,

Après les questions metaphysiques sur Xen et LVM, me voilà en bute a un
autre souci:
J'essaye de réaliser une installation automatique de machine Xen sous
Debian via PXE avec un fichier preseed.
Tout va bien sauf... le partitionnement de mon disque.

Je suis parti de là:
http://d-i.alioth.debian.org/manual/en.i386/apbs04.html#preseed-partman
et d'autres exemples glanés sur le net (notamment là: http://hands.co m/)

Ce que je voudrais faire:
- Partitionnement assisté LVM
- Partition /home séparée

Au mieux, il ne prend pas en compte mes réglages, au pire un message
d'erreur apparaît à propos du nom de VG qui existe déjà.
Ceci m'étonne un peu dans la mesure où j'efface le "disque" à chaqu e fois.

Une piste ?
JB



Le partitionnement LVM en preseed est vraiment minimal sous
Etch.
J'espère que ça sera mieux avec Lenny.

Mon problème à moi, c'était que je ne voulais pas utiliser tout l'esp ace
libre.
Et au bout d'un moment, j'avais compris qu'on était obligé.
Du coup je créais un LV que je supprimais après, avec un script...

Voici la partie concernant le partitionnement que j'ai testé :

###################################################################
d-i partman-auto/method string lvm

# This makes partman automatically partition without confirmation.
d-i partman/confirm_write_new_label boolean true
d-i partman-auto/purge_lvm_from_device boolean true
d-i partman-lvm/device_remove_lvm boolean true
d-i partman-lvm/confirm boolean true
d-i partman-auto-lvm/new_vg_name string vgsys
d-i partman-auto/expert_recipe string ghm-serveur ::
96 128 128 ext3
$primary{ }
$bootable{ }
method{ format }
format{ }
use_filesystem{ }
filesystem{ ext3 }
options/noatime{ noatime }
mountpoint{ /boot }
.
128 200% 512 linux-swap
$lvmok{ }
method{ swap }
format{ }
.
512 768 1024 ext3
$lvmok{ }
method{ format }
format{ }
use_filesystem{ }
filesystem{ ext3 }
options/noatime{ noatime }
mountpoint{ /home }
.
1024 1024 2048 ext3
$lvmok{ }
method{ format }
format{ }
use_filesystem{ }
filesystem{ ext3 }
options/noatime{ noatime }
mountpoint{ /tmp }
.
2048 4096 5120 ext3
$lvmok{ }
method{ format }
format{ }
use_filesystem{ }
filesystem{ ext3 }
options/noatime{ noatime }
mountpoint{ / }
.
2048 4096 5120 ext3
$lvmok{ }
method{ format }
format{ }
use_filesystem{ }
filesystem{ ext3 }
options/noatime{ noatime }
mountpoint{ /var }
.
1 1000 1000000000 ext3
$lvmok{ }
method{ keep }
.

d-i partman/choose_partition select Finish partitioning and writ e
changes to disk
d-i partman/confirm boolean true

# Le LV cree avec la methode keep, et de taille max, le max possible
(1000000000) est
# obligatoire, sinon la procédure plante (division par zero) et aucun LV n'est
créé
# On le supprime après l'installation
d-i partman-basicmethods/method_only boolean false
d-i preseed/late_command string lvremove -f /dev/vgsys/keep_2


--nextPart5588115.XqtMZHuNfS
Content-Type: application/pgp-signature; name=signature.asc
Content-Description: This is a digitally signed message part.

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iEYEABECAAYFAkkZfPEACgkQDltnDmLJYdBOuwCfczCmuc7JTahuxya8cqzDbaxt
sf0An1smZEdPdwh2dxuVuKpp1h+PDruX
=Mj64
-----END PGP SIGNATURE-----

--nextPart5588115.XqtMZHuNfS--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Jean Baptiste FAVRE
Le #17809721
Re,
En fait, j'ai l'impression d'être tombé sur un comportement bizarre de
LVM dans le Dom0:

- Je créée un LV tout neuf pour mon DomU:
# lvcreate XenVG -n xps-104.disk.1 -L 10G
Résultat
# lvdisplay /dev/XenVG/xps-104.disk.1
--- Logical volume ---
LV Name /dev/XenVG/xps-104.disk.1
VG Name XenHosting
LV UUID dbP9tN-sgV2-XYq0-mLBT-4J2J-MP4i-90GSX3
LV Write Access read/write
LV Status available
# open 2
LV Size 10,00 GB
Current LE 2560
Segments 1
Allocation inherit
Read ahead sectors auto
- currently set to 256
Block device 254:3

- J'installe mon DomU dans ce LV avec le paramétrage suivant pour le
preseed:
#########################################################
### Disk and partitions configuration
#########################################################
# LVM configuration
d-i partman-auto/disk string /dev/hda
d-i partman-auto/method string lvm
d-i partman/confirm_write_new_label boolean true
d-i partman-auto/purge_lvm_from_device boolean true
d-i partman-lvm/device_remove_lvm boolean true
d-i partman-lvm/confirm boolean true
d-i partman-auto-lvm/new_vg_name string
# Partitions repartition
d-i partman-auto/choose_recipe select Partition /home séparée
d-i partman/choose_partition select Terminer le partitionnement et
appliquer les changements
d-i partman/confirm boolean true
d-i partman-lvm/confirm_nochanges boolean false

Tout va bien ! L'installation se fait en automatique, comme je le veux,
le DomU redémarre correctement.

- J'éteins (un peu brutalement je l'avoue) mon DomU:
# xm shutdown xps-104

- Je détruis et recrééele LV:
# lvremove -f /dev/XenVG/xps-104.disk.1
Logical volume "xps-104.disk.1" successfully removed
# lvcreate XenVG -n xps-104.disk.1 -L 10G
Logical volume "xps-104.disk.1" created

- Je recréée mon Domu et j'ai l'erreur.

J'en déduis donc qu'il y a une sorte de rémanence, c'est-à-dire que le
LV dans le Dom0 n'est pas effacé correctement. Du coup, lorsqu'il est
recréé, le VG est toujours là et l'installeur Debian perd les pédales.

C'est embêtant dans la mesure où cela m'oblige à faire mes tests sur des
DomU différents à chaque fois (mon install créée le LV en fnction du nom
du DomU). C'est juste fatigant ;-)


Une piste pour forcer la réinitialisation du LV dans le Dom0 ?
JB

Gilles Mocellin a écrit :
Le Tuesday 11 November 2008 12:28:17 Jean Baptiste FAVRE, vous avez écrit :
Bonjour la liste,

Après les questions metaphysiques sur Xen et LVM, me voilà en bute a un
autre souci:
J'essaye de réaliser une installation automatique de machine Xen sous
Debian via PXE avec un fichier preseed.
Tout va bien sauf... le partitionnement de mon disque.

Je suis parti de là:
http://d-i.alioth.debian.org/manual/en.i386/apbs04.html#preseed-partman
et d'autres exemples glanés sur le net (notamment là: http://hands.com/)

Ce que je voudrais faire:
- Partitionnement assisté LVM
- Partition /home séparée

Au mieux, il ne prend pas en compte mes réglages, au pire un message
d'erreur apparaît à propos du nom de VG qui existe déjà.
Ceci m'étonne un peu dans la mesure où j'efface le "disque" à chaque fois.

Une piste ?
JB



Le partitionnement LVM en preseed est vraiment minimal sous
Etch.
J'espère que ça sera mieux avec Lenny.

Mon problème à moi, c'était que je ne voulais pas utiliser tout l'espace
libre.
Et au bout d'un moment, j'avais compris qu'on était obligé.
Du coup je créais un LV que je supprimais après, avec un script...

Voici la partie concernant le partitionnement que j'ai testé :

###################################################################
d-i partman-auto/method string lvm

# This makes partman automatically partition without confirmation.
d-i partman/confirm_write_new_label boolean true
d-i partman-auto/purge_lvm_from_device boolean true
d-i partman-lvm/device_remove_lvm boolean true
d-i partman-lvm/confirm boolean true
d-i partman-auto-lvm/new_vg_name string vgsys
d-i partman-auto/expert_recipe string ghm-serveur ::
96 128 128 ext3
$primary{ }
$bootable{ }
method{ format }
format{ }
use_filesystem{ }
filesystem{ ext3 }
options/noatime{ noatime }
mountpoint{ /boot }
.
128 200% 512 linux-swap
$lvmok{ }
method{ swap }
format{ }
.
512 768 1024 ext3
$lvmok{ }
method{ format }
format{ }
use_filesystem{ }
filesystem{ ext3 }
options/noatime{ noatime }
mountpoint{ /home }
.
1024 1024 2048 ext3
$lvmok{ }
method{ format }
format{ }
use_filesystem{ }
filesystem{ ext3 }
options/noatime{ noatime }
mountpoint{ /tmp }
.
2048 4096 5120 ext3
$lvmok{ }
method{ format }
format{ }
use_filesystem{ }
filesystem{ ext3 }
options/noatime{ noatime }
mountpoint{ / }
.
2048 4096 5120 ext3
$lvmok{ }
method{ format }
format{ }
use_filesystem{ }
filesystem{ ext3 }
options/noatime{ noatime }
mountpoint{ /var }
.
1 1000 1000000000 ext3
$lvmok{ }
method{ keep }
.

d-i partman/choose_partition select Finish partitioning and write
changes to disk
d-i partman/confirm boolean true

# Le LV cree avec la methode keep, et de taille max, le max possible
(1000000000) est
# obligatoire, sinon la procédure plante (division par zero) et aucun LV n'est
créé
# On le supprime après l'installation
d-i partman-basicmethods/method_only boolean false
d-i preseed/late_command string lvremove -f /dev/vgsys/keep_2




--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Jean Baptiste FAVRE
Le #17810981
Re (et c'est fini pour aujourd'hui ;-) )
Bon, j'ai fini par réussir mes install.
En fait, j'ai l'impression qu'effectivement LVM n'initialise pas ou pas
bien le LV dans le Dom0.

Du coup, lorsque je veux réinstaller un DomU, je suis obligé de faire:
lvremove
lvcreate
dd if=/dev/urandom of=/dev/XenHosting/xps-103.disk.1 bs=1G
xm create

Un peu chiant car un peu long, mais pas dramatique. Je vais peut-être
essayée avec moins de 1G, faut p'tre pas exagérer ;-)
Je suis en tout cas toujours preneur de conseils pour me débarrasser du
dd :-)

Merci,
JB

Jean Baptiste FAVRE a écrit :

Re,
En fait, j'ai l'impression d'être tombé sur un comportement bizarre de
LVM dans le Dom0:

- Je créée un LV tout neuf pour mon DomU:


<SNIP>

- J'installe mon DomU dans ce LV avec le paramétrage suivant pour le
preseed:


<SNIP>

Tout va bien ! L'installation se fait en automatique, comme je le veux,
le DomU redémarre correctement.

- J'éteins (un peu brutalement je l'avoue) mon DomU:
# xm shutdown xps-104

- Je détruis et recrééele LV:
# lvremove -f /dev/XenVG/xps-104.disk.1
Logical volume "xps-104.disk.1" successfully removed
# lvcreate XenVG -n xps-104.disk.1 -L 10G
Logical volume "xps-104.disk.1" created

- Je recréée mon Domu et j'ai l'erreur.

J'en déduis donc qu'il y a une sorte de rémanence, c'est-à-dire que le
LV dans le Dom0 n'est pas effacé correctement. Du coup, lorsqu'il est
recréé, le VG est toujours là et l'installeur Debian perd les pédales.

C'est embêtant dans la mesure où cela m'oblige à faire mes tests sur des
DomU différents à chaque fois (mon install créée le LV en fnction du nom
du DomU). C'est juste fatigant ;-)


Une piste pour forcer la réinitialisation du LV dans le Dom0 ?
JB

Gilles Mocellin a écrit :
Le Tuesday 11 November 2008 12:28:17 Jean Baptiste FAVRE, vous avez
écrit :
Bonjour la liste,

Après les questions metaphysiques sur Xen et LVM, me voilà en bute a un
autre souci:
J'essaye de réaliser une installation automatique de machine Xen sous
Debian via PXE avec un fichier preseed.
Tout va bien sauf... le partitionnement de mon disque.

Je suis parti de là:
http://d-i.alioth.debian.org/manual/en.i386/apbs04.html#preseed-partman
et d'autres exemples glanés sur le net (notamment là: http://hands.com/)

Ce que je voudrais faire:
- Partitionnement assisté LVM
- Partition /home séparée

Au mieux, il ne prend pas en compte mes réglages, au pire un message
d'erreur apparaît à propos du nom de VG qui existe déjà.
Ceci m'étonne un peu dans la mesure où j'efface le "disque" à chaque
fois.

Une piste ?
JB



Le partitionnement LVM en preseed est vraiment minimal
sous Etch.
J'espère que ça sera mieux avec Lenny.

Mon problème à moi, c'était que je ne voulais pas utiliser tout
l'espace libre.
Et au bout d'un moment, j'avais compris qu'on était obligé.
Du coup je créais un LV que je supprimais après, avec un script...

Voici la partie concernant le partitionnement que j'ai testé :




<SNIP>

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Gilles Mocellin
Le #17811271
--GvXjxJ+pjyke8COw
Content-Type: text/plain; charset=iso-8859-1
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

On Tue, Nov 11, 2008 at 04:21:43PM +0100, Jean Baptiste FAVRE wrote:
Re (et c'est fini pour aujourd'hui ;-) )
Bon, j'ai fini par réussir mes install.
En fait, j'ai l'impression qu'effectivement LVM n'initialise pas ou pas
bien le LV dans le Dom0.

Du coup, lorsque je veux réinstaller un DomU, je suis obligé de faire:
lvremove
lvcreate
dd if=/dev/urandom of=/dev/XenHosting/xps-103.disk.1 bs=1G
xm create

Un peu chiant car un peu long, mais pas dramatique. Je vais peut-être
essayée avec moins de 1G, faut p'tre pas exagérer ;-)
Je suis en tout cas toujours preneur de conseils pour me débarrasser du
dd :-)



Ca ressemble a des infos (VGDA) qui reste physiquement sur le disque.

Après le lvremove, est-ce-qu'un lvscan trouve quelque chose ?

Sinon, tu pourrais aussi jouer l'installation sans pressed (en tout cas pou r la partie partitionnement) pour voir s'il y a une différence de comport ement entre les deux cas (lv écrasé avec le dd ou non).
Il y a peut-être une question du style "ce LV existe déjà, voulez-vou us vraiment utiliser ce nom ?"

--GvXjxJ+pjyke8COw
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iEYEARECAAYFAkkZsDIACgkQDltnDmLJYdAhwACfd4h6E//Do78tp/qXZEjKEaF1
JTUAn31YwPmwm5nnJXTrUoAxUFVIFQdR
=dz88
-----END PGP SIGNATURE-----

--GvXjxJ+pjyke8COw--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Jean Baptiste FAVRE
Le #17815801
Bonsoir,

Gilles Mocellin a écrit :
On Tue, Nov 11, 2008 at 04:21:43PM +0100, Jean Baptiste FAVRE wrote:
Re (et c'est fini pour aujourd'hui ;-) )
Bon, j'ai fini par réussir mes install.
En fait, j'ai l'impression qu'effectivement LVM n'initialise pas ou pas
bien le LV dans le Dom0.

Du coup, lorsque je veux réinstaller un DomU, je suis obligé de faire:
lvremove
lvcreate
dd if=/dev/urandom of=/dev/XenHosting/xps-103.disk.1 bs=1G
xm create

Un peu chiant car un peu long, mais pas dramatique. Je vais peut-être
essayée avec moins de 1G, faut p'tre pas exagérer ;-)
Je suis en tout cas toujours preneur de conseils pour me débarrasser du
dd :-)



Ca ressemble a des infos (VGDA) qui reste physiquement sur le disque.


On dirait oui... mais je découvre un peu tout ça ;-)

Après le lvremove, est-ce-qu'un lvscan trouve quelque chose ?


non, rien du tout. Il me montre bien les LV actifs, mais pas celui que
je viens de supprimer (ce qui est logique quelque part).

Sinon, tu pourrais aussi jouer l'installation sans pressed (en tout cas pour la partie partitionnement) pour voir s'il y a une différence de comportement entre les deux cas (lv écrasé avec le dd ou non).
Il y a peut-être une question du style "ce LV existe déjà, voulez-vouus vraiment utiliser ce nom ?"


J'essaierai ça dès demain ;-)

Bonne nuit,
JB

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme