Installation avec une carte Ethernet Realtek RTL8168C

Le
Stephane Bortzmeyer
J'ai un PC (un HP/Compaq Presario SR5308 neuf) où je cherche à
installer Debian etch. Il a une carte Ethernet "Realtek RTL8168C/8111C
Family PCI-E Gigabit E" qui marche sous Windows Vista.

Lors de l'installation, l'installeur détecte la carte, charge le
pilote mais la carte ne marche pas, ifconfig ne montre qu'un seul
compteur non-nul, celui des erreurs et une autre machine du réseau ne
voit pas les requêtes DHCP passer.

Le problème semble être celui décrit ici :

http://ubuntuforums.org/showthread.php?pE89140#post4589140
http://www.linuxquestions.org/questions/linux-networking-3/no-network-detected-realtek-81118168-issue-615047/#post3029998

La seule solution est apparemment un nouveau pilote (avec sans doute
une licence non-libre mais c'est une autre histoire) :

http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNid&PFid=5&Level=5&Conn=4&DownTypeID=3&GetDownúlse

Comme il s'agit d'installer Debian, la solution "télécharge le pilote
et recompile ton noyau" n'est pas très pratique.

Comme je suis paresseux, je cherche si quelqu'un a déjà fait :

- soit une image "netinst" avec le bon pilote,

- soit un binaire du pilote, que je pourrais mettre par exemple sur
une clé USB) avec une doc expliquant comment le
charger lors de l'installation (ça devrait être simple mais je ne
trouve pas)

Sinon, il faudra que j'installe une vieille carte Ethernet qui marche
dans une fente PCI de la machine

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jacques L'helgoualc'h
Le #9689961
Stephane Bortzmeyer a écrit, mercredi 9 avril 2008, à 22:59 :
J'ai un PC (un HP/Compaq Presario SR5308 neuf) où je cherche à
installer Debian etch. Il a une carte Ethernet "Realtek RTL8168C/8111C
Family PCI-E Gigabit E" qui marche sous Windows Vista.

Lors de l'installation, l'installeur détecte la carte, charge le
pilote... mais la carte ne marche pas, ifconfig ne montre qu'un seul
compteur non-nul, celui des erreurs et une autre machine du réseau ne
voit pas les requêtes DHCP passer.



J'ai eu un problème du même genre avec un Shuttle SG31G2, l'installeur
(Etch amd64) trouvait bien l'interface réseau Marvell 88E8056, mais
n'arrivait pas à s'en servir --- la limitation à ethernet 100 de mon
Linksys wrt54 peut être en cause, je n'ai pas essayé de cordon croisé
vers une autre machine.

J'ai cependant pu faire une installation minimale grâce à l'image
netinstall copiée sur la clef usb.

Après avoir rebouté, le noyau etch standard 2.6.18 installé a reconnu et
utilisé cette même interface réseau pour compléter l'installation, puis
importer sans aucune erreur près de 40G d'archives locales.

Depuis (toujours en Etch), je suis passé au noyau 2.6.22 backport, puis
au 2.6.24 Lenny (meilleure gestion des lm_sensors), et ça marche encore.

Le problème semble être celui décrit ici :

http://ubuntuforums.org/showthread.php?pE89140#post4589140
[...]



J'avais vu aussi quelques messages alarmants à propos de la Marvell,
mais pas sur Shuttle.

[...]
Sinon, il faudra que j'installe une vieille carte Ethernet qui marche
dans une fente PCI de la machine...



C'est dans les vieux pots...
--
Jacques L'helgoualc'h

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Stephane Bortzmeyer
Le #9688181
On Thu, Apr 10, 2008 at 12:50:35AM +0200,
Jacques L'helgoualc'h a message of 50 lines which said:

Après avoir rebouté, le noyau etch standard 2.6.18 installé a
reconnu et utilisé cette même interface réseau pour compléter
l'installation,



Ah, je n'avais pas pensé à ça mais, dans mon cas, ça n'a rien changé.

> Sinon, il faudra que j'installe une vieille carte Ethernet qui marche
> dans une fente PCI de la machine...

C'est dans les vieux pots...



C'est ce que j'ai fini par faire :

- mettre une vieille carte Ethernet 3com 3C905 dans l'unique fente PCI
libre

- installation Debian netinst classique

- aptitude install build-essential linux-headers-$(uname -r)

- récupérer le pilote Realtek en
Aucune idée de sa licence, je ne trouve rien dans la distribution.

- make install
(Compilation du pilote)

- depmod -a

Là, j'ai testé avec modprobe, ça a marché. dmesg affiche :

eth1394: eth0: IEEE-1394 IPv4 over 1394 Ethernet (fw-host0)
eth1: Identified chip type is 'RTL8168C/8111C'.
eth1: RTL8168B/8111B at 0xf8934000, 00:1e:8c:76:29:b6, IRQ 177

Et j'ai configuré la machine ainsi pour que ce soit permanent :

- éditer /etc/modprobe.d/blacklist pour y mettre :
# Regular Debian "etch" driver does not work
blacklist r8169

- update-initramfs -u
(Pas sûr que ce soit vraiment nécessaire)

- configurer /etc/network/interfaces ainsi :
allow-hotplug eth1
iface eth1 inet dhcp
# Le module qui marche
pre-up modprobe r8168

et tout est bon au redémarrage. Merci.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme