Installation de google earth

Le
Laurent GUERRIER
--_94cd0089-6787-4ade-8961-a9f4e618dbb3_
Content-Type: text/plain; charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

Bonjour,

Je souhaite installer google earth sur ma debian testing (architecture amd6=
4).

J'ai installé le paquet googleearth-package puis j'ai lancé un
make-googleearth-package
A priori tout c'est bien passé et j'ai bien un paquet .deb de googleearth=
, donc
je l'installe :

# dpkg -i googleearth_6.0.3.2197+1.1.0-1_amd64.deb
Sélection du paquet googleearth précédemment désélectionné.
(Lecture de la base de données 188606 fichiers et répertoires déj=
à installés.)
Dépaquetage de googleearth (à partir de /googleearth_6.0.3.2197+1.1.=
0-1_amd64.deb)
dpkg: des problèmes de dépendances empêchent la configuration de goog=
leearth :
googleearth dépend de libcurl3:i386.
googleearth dépend de libsm6:i386.
googleearth dépend de libfontconfig1:i386.
googleearth dépend de libxt6:i386.
googleearth dépend de libxrender1:i386.
googleearth dépend de libxext6:i386.
googleearth dépend de libgl1-mesa-glx:i386.
googleearth dépend de libgl1-mesa-dri:i386.

dpkg: erreur de traitement de googleearth (--install) :
problèmes de dépendances - laissé non configuré
Traitement des actions différées (« triggers ») pour « menu »..=
.
Traitement des actions différées (« triggers ») pour « desktop-fi=
le-utils »
Traitement des actions différées (« triggers ») pour « mime-suppo=
rt »
Traitement des actions différées (« triggers ») pour « gnome-menu=
s »
Traitement des actions différées (« triggers ») pour « shared-mim=
e-info »
Des erreurs ont été rencontrées pendant l'exécution :
googleearth

Déjà j'arrive pas à installer ces paquets dans leur version i386. Mai=
s en plus
je doute que mélanger des paquets i386 et amd64 soit judicieux !


Question subsidiaire, GE est actuellement en version 7 et non 6. Comment =
faire
pour avoir la version 7 ?
Si ce n'est pas possible tant pis, je me contenterai de la 6 :(

Merci pour votre aide !

Laurent =

--_94cd0089-6787-4ade-8961-a9f4e618dbb3_
Content-Type: text/html; charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

<html>
<head>
<style><!--
.hmmessage P
{
margin:0px;
padding:0px
}
body.hmmessage
{
font-size: 12pt;
font-family:Calibri
}
--></style></head>
<body class='hmmessage'><div dir='ltr'><pre>Bonjour,<br><br>Je souhai=
te installer google earth sur ma debian testing (architecture amd64).<br><b=
r>J'ai installé le paquet googleearth-package puis j'ai lancé un <br>ma=
ke-googleearth-package<br>A priori tout c'est bien passé et j'ai bien un =
paquet .deb de googleearth, donc <br>je l'installe :<br><br># dpkg -i goo=
gleearth_6.0.3.2197+1.1.0-1_amd64.deb <br>Sélection du paquet googleearth=
précédemment désélectionné.<br>(Lecture de la base de données.=
.. 188606 fichiers et répertoires déjà installés.)<br>Dépaquetage=
de googleearth (à partir de /googleearth_6.0.3.2197+1.1.0-1_amd64.deb=
) <br>dpkg: des problèmes de dépendances empêchent la configuratio=
n de googleearth&nbsp;:<br> googleearth dépend de libcurl3:i386.<br> go=
ogleearth dépend de libsm6:i386.<br> googleearth dépend de libfontconfi=
g1:i386.<br> googleearth dépend de libxt6:i386.<br> googleearth dépend =
de libxrender1:i386.<br> googleearth dépend de libxext6:i386.<br> googlee=
arth dépend de libgl1-mesa-glx:i386.<br> googleearth dépend de libgl1-m=
esa-dri:i386.<br><br>dpkg: erreur de traitement de googleearth (--install)&=
nbsp;:<br> problèmes de dépendances - laissé non configuré<br>Tra=
itement des actions différées («&nbsp;triggers&nbsp;») pour «=
&nbsp;menu&nbsp;»<br>Traitement des actions différées («&nbs=
p;triggers&nbsp;») pour «&nbsp;desktop-file-utils&nbsp;»<b=
r>Traitement des actions différées («&nbsp;triggers&nbsp;») pou=
r «&nbsp;mime-support&nbsp;»<br>Traitement des actions différ=
ées («&nbsp;triggers&nbsp;») pour «&nbsp;gnome-menus&nbsp;=
»<br>Traitement des actions différées («&nbsp;triggers&nbsp;=
») pour «&nbsp;shared-mime-info&nbsp;»<br>Des erreurs ont ét=
é rencontrées pendant l'exécution&nbsp;:<br> googleearth<br><br>D=
éjà j'arrive pas à installer ces paquets dans leur version i386. Mais=
en plus<br>je doute que mélanger des paquets i386 et amd64 soit judicieu=
x !<br><br><br>Question subsidiaire, GE est actuellement en version 7 et =
non 6. Comment faire<br>pour avoir la version 7 ? <br>Si ce n'est pas possi=
ble tant pis, je me contenterai de la 6 :(<br><br>Merci pour votre aide !=
<br><br>Laurent</pre> </div></body>
</html>=

--_94cd0089-6787-4ade-8961-a9f4e618dbb3_--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/DUB109-W155128775CAF156C3B1552E3EF0@phx.gbl
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
François Le Gad
Le #25822912
Le Wed, 27 Nov 2013 19:34:38 +0100
Laurent GUERRIER
googleearth dépend de libcurl3:i386.
googleearth dépend de libsm6:i386.
googleearth dépend de libfontconfig1:i386.
googleearth dépend de libxt6:i386.
googleearth dépend de libxrender1:i386.
googleearth dépend de libxext6:i386.
googleearth dépend de libgl1-mesa-glx:i386.
googleearth dépend de libgl1-mesa-dri:i386.



J'ai pu les installer sans problème, également sous testing 64 bits.
Où est-ce que ça coince ?

--
Cordialement,
François

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Christophe
Le #25822992
Bonsoir,

Le 27/11/2013 19:58, valentin OVD a écrit :
Normale que tu ne puisse pas installer le paquet car il utilise des
dépendances i386, tu dois installer google earth pour amd64 avoir des
dépendance amd64 et non google earth pour i386.

En espérant avoir aidé,
Valentin




Même en allant chercher le paquet officiel sur le site Google, ce paquet
dit amd64 est une vaste fumisterie ;) .

Voici comment je l'ai installé après avoir téléchargé le paquet de 44 Mo
sur le site de Google :

dpkg -i google-earth-stable_current_amd64.deb

<= La , ca couine sur les dépendances.

apt-get -f install

<= La , ca a installé tout plein de trucs en archi i386.

Au final ca fonctionne, mais je ne suis pas vraiment satisfait d'avoir
un certain nombre de paquets dans les deux architectures.

@+
Christophe.


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Gaëtan PERRIER
Le #25823302
Le Wed, 27 Nov 2013 20:07:12 +0100
Christophe
Bonsoir,

Le 27/11/2013 19:58, valentin OVD a écrit :
> Normale que tu ne puisse pas installer le paquet car il utilise des
> dépendances i386, tu dois installer google earth pour amd64 avoir des
> dépendance amd64 et non google earth pour i386.
>
> En espérant avoir aidé,
> Valentin
>

Même en allant chercher le paquet officiel sur le site Google, ce paquet
dit amd64 est une vaste fumisterie ;) .



Le problème c'est qu'il n'est pas multiarch ...


Voici comment je l'ai installé après avoir téléchargé le paquet de 44 Mo
sur le site de Google :

dpkg -i google-earth-stable_current_amd64.deb

<= La , ca couine sur les dépendances.

apt-get -f install

<= La , ca a installé tout plein de trucs en archi i386.

Au final ca fonctionne, mais je ne suis pas vraiment satisfait d'avoir
un certain nombre de paquets dans les deux architectures.




Pourquoi ?

Gaëtan

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Christophe
Le #25823332
Hello,

Le 27/11/2013 21:31, Gaëtan PERRIER a écrit :

Au final ca fonctionne, mais je ne suis pas vraiment satisfait d'avoir
un certain nombre de paquets dans les deux architectures.



Pourquoi ?

Gaëtan




Pour plusieurs raisons,

Une première relative au système : Installer du paquet x86 sur une
architecture amd64, ça marche, mais je ne considère clairement pas ça
comme propre.

Une deuxième sur la bande passante consommée lors des mises à jour : Et
c'est particulièrement important dans mon cas.

Et bien que j'ai fait ce qu'il fallait avec apt-cacher-ng, le
rapatriement des paquets jusqu'au domicile est particulièrement lourd :
donc si je peux me limiter à une seule et unique architecture sur toutes
les machines, c'est pas plus mal.

Au final, je trouve que c'est du pur travail de porcasse que de faire ça
(Merci Google ;) ): à ce niveau, autant ne pas proposer de paquet amd64
: Au moins on sait à quoi s'en tenir ...

@+
Christophe.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Laurent GUERRIER
Le #25824332
--_b694ccbb-8b8c-413c-93de-46ae3916fefe_
Content-Type: text/plain; charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

Bonjour,

Réponse dans le texte.
Voici comment je l'ai installé après avoir téléchargé le paquet de 44 Mo
sur le site de Google :

dpkg -i google-earth-stable_current_amd64.deb

<= La , ca couine sur les dépendances.



Moi aussi çà couine


apt-get -f install

<= La , ca a installé tout plein de trucs en archi i386.



Je l'avais déjà fait et j'obtiens ceci :

# apt-get -f install
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets suivants seront ENLEVÉS :
googleearth
0 mis à jour, 0 nouvellement installés, 1 à enlever et 0 non mis à jour.
1 partiellement installés ou enlevés.
Après cette opération, 0 o d'espace disque supplémentaires seront u tilisés.

Au final ca fonctionne, mais je ne suis pas vraiment satisfait d'avoir
un certain nombre de paquets dans les deux architectures.



Donc pas grand choses d'installées au final.

Et comment forcer à installer un paquet en arch i386 car avec la méthod e traditionnelle, ça ne fonctionne pas !

# apt-get install libcurl3
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
libcurl3 is already the newest version.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.

# apt-get install libcurl3:i386
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet libcurl3

Je le dit quand même, un reboot ne change rien à la donne !

Merci pour votre aide

PS
: Désolé pour Christophe, 1ère liste que je vois ou le "Répondre " ne se
fait non pas à la liste mais à l'expéditeur du message :( !

Laurent
--_b694ccbb-8b8c-413c-93de-46ae3916fefe_
Content-Type: text/html; charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

<html>
<head>
<style><!--
.hmmessage P
{
margin:0px;
padding:0px
}
body.hmmessage
{
font-size: 12pt;
font-family:Calibri
}
--></style></head>
: Désolé pour Christophe, 1ère liste que je vois ou le "Répondre " ne se
fait non pas à la liste mais à l'expéditeur du message :( !<br><br>L aurent </div></body>
</html>
--_b694ccbb-8b8c-413c-93de-46ae3916fefe_--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
François Le Gad
Le #25826172
Le Thu, 28 Nov 2013 11:43:30 +0100
Laurent GUERRIER
# apt-get install libcurl3:i386
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet libcurl3



Il est en principe dans les dépôts testing/main. Vérifie ton
sources.list et fais un apt-get update.

Il arrive que des paquets soient manquants dans les dépôts testing. Tu
peux alors essayer de puiser dans les dépôts sid.


--
Cordialement,
François

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Christophe
Le #25826842
Bonsoir,

Le 28/11/2013 11:43, Laurent GUERRIER a écrit :

apt-get -f install



Je l'avais déjà fait et j'obtiens ceci :

# apt-get -f install
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets suivants seront ENLEVÉS :
googleearth
0 mis à jour, 0 nouvellement installés, 1 à enlever et 0 non mis à jour.
1 partiellement installés ou enlevés.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.



Ca, ca ne ressemble pas à ce que j'ai d'installé pour ma part (et qui
"fonctionne") :

# dpkg -l|grep "earth"|awk ' { print $2" "$3 } '
google-earth-stable 7.1.2.2041-r0

As tu été chercher le package directement sur
http://www.google.fr/intl/fr/earth/download/ge/agree.html ?


PS : Désolé pour Christophe, 1ère liste que je vois ou le "Répondre" ne
se fait non pas à la liste mais à l'expéditeur du message :( !




Pas de soucis,

C'est toujours un grand dilemme sur la config des listes ... bien que
dans le cas présent , je considère que c'est plutôt un problème du
client de messagerie sur lequel il manque la fonction "Répondre à la
liste" très efficace sous Mutt et Thunderbird (et surement bien
d'autres). Du reste, c'est loin d'être la seule liste à fonctionner
comme ça.
Mais sur énorme majorité des Webmail, c'est l'impasse. Cela nécessite
des manipulations genre "Répondre à tous" et supprimer ce qui n'est pas
nécessaire. (n'est-ce pas Stéphane G. ? ;) )

@+
Christophe.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme