Installation OpenGL pour serveur XBMC

Le
TISSET Mathieu
Salut la liste,

bon, j'ai un ptite question : je souhaite installer XMBC (le media center) sur ma squeeze.

Actuellement, j'ai un serveur X fonctionnel, pas de soucis.
J'installe XBMC, quand je le lance, j'ai le message suivant :
"XBMC needs hardware accelerated OpenGL rendering.
Install an appropriate graphics driver."

Je tourne actuellement avec le driver nvidia :
$ grep Driver /etc/X11/xorg.conf 2>&1|grep nvidia
Driver "nvidia"


Déduction, il faut que j'installe l'accélération graphique (pas con le gars ^^)




Après quelques recherches, je vois qu'il me faut installer "mesa";
c'est partit pour un :
$ apt-get install mesa-utils


Et là (si je ne dis pas de connerie),
je peux tester que cela fonctionne par :
$ glxinfo
J'ai alors le retour suivant :
X Error of failed request: BadWindow (invalid Window parameter)
Major opcode of failed request: 137 (NV-GLX)
Minor opcode of failed request: 4 ()
Resource id in failed request: 0x2600003
Serial number of failed request: 30
Current serial number in output stream: 30


Aussi voilà ma question : qu'ais-je loupé?
Je pige pas bien ce qui cloche.

Merci d'avance,


--
TISSET Mathieu

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/20111010201256.GA4898@serveur.lutix.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jean-Yves F. Barbier
Le #23848241
On Mon, 10 Oct 2011 22:12:56 +0200
TISSET Mathieu
"XBMC needs hardware accelerated OpenGL rendering.

J'ai alors le retour suivant :
X Error of failed request: BadWindow (invalid Window parameter)



installe freeglutN et reteste avec glxgears.

glxinfo|grep rend doit renvoyer:
direct rendering: Yes
OpenGL renderer string: blah

--
Any priest or shaman must be presumed guilty until proved innocent.
-- Lazarus Long

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
J
Le #23848421
Le lundi 10 octobre 2011 à 22:12 +0200, TISSET Mathieu a écrit :
Aussi voilà ma question : qu'ais-je loupé?
Je pige pas bien ce qui cloche.



J'ai oublié et je suis sur une Intel/ATI là, mais si tu utilise le
binaire Nvidia, il me semble qu'il y a une commande nvidia-settings et
nvidia-xconfig ou un truc du genre

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
TISSET Mathieu
Le #23848431
Bonsoir,

tout d'abord merci pour l'aide,

après l'install de freeglut3,
toujours le même message d'erreur :

% glxinfo
X Error of failed request: BadWindow (invalid Window parameter)
Major opcode of failed request: 137 (NV-GLX)
Minor opcode of failed request: 4 ()
Resource id in failed request: 0x1400003
Serial number of failed request: 30
Current serial number in output stream: 30


Merci d'avance,

mat

On Mon, Oct 10, 2011 at 10:31:21PM +0200, Jean-Yves F. Barbier wrote:
On Mon, 10 Oct 2011 22:12:56 +0200
TISSET Mathieu
> "XBMC needs hardware accelerated OpenGL rendering.

> J'ai alors le retour suivant :
> X Error of failed request: BadWindow (invalid Window parameter)

installe freeglutN et reteste avec glxgears.

glxinfo|grep rend doit renvoyer:
direct rendering: Yes
OpenGL renderer string: blah

--
Any priest or shaman must be presumed guilty until proved innocent.
-- Lazarus Long

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/




--
TISSET Mathieu

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
TISSET Mathieu
Le #23848471
Le nvidia-xconfig ne donne pas grand chose,
après un redémarage du serveur X pas de grandes différences...

nvidia-settings ne m'apporte pas de grandes infos :
- la catégorie "OpenGL Settings" est un peu vide
- la catégorie "OpenGL/GLX Information" provoque le plantage de nvidia-settings avec l'erreur :
The program 'nvidia-settings' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadWindow (invalid Window parameter)'.
(Details: serial 288 error_code 3 request_code 137 minor_code 4)
(Note to programmers: normally, X errors are reported asynchronously;
that is, you will receive the error a while after causing it.
To debug your program, run it with the --sync command line
option to change this behavior. You can then get a meaningful
backtrace from your debugger if you break on the gdk_x_error() function.)


mat

On Mon, Oct 10, 2011 at 10:24:54PM +0200, Jérôme wrote:
Le lundi 10 octobre 2011 à 22:12 +0200, TISSET Mathieu a écrit :
> Aussi voilà ma question : qu'ais-je loupé?
> Je pige pas bien ce qui cloche.

J'ai oublié et je suis sur une Intel/ATI là, mais si tu utilise le
binaire Nvidia, il me semble qu'il y a une commande nvidia-settings et
nvidia-xconfig ou un truc du genre

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/




--
TISSET Mathieu

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Sylvain L. Sauvage
Le #23848681
’lut,

Le lundi 10 octobre 2011 à 22:12:56, TISSET Mathieu a écrit :
[…]



Je n’ai pas très bien compris pourquoi XBMC avait besoin de
l’OpenGL _matériel_ pour ce qu’il affiche (quelques im ages).
L’UI est inutilisable (super lente) en OpenGL logiciel (la
souris est aussi rapide qu’un reboursement par une
administration en vacances).

[…]
Je tourne actuellement avec le driver nvidia :
$ grep Driver /etc/X11/xorg.conf 2>&1|grep nvidia
Driver "nvidia"



Ça ne prouve rien. Il vaut mieux plutôt vérifier la sortie de
X dans /var/log/Xorg.0.log et la présence du module nvidia (via
lsmod p.ex.).

Bon, puisque nvidia-settings semble fonctionner, ça doit être
correct (il se plaint sinon) mais il reste les alternatives :
vérifie le paquet glx-alternative-nvidia et update-alternative
--config glx.

Note que Nouveau fait aussi de l’OpenGL qui est suffisant pour
pas mal de choses mais très lent avec XMBC. Avec libgl1-mesa-
dri-experimental (Gallium en fait), XBMC semble fonctionnel.
(SGDG : Gallium-Nouveau plantouille dans les coins :
« experimental » qu’on vous dit…).

[…]
Après quelques recherches, je vois qu'il me faut installer
"mesa";



Les paquets de Mesa sont déjà une dépendance de XBMC†¦

c'est partit pour un :
$ apt-get install mesa-utils



… mais ce paquet te permet effictivement d’avoir glxinfo.

[…]



Sinon tu peux aussi vérifier les bogues référencés av ec ta
carte et l’OpenGL…

--
Sylvain Sauvage

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Jean-Yves F. Barbier
Le #23848691
On Mon, 10 Oct 2011 23:02:04 +0200
TISSET Mathieu
après l'install de freeglut3,
toujours le même message d'erreur :



Si le drv nvidia a été installé manuellement, il doit-ê tre réinstallé à chaque
chgt de kernel - sinon, essaye d'enlever ce drv et de le réinstaller.

--
BOFH excuse #85:
Windows 95 undocumented "feature"

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Rémi Vanicat
Le #23849691
TISSET Mathieu
Bonsoir,

tout d'abord merci pour l'aide,

après l'install de freeglut3,
toujours le même message d'erreur :

% glxinfo
X Error of failed request: BadWindow (invalid Window parameter)
Major opcode of failed request: 137 (NV-GLX)
Minor opcode of failed request: 4 ()
Resource id in failed request: 0x1400003
Serial number of failed request: 30
Current serial number in output stream: 30




Regarde dans le fichier /var/log/Xorg.0.log il faut chercher:
- les lignes parlant de nvidia
- les lignes de warning (contenant "(WW)")
- les lignes d'erreurs (contenant "(EE)")

Ça devrais permettre de savoir si oui ou non ton driver nvidia est bien
installé.
[...]

--
Rémi Vanicat

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
TISSET Mathieu
Le #23858021
Re-salut la liste,

bon, ben suite à vos infos,
voilà mon problème résolu.

J'ai vu dans le /var/log/Xorg.0.log
qu'il y avait un soucis avec le module glx.

Je suis allé voir sur le site nvidia quel était le dernier driver dispo pour ma carte (une nvidia ION, sur une eeeBox 1501).
J'ai installé avec la procédure nvidia trouvée ici : http://www.nvidia.fr/object/linux-display-ia32-285.05.09-driver-fr.html

Tout fonctionne.

Merci encore

++

mat


On Mon, Oct 10, 2011 at 10:24:54PM +0200, Jérôme wrote:
Le lundi 10 octobre 2011 à 22:12 +0200, TISSET Mathieu a écrit :
> Aussi voilà ma question : qu'ais-je loupé?
> Je pige pas bien ce qui cloche.

J'ai oublié et je suis sur une Intel/ATI là, mais si tu utilise le
binaire Nvidia, il me semble qu'il y a une commande nvidia-settings et
nvidia-xconfig ou un truc du genre

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/




--
TISSET Mathieu

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Leopold BAILLY
Le #23870081
TISSET Mathieu
Re-salut la liste,

bon, ben suite à vos infos,
voilà mon problème résolu.

J'ai vu dans le /var/log/Xorg.0.log
qu'il y avait un soucis avec le module glx.

Je suis allé voir sur le site nvidia quel était le dernier driver dispo pour ma carte (une nvidia ION, sur une eeeBox 1501).
J'ai installé avec la procédure nvidia trouvée ici : http://www.nvidia.fr/object/linux-display-ia32-285.05.09-driver-fr.html

Tout fonctionne.



Aujourd'hui, les drivers nvidia sont très bien intégrés à la
distribution et il ne devrait plus y avoir besoin de bidouiller à la
main.

Les seuls paquets à installer devraient être nvidia-alternative et
nvidia-kernel-dkms. Toute la configuration est automatique.

Les mêmes paquets sont disponibles en version "legagcy" pour les
cartes anciennes.

--
Léo.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme