Installation support WIFI sur DELL inspiron 1520 sous ETCH

Le
Moncef Mezghani
Bonjour,
J'essaie de faire marcher ma connexion wifi sur Inspiron 1520 sous
ETCH sans beaucoup de succès.
En essayant ce que j'ai trouvé de plus prés sur le net, j'aboutit à =

ceci:

* Not starting ipw3945 regulatory daemon, driver not loaded.

Avez-vous une idée par où dois-je commencer?

Merci beaucoup de votre aide.
Moncef.

Ci-dessous une petite trace:
inspirion-mme:/home/mme# apt-get install ipw3945d firmware-ipw3945
ipw-modules-2.6.18-6-686
Lecture des listes de paquets Fait
Construction de l'arbre des dépendances Fait
ipw3945d est déjà la plus récente version disponible.
firmware-ipw3945 est déjà la plus récente version disponible.
E: Impossible de trouver le paquet ipw-modules-2.6.18-6-686
inspirion-mme:/home/mme# uname -r
2.6.18-6-686
inspirion-mme:/home/mme# apt-get install ipw3945-modules-2.6.18-6-686
Lecture des listes de paquets Fait
Construction de l'arbre des dépendances Fait
ipw3945-modules-2.6.18-6-686 est déjà la plus récente version
disponible.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à=
jour.
inspirion-mme:/home/mme# apt-get install network-manager
Lecture des listes de paquets Fait
Construction de l'arbre des dépendances Fait
network-manager est déjà la plus récente version disponible.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à=
jour.
inspirion-mme:/home/mme# apt-get install network-manager-gnome
Lecture des listes de paquets Fait
Construction de l'arbre des dépendances Fait
network-manager-gnome est déjà la plus récente version disponible.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à=
jour.
inspirion-mme:/home/mme# modprobe ipw3945
* Not starting ipw3945 regulatory daemon, driver not loaded.
inspirion-mme:/home/mme#
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Sébastien NOBILI
Le #9699881
Le jeudi 13 mars 08 à 17:38, Moncef Mezghani a écrit :
| Bonjour,

Bonjour,

| J'essaie de faire marcher ma connexion wifi sur Inspiron 1520 sous
| ETCH sans beaucoup de succès.
| En essayant ce que j'ai trouvé de plus prés sur le net, j'aboutit à
| ceci:
|
| * Not starting ipw3945 regulatory daemon, driver not loaded.

Je n'ai pas la même machine mais c'est la même carte WiFi (du moins le
même module) et ça fonctionne.

| Avez-vous une idée par où dois-je commencer?

J'ai lu la trace en bas de message et la différence que je constate avec
ce que je fais chez moi, c'est l'utilisation de ipw-modules-xxx.
Personnellement je recompile le module depuis les sources avec
module-assistant :
m-a a-i ipw3945-source
mais y-a-t-il vraiment une différence ?

Visiblement, lorsque tu charges le module, le démon ne démarre pas car
il ne trouve pas le driver (le module que tu viens de charger).
Peut-être y-a-t-il des messages intéressants dans /var/log/messages ?

| Merci beaucoup de votre aide.
| Moncef.

Seb

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Edi Stojicevic
Le #9699861
* Sébastien NOBILI
[...]
mais y-a-t-il vraiment une différence ?



Normalement non ... enfin depend des options que tu lui passes ...

Visiblement, lorsque tu charges le module, le démon ne démarre pas car
il ne trouve pas le driver (le module que tu viens de charger).
Peut-être y-a-t-il des messages intéressants dans /var/log/messages ?



modprobe ipw3945 ?

il y a un nouveau driver pour ces cartes :

http://www.nanonanonano.net/linux/debian/iwlwifi

mais pas eu le temps de tester :(

J'essaierai de faire une ptite doc pour debianworld aussi ...


| Merci beaucoup de votre aide.
| Moncef.

Seb



--
. ''`. (___/) E d i S T O J I C E V I C
: :' : (='.'=) http://www.debianworld.org
`. `~' (")_(") GPG: 0x1237B032
`-

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
PaPiNuX
Le #9699821
Le Thu, 13 Mar 2008 17:16:40 +0000, Edi Stojicevic a voulu dire :

[...]

il y a un nouveau driver pour ces cartes :

http://www.nanonanonano.net/linux/debian/iwlwifi

mais pas eu le temps de tester :(




Bonsoir,

iwlwifi est intégré dans le noyau 2.6.24. Il faut aussi installé le
firmware (apt-get install firmware-iwlwifi ).

J'ai testé sur un dell inspiron 1520 et ça a marché du premier coup
(penser à supprimer l'ancien module et le firmware, ainsi que le
daemon).

@+

--
Sylvain Sauvage
Le #9699791
PaPiNuX, jeudi 13 mars 2008, 19:45:23 CET
[…]
Bonsoir,



’soir,

iwlwifi est intégré dans le noyau 2.6.24. Il faut aussi install é le
firmware (apt-get install firmware-iwlwifi ).



Pas disponible en Etch. Donc rétroportage…

J'ai testé sur un dell inspiron 1520 et ça a marché du pre mier coup
(penser à supprimer l'ancien module et le firmware, ainsi que le
daemon).



L’ancien module, l’ancien microcode et le daemon peuvent
toujours servir à l’ancien noyau (ce n’est pas un mal de
conserver un noyau « qui marche ») et ne gênent en rien le
nouveau. Les deux peuvent coexister.

--
Sylvain Sauvage
PaPiNuX
Le #9699781
Le Thu, 13 Mar 2008 20:42:49 +0100, Sylvain Sauvage a voulu dire :



> iwlwifi est intégré dans le noyau 2.6.24. Il faut aussi installé le
> firmware (apt-get install firmware-iwlwifi ).

Pas disponible en Etch. Donc rétroportage…



Hum... je ne faisais que préciser à Edi (qui indiquait qu'il existait
un nouveau module) la version du noyau intégrant ce nouveau module.
Ma réponse ne concernait donc pas, a priori, la question initiale.


> J'ai testé sur un dell inspiron 1520 et ça a marché du premier coup
> (penser à supprimer l'ancien module et le firmware, ainsi que le
> daemon).

L’ancien module, l’ancien microcode et le daemon peuvent
toujours servir à l’ancien noyau (ce n’est pas un mal de
conserver un noyau « qui marche ») et ne gênent en rien le
nouveau. Les deux peuvent coexister.



Certes...mais comme j'indiquais que cela fonctionnait ...
mais tu fais bien de préciser que l'ancienne version ne gêne en rien
la nouvelle.

--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Sylvain Sauvage
Le #9699771
PaPiNuX, jeudi 13 mars 2008, 21:03:24 CET

Le Thu, 13 Mar 2008 20:42:49 +0100, Sylvain Sauvage a voulu dire :


^^^^^^^^^^^^
Non non. J’ai dit.
Pour que ce soit « voulu dire », il faudrait que ce s oit une
reformulation de ce que j’ai écrit, ce qui n’est pas l e cas
puisque c’est une citation, voire que je n’ai pas exprimà © ce que
j’ai pensé, ce qui — je pense être assez bien pla cé pour le
penser/savoir/dire —, n’est pas le cas non plus.

(Cf. signature :o)

> > iwlwifi est intégré dans le noyau 2.6.24. Il faut aussi ins tallé le
> > firmware (apt-get install firmware-iwlwifi ).
>
> Pas disponible en Etch. Donc rétroportage…

Hum... je ne faisais que préciser à Edi (qui indiquait qu'il ex istait
un nouveau module) la version du noyau intégrant ce nouveau module.
Ma réponse ne concernait donc pas, a priori, la question initiale.



Pareil, je précisais juste. Pour le questionneur initial ou
d’autres. Faut pas tout prendre pour soi :o)

--
Sylvain Sauvage, Chipoteur extraordinaire.
Publicité
Poster une réponse
Anonyme