Installer un paquet de lenny en étant etch (kino/export autre ne génére aucun fichier)

Le
Bulot Grégory
Bonjour, suite à des soucis avec etch/kino pour export en xvid, je
souhaiterais installer la version lenny de kino (il parait que les versions=

>1.0 non plus le bug d'export)

mais aptitude -s -t lenny install kino ne propose rien en maj (ni testing, =
ni
etch-backports)

l'erreur est surement évidente, mais je la vois pas, pouvez-vous me corri=
ger ?


dans mon /etc/apt/sources.list j'ai ajouté ceci puis fait un aptitude upd=
ate :
deb-src http://ftp.fr.debian.org/debian/ lenny main contrib non-free

après un premier test j'ai modifier le apt-preference (ajout de lenny et=

testing) :
Package: *
Pin: release a=testing
Pin-Priority: 500

Package: *
Pin: release a=lenny
Pin-Priority: 500

# Les paquets de la cible stable reste avec un priorité supérieure, pour
# éviter que les paquets de testing remplacent tous ceux de stable.
Package: *
Pin: release a=stable
Pin-Priority: 990

#backport
Package: *
Pin: release a=etch-backports
Pin-Priority: 501

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Sylvain Sauvage
Le #16371821
Bulot Grégory, samedi 19 juillet 2008, 19:07:01 CEST

Bonjour,



’soir,

[…]
dans mon /etc/apt/sources.list j'ai ajouté ceci puis fait un
aptitude update :
deb-src http://ftp.fr.debian.org/debian/ lenny main contrib non-free



Hum, deb-src = sources, il manque la ligne deb (sans -src).

Si c’est bien ça, tu pourras te corriger tout seul en allant
cueillir quelques orties fraîches (cherche à l’ombre)⠀¦

--
Sylvain Sauvage

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Bulot Grégory
Le #16374471
Le samedi 19 juillet 2008 19:34, Sylvain Sauvage a écrit :

Hum, deb-src = sources, il manque la ligne deb (sans -src).

Si c’est bien ça, tu pourras te corriger tout seul en alla nt
cueillir quelques orties fraîches (cherche à l’ombre) …



hum, hum, j'y vais de ce pas (avant midi, il parait que ça pique plus !

mais kino, n'est toujours pas disponible (j'ai pidgin et les dépendanc es
associées de proposés en 'Les paquets suivants ont été conservés')

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Sylvain Sauvage
Le #16376801
Bulot Grégory, dimanche 20 juillet 2008, 10:59:34 CEST

Le samedi 19 juillet 2008 19:34, Sylvain Sauvage a écrit :

> Hum, deb-src = sources, il manque la ligne deb (sans -src).
>
> Si c’est bien ça, tu pourras te corriger tout seul en
> allant cueillir quelques orties fraîches (cherche à l†™ombre)…

hum, hum, j'y vais de ce pas (avant midi, il parait que ça
pique plus !

mais kino, n'est toujours pas disponible (j'ai pidgin et les
dépendances associées de proposés en 'Les paquets suivants ont
été conservés')



Ben,

$ apt-cache policy kino
kino:
Installé : (aucun)
Candidat : 1.3.0-2+b1
Table de version :
1.3.0-2+b1 0
500 http://ftp.fr.debian.org sid/main Packages
500 http://ftp.fr.debian.org testing/main Packages

donc kino est bien dispo en testing.

Tu peux nous remettre ton apt/preferences, ton sources.list et
la sortie de « apt-cache policy kino » et de «  aptitude -s
install kino ».

--
Sylvain Sauvage

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Bulot Grégory
Le #16379881
Le dimanche 20 juillet 2008 18:26, Sylvain Sauvage a écrit :

Tu peux nous remettre ton apt/preferences, ton sources.list et
la sortie de « apt-cache policy kino » et de «  aptitude -s
install kino ».

--
Sylvain Sauvage



| apt-cache policy kino ; aptitude -s -t lenny install kino
kino:
Installé : 0.92-3
Candidat : 0.92-3
Table de version :
1.3.0-2+b1 0
500 http://ftp.fr.debian.org lenny/main Packages
*** 0.92-3 0
990 http://ftp.fr.debian.org etch/main Packages
100 /var/lib/dpkg/status
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture de l'information d'état étendu
Initialisation de l'état des paquets... Fait
Lecture des descriptions de tâches... Fait
Construction de la base de données des étiquettes... Fait
Les paquets suivants ont été conservés :
libfaad0 libfaad2-0 libpurple-bin libpurple0 libsilc-1.1-2
localization-config pidgin pidgin-data
0 paquets mis à jour, 0 nouvellement installés, 0 à enlever et 8 non mis à
jour.
Il est nécessaire de télécharger 0o d'archives. Après d épaquetage, 0o seront
utilisés.
Charger/installer/enlever des paquets.

le fonctionnement d'aptitude sans imposer lenny (donc prendre la stable, ca r
je suis en stable)

| aptitude -s install kino

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture de l'information d'état étendu
Initialisation de l'état des paquets... Fait
Lecture des descriptions de tâches... Fait
Construction de la base de données des étiquettes... Fait
Les paquets suivants ont été conservés :
libfaad0 libfaad2-0 libpurple-bin libpurple0 libsilc-1.1-2
localization-config pidgin pidgin-data
0 paquets mis à jour, 0 nouvellement installés, 0 à enlever et 8 non mis à
jour.
Il est nécessaire de télécharger 0o d'archives. Après d épaquetage, 0o seront
util

| cat /etc/apt/preferences /etc/apt/sources.list | grep -v "^#"
Package: *
Pin: release a=testing
Pin-Priority: 500

Package: *
Pin: release a=lenny
Pin-Priority: 500

Package: *
Pin: release a=stable
Pin-Priority: 990

Package: *
Pin: release a=etch-backports
Pin-Priority: 501


deb http://ftp.fr.debian.org/debian/ etch main contrib non-free
deb http://ftp.fr.debian.org/debian/ etch main contrib non-free


deb http://ftp.fr.debian.org/debian/ lenny main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ lenny main contrib non-free

deb http://security.debian.org/ etch/updates main
deb-src http://security.debian.org/ etch/updates main

note : je viens de réaliser que etch-backport est moins prioritaire qu e lenny
(cela ne concerne mon problème actuel, mais je préfère l'à ©crire qd même)


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Sylvain Sauvage
Le #16388871
Bulot Grégory, lundi 21 juillet 2008, 10:37:02 CEST
[…]
| apt-cache policy kino ; aptitude -s -t lenny install kino
kino:
Installé : 0.92-3
Candidat : 0.92-3
Table de version :
1.3.0-2+b1 0
500 http://ftp.fr.debian.org lenny/main Packages
*** 0.92-3 0
990 http://ftp.fr.debian.org etch/main Packages
100 /var/lib/dpkg/status



Donc kino 1.3.0 est bien disponible par le dépôt lenny, avec
une priorité 500. Celui installé a une priorité de 100, ce q ui
fait qu’il serait remplacé par celui de etch si la version de ce
dernier différait ; ce qui fait aussi que sans « -t len ny »,
c’est bien celui de etch qui serait installé.

[…]
Package: *
Pin: release a=testing
Pin-Priority: 500

Package: *
Pin: release a=lenny
Pin-Priority: 500

Package: *
Pin: release a=stable
Pin-Priority: 990

Package: *
Pin: release a=etch-backports
Pin-Priority: 501



À part pour backports, ton fichier correspond aux valeurs par
défaut (cf. man apt_preferences).

Ça fait un moment que je n’ai pas fait de mélange stabl e et
testing, mais as-tu essayé de demander aussi l’installation des
dépendances de kino qui seraient seulement en testing ? Je pense
que ce sont elles qui empêchent l’installation de kino/testing
(/testing non explicite pour elles, donc se rabat sur /etch,
donc version non disponible pour la dépendance, donc blocage de
kino/testing, donc se rabat sur kino/etch, donc ne fait rien).

[…]
note : je viens de réaliser que etch-backport est moins
prioritaire que lenny (cela ne concerne mon problème actuel,
mais je préfère l'écrire qd même)



1. Pour moi, 501 > 500, donc 501 est prioritaire sur 500.
2. De toute façon, ce n’est pas grave puisque backports n⠀™est
pas dans le sources.list…

--
Sylvain Sauvage

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Bulot Grégory
Le #16389781
Le mardi 22 juillet 2008 16:35, Sylvain Sauvage a écrit :
Bulot Grégory, lundi 21 juillet 2008, 10:37:02 CEST

>[…]
>
> | apt-cache policy kino ; aptitude -s -t lenny install kino
>
> kino:
> Installé : 0.92-3
> Candidat : 0.92-3
> Table de version :
> 1.3.0-2+b1 0
> 500 http://ftp.fr.debian.org lenny/main Packages
> *** 0.92-3 0
> 990 http://ftp.fr.debian.org etch/main Packages
> 100 /var/lib/dpkg/status

Donc kino 1.3.0 est bien disponible par le dépôt lenny, avec
une priorité 500. Celui installé a une priorité de 100, ce qui
fait qu’il serait remplacé par celui de etch si la version d e ce
dernier différait ; ce qui fait aussi que sans « -t l enny »,
c’est bien celui de etch qui serait installé.

>[…]
> Package: *
> Pin: release a=testing
> Pin-Priority: 500
>
> Package: *
> Pin: release a=lenny
> Pin-Priority: 500
>
> Package: *
> Pin: release a=stable
> Pin-Priority: 990
>
> Package: *
> Pin: release a=etch-backports
> Pin-Priority: 501

À part pour backports, ton fichier correspond aux valeurs par
défaut (cf. man apt_preferences).

Ça fait un moment que je n’ai pas fait de mélange sta ble et
testing, mais as-tu essayé de demander aussi l’installation des
dépendances de kino qui seraient seulement en testing ? Je pense
que ce sont elles qui empêchent l’installation de kino/testi ng
(/testing non explicite pour elles, donc se rabat sur /etch,
donc version non disponible pour la dépendance, donc blocage de
kino/testing, donc se rabat sur kino/etch, donc ne fait rien).

>[…]
> note : je viens de réaliser que etch-backport est moins
> prioritaire que lenny (cela ne concerne mon problème actuel,
> mais je préfère l'écrire qd même)

1. Pour moi, 501 > 500, donc 501 est prioritaire sur 500.
2. De toute façon, ce n’est pas grave puisque backports n ’est
pas dans le sources.list…

--
Sylvain Sauvage


genre libavutil49 ?

j'ai essayé en simulation,

Les NOUVEAUX paquets suivants vont être automatiquement installés  :
linux-libc-dev
Les paquets suivants seront automatiquement ENLEVÉS :
linux-kernel-headers
Les paquets suivants ont été conservés :
libfaad0 libfaad2-0 libpurple-bin libpurple0 libruby1.8 libsilc-1.1-2
localization-config pidgin pidgin-data ruby1.8
Les NOUVEAUX paquets suivants vont être installés :
libavutil49 linux-libc-dev
Les paquets suivants seront ENLEVÉS :
linux-kernel-headers
Les paquets suivants seront mis à jour :
binutils libc6 libc6-amd64 libc6-dev libc6-i686 locales tzdata
7 paquets mis à jour, 2 nouvellement installés, 1 à enlever et 10 non mis à
jour.



Mise à jour de la libc6 sans passer par un dist-upgrade ça condui t au
suicide ?
J'suis pas encore prêt pour mon serveur, et mes postes à passer e n lenny

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme