Intégrer une variable dans une définition de plage

Le
franck001
Bonjour à tous,

voici le problème que je rencontre, j'ai un fichier qui contient plusieurs
onglets dont un qui est la synthèse des autres de type par exemple:
A B
Onglet1 =somme(Onglet1!A1:A100)
Onglet2 =somme(Onglet2!A1:A100)
Onglet3 =somme(Onglet3!A1:A100)
Onglet4 =somme(Onglet4!A1:A100)

Ma question est: Est-il possible au lieu de rentrer le nom de l'onglet en
dur dans la formule de faire un renvoi au contenu de la cellule de la colonne
A, un truc du style:
=somme("contenu de la cellule d'à côté dans la colonne A"&"!A1:A100")<- j'ai
essayé ça ça ne marche pas :-)

Merci pour votre aide j'espère avoir été clair.

(-_-)°zZz
Franck
http://www.deschamps-web.com
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Youky
Le #11168601
Bonjour,
Le nom de l'onglet en B1 à rectifier en formule si ailleurs.
=SOMME(INDIRECT(B1 &"!A1:A100"))
Possibilité aussi de faire une liste de validation en B1 avec tous les noms
d'onglets
Youky
"franck001" news:
Bonjour à tous,

voici le problème que je rencontre, j'ai un fichier qui contient plusieurs
onglets dont un qui est la synthèse des autres de type par exemple:
A B
Onglet1 =somme(Onglet1!A1:A100)
Onglet2 =somme(Onglet2!A1:A100)
Onglet3 =somme(Onglet3!A1:A100)
Onglet4 =somme(Onglet4!A1:A100)

Ma question est: Est-il possible au lieu de rentrer le nom de l'onglet en
dur dans la formule de faire un renvoi au contenu de la cellule de la
colonne
A, un truc du style:
=somme("contenu de la cellule d'à côté dans la colonne A"&"!A1:A100")<-
j'ai
essayé ça ça ne marche pas :-)

Merci pour votre aide j'espère avoir été clair.

------(-_-)°zZz------
Franck
http://www.deschamps-web.com


franck001
Le #11169221
Pour youki je dis youpi !!!

Merci cela marche impeccable ! Sinon je profite de rebondir sur
l'amélioration que tu proposes....il est possible d'avoir une liste de choix
automatique qui inclus tous les noms d'onglet sans les rentrer préalablement
en dur dans une liste ?
--
------(-_-)°zZz------
Franck
http://www.deschamps-web.com


"Youky" a écrit :

Bonjour,
Le nom de l'onglet en B1 à rectifier en formule si ailleurs.
=SOMME(INDIRECT(B1 &"!A1:A100"))
Possibilité aussi de faire une liste de validation en B1 avec tous les noms
d'onglets
Youky
"franck001" news:
> Bonjour à tous,
>
> voici le problème que je rencontre, j'ai un fichier qui contient plusieurs
> onglets dont un qui est la synthèse des autres de type par exemple:
> A B
> Onglet1 =somme(Onglet1!A1:A100)
> Onglet2 =somme(Onglet2!A1:A100)
> Onglet3 =somme(Onglet3!A1:A100)
> Onglet4 =somme(Onglet4!A1:A100)
>
> Ma question est: Est-il possible au lieu de rentrer le nom de l'onglet en
> dur dans la formule de faire un renvoi au contenu de la cellule de la
> colonne
> A, un truc du style:
> =somme("contenu de la cellule d'à côté dans la colonne A"&"!A1:A100")<-
> j'ai
> essayé ça ça ne marche pas :-)
>
> Merci pour votre aide j'espère avoir été clair.
>
> ------(-_-)°zZz------
> Franck
> http://www.deschamps-web.com





franck001
Le #11169341
Me revoila,

ta formule marche bien mais j'ai encore un petit souci dans mon cas:
=SOMME(INDIRECT(B1 &"!A1:A100")) marche très bien
mais dans mon cas concret, il s'agit en fait d'une sommeprod conditionnelle
du type:
=SOMMEPROD((Onglet1!A1:A100<DATEVAL("01/07/08"))
Si je mets les guillemés pour entourer ma formule cela donne
=SOMMEPROD(INDIRECT(B1 & "!A1:A100<DATEVAL("01/07/08")")
il y a un bug car j'ai déjà des guillemés dans mon texte, saurais tu
comment contourner ce problème ?

Merci

--
------(-_-)°zZz------
Franck
http://www.deschamps-web.com


"Youky" a écrit :

Bonjour,
Le nom de l'onglet en B1 à rectifier en formule si ailleurs.
=SOMME(INDIRECT(B1 &"!A1:A100"))
Possibilité aussi de faire une liste de validation en B1 avec tous les noms
d'onglets
Youky
"franck001" news:
> Bonjour à tous,
>
> voici le problème que je rencontre, j'ai un fichier qui contient plusieurs
> onglets dont un qui est la synthèse des autres de type par exemple:
> A B
> Onglet1 =somme(Onglet1!A1:A100)
> Onglet2 =somme(Onglet2!A1:A100)
> Onglet3 =somme(Onglet3!A1:A100)
> Onglet4 =somme(Onglet4!A1:A100)
>
> Ma question est: Est-il possible au lieu de rentrer le nom de l'onglet en
> dur dans la formule de faire un renvoi au contenu de la cellule de la
> colonne
> A, un truc du style:
> =somme("contenu de la cellule d'à côté dans la colonne A"&"!A1:A100")<-
> j'ai
> essayé ça ça ne marche pas :-)
>
> Merci pour votre aide j'espère avoir été clair.
>
> ------(-_-)°zZz------
> Franck
> http://www.deschamps-web.com





Youky
Le #11170181
non testé car trop pressé
j'en suis pas sur....!!!
=SOMMEPROD(INDIRECT(B1 & "!A1:A100")<DATEVAL("01/07/08"))
Youky

"franck001" news:
Me revoila,

ta formule marche bien mais j'ai encore un petit souci dans mon cas:
=SOMME(INDIRECT(B1 &"!A1:A100")) marche très bien
mais dans mon cas concret, il s'agit en fait d'une sommeprod
conditionnelle
du type:
=SOMMEPROD((Onglet1!A1:A100<DATEVAL("01/07/08"))
Si je mets les guillemés pour entourer ma formule cela donne
=SOMMEPROD(INDIRECT(B1 & "!A1:A100<DATEVAL("01/07/08")")
il y a un bug car j'ai déjà des guillemés dans mon texte, saurais tu
comment contourner ce problème ?

Merci

--
------(-_-)°zZz------
Franck
http://www.deschamps-web.com


"Youky" a écrit :

Bonjour,
Le nom de l'onglet en B1 à rectifier en formule si ailleurs.
=SOMME(INDIRECT(B1 &"!A1:A100"))
Possibilité aussi de faire une liste de validation en B1 avec tous les
noms
d'onglets
Youky
"franck001" de
news:
> Bonjour à tous,
>
> voici le problème que je rencontre, j'ai un fichier qui contient
> plusieurs
> onglets dont un qui est la synthèse des autres de type par exemple:
> A B
> Onglet1 =somme(Onglet1!A1:A100)
> Onglet2 =somme(Onglet2!A1:A100)
> Onglet3 =somme(Onglet3!A1:A100)
> Onglet4 =somme(Onglet4!A1:A100)
>
> Ma question est: Est-il possible au lieu de rentrer le nom de l'onglet
> en
> dur dans la formule de faire un renvoi au contenu de la cellule de la
> colonne
> A, un truc du style:
> =somme("contenu de la cellule d'à côté dans la colonne A"&"!A1:A100")<-
> j'ai
> essayé ça ça ne marche pas :-)
>
> Merci pour votre aide j'espère avoir été clair.
>
> ------(-_-)°zZz------
> Franck
> http://www.deschamps-web.com







Publicité
Poster une réponse
Anonyme