Je cherche un truc "Ah que je ne sais comment on dit"

Le
rthompson
Bonjour

Petit souci

Dans une colonne des noms dans le genre "huit juigf deiu B-1000 Builkjh"

Je voudrais que le B- et tout ce qui se trouve après soit coupé/collé dans
la colonne B

Je sais qu'il y a des fils ici et sur excelabo à ce sujet

Mais je ne sais pas comment cela s'appelle

Alors si quelqu'un me donne le terme (sans jeu de mot Belge) exact
je pourrais chercher à mon aise sans trop vous importuner

A bientôt et un grand merci à vous toutes et tous

Rex
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
AV
Le #4916461
Dans une colonne des noms dans le genre "huit juigf deiu B-1000 Builkjh"

Je voudrais que le B- et tout ce qui se trouve après soit coupé/collé dans la
colonne B


Une bouclette avec les plages à adapter :

Sub zzz()
On Error Resume Next 'chaîne pas trouvée
For Each c In [A1:A20]
x = InStr(1, c, "B-")
c(1, 2) = Mid(c, x, 9 ^ 9)
c.Value = Left(c, x - 1)
Next
End Sub

AV

rthompson
Le #4916421
Bonjour et merci

Je vais voir si ça fonctionne

MAIS

Il n'y a pas une formule style offset counta ect qui fait cela??

Je crois avoir vu un truc comme cela, mais il est possible que je débloque

En tous les cas merci et à bientôt

Rex


"AV"
Dans une colonne des noms dans le genre "huit juigf deiu B-1000
Builkjh"

Je voudrais que le B- et tout ce qui se trouve après soit coupé/collé
dans la colonne B


Une bouclette avec les plages à adapter :

Sub zzz()
On Error Resume Next 'chaîne pas trouvée
For Each c In [A1:A20]
x = InStr(1, c, "B-")
c(1, 2) = Mid(c, x, 9 ^ 9)
c.Value = Left(c, x - 1)
Next
End Sub

AV




rthompson
Le #4916401
Bonjour

Testé avec succès

N'empêche que je me demande comment s'appelle cette fonction....

Emfin MERCI


Et à un de ces jours

Rex ;-)))
"AV"
Dans une colonne des noms dans le genre "huit juigf deiu B-1000
Builkjh"

Je voudrais que le B- et tout ce qui se trouve après soit coupé/collé
dans la colonne B


Une bouclette avec les plages à adapter :

Sub zzz()
On Error Resume Next 'chaîne pas trouvée
For Each c In [A1:A20]
x = InStr(1, c, "B-")
c(1, 2) = Mid(c, x, 9 ^ 9)
c.Value = Left(c, x - 1)
Next
End Sub

AV




JB
Le #4916391
Bonjour,

=STXT(A1;CHERCHE("B-";A1);999ç)

=SI(ESTNUM(CHERCHE("B-";A&));STXT(A&;CHERCHE("B-";A&);9999);"")

JB

On 13 juin, 15:06, "rthompson" wrote:
Bonjour

Petit souci

Dans une colonne des noms dans le genre "huit juigf deiu B-1000 Builkjh"

Je voudrais que le B- et tout ce qui se trouve après soit coupé/coll é dans
la colonne B

Je sais qu'il y a des fils ici et sur excelabo à ce sujet

Mais je ne sais pas comment cela s'appelle

Alors si quelqu'un me donne le terme (sans jeu de mot Belge) exact
je pourrais chercher à mon aise sans trop vous importuner

A bientôt et un grand merci à vous toutes et tous

Rex


dre
Le #4916371
Bonjour,

Si tu ne sais pas comment on dit, je te conseille de consulter le terme
minus (lol).
Et je crois que ce sera le cas pour la Belgique s'il vient au pouvoir !

La valeur en A1
En B1 : =GAUCHE(A1;CHERCHE("B-";A1)-2)
En C1 : =DROITE(A1;NBCAR(A1)-NBCAR(B1)-1)

dré


Bonjour

Petit souci

Dans une colonne des noms dans le genre "huit juigf deiu B-1000 Builkjh"

Je voudrais que le B- et tout ce qui se trouve après soit coupé/collé dans
la colonne B

Je sais qu'il y a des fils ici et sur excelabo à ce sujet

Mais je ne sais pas comment cela s'appelle

Alors si quelqu'un me donne le terme (sans jeu de mot Belge) exact
je pourrais chercher à mon aise sans trop vous importuner

A bientôt et un grand merci à vous toutes et tous

Rex






rthompson
Le #4916301
Bonjour et merci

C'est pas ce que j'avias en tête

Mais c'est testé et cela fonctionne

Et comme je fais plus confiance aux habitués d'ici qu'en ma mémoire
..........

En ce qui concerne l'autre il est évident que tout est écrit dans le grand
livre du monde

C'es troublant qu'un gars qui s'appelle Leterme veut faire une réforme
d'Etat qui mettera un terme à la Belgique


Enfin

Le coup des OGM au parlement Européen me causera beaucoup plus de nuits sans
sommeil



A bientôt

Rex



"dre"
Bonjour,

Si tu ne sais pas comment on dit, je te conseille de consulter le terme
minus (lol).
Et je crois que ce sera le cas pour la Belgique s'il vient au pouvoir !

La valeur en A1
En B1 : =GAUCHE(A1;CHERCHE("B-";A1)-2)
En C1 : =DROITE(A1;NBCAR(A1)-NBCAR(B1)-1)

dré


Bonjour

Petit souci

Dans une colonne des noms dans le genre "huit juigf deiu B-1000
Builkjh"

Je voudrais que le B- et tout ce qui se trouve après soit coupé/collé
dans
la colonne B

Je sais qu'il y a des fils ici et sur excelabo à ce sujet

Mais je ne sais pas comment cela s'appelle

Alors si quelqu'un me donne le terme (sans jeu de mot Belge) exact
je pourrais chercher à mon aise sans trop vous importuner

A bientôt et un grand merci à vous toutes et tous

Rex








rthompson
Le #4916291
Bonjour

Le 999ç est voulu, ou c'est une faute de frappe??????

La deuxième fonctionne

Et DRE m'as aussi proposé un truc

Un grand merci à toi et à bientôt

Rex ;-)))




"JB"
Bonjour,

=STXT(A1;CHERCHE("B-";A1);999ç)

=SI(ESTNUM(CHERCHE("B-";A&));STXT(A&;CHERCHE("B-";A&);9999);"")

JB

On 13 juin, 15:06, "rthompson" wrote:
Bonjour

Petit souci

Dans une colonne des noms dans le genre "huit juigf deiu B-1000 Builkjh"

Je voudrais que le B- et tout ce qui se trouve après soit coupé/collé dans
la colonne B

Je sais qu'il y a des fils ici et sur excelabo à ce sujet

Mais je ne sais pas comment cela s'appelle

Alors si quelqu'un me donne le terme (sans jeu de mot Belge) exact
je pourrais chercher à mon aise sans trop vous importuner

A bientôt et un grand merci à vous toutes et tous

Rex


Publicité
Poster une réponse
Anonyme