Kernel too old

Le
fenkys
Bonjour,


J'ai une linux LFS assez ancienne. Et à cause de son ancienneté, je ne
peux pas utiliser les programmes récents sous forme binaire. C'est la
lib C qui pose problème.

J'ai voulu profiter de l'ajout d'un nouveau disque pour mettre à jour.
J'ai scrupuleusement suivit les étapes. Mais l'installation du 4eme
package a échoué :

- Binutils : aucun problème.
- Gcc 4 : aucun problème
- Linux header 2.6 : aucun problème (la ca aurait été surprenant)
- Glibc 2.3 : pendant la compilation j'ai le message :
FATAL: KERNEL TOO OLD

J'ai eu beaucoup de cas recensé sur Internet, mais aucun se rapportant à
mon cas. Quel package ? Binutils ou Gcc 4 ou meme les headers.


Merci pour votre aide.


LD
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Nicolas George
Le #1895142
fenkys wrote in message
J'ai eu beaucoup de cas recensé sur Internet, mais aucun se rapportant à
mon cas. Quel package ? Binutils ou Gcc 4 ou meme les headers.


De toute évidence, il te faut un noyau plus récent. Tu as quelle version ?

Mais je ne vois pas pourquoi tu parles de package. Il y a des packages, dans
LFS ?

fenkys
Le #1895140
Nicolas George wrote:
fenkys wrote in message
J'ai eu beaucoup de cas recensé sur Internet, mais aucun se rapportant à
mon cas. Quel package ? Binutils ou Gcc 4 ou meme les headers.



De toute évidence, il te faut un noyau plus récent. Tu as quelle version ?


La future version aura un noyau plus récent. Mais je ne veux pas toucher
à mon système actuel tant que c'est lui qui fait marcher mon ordi.

Mais je ne vois pas pourquoi tu parles de package. Il y a des packages, dans
LFS ?


Je parles de package par analogie avec les autres distributions. LFS est
une "distribution" ou on compile les programmes soit même.

LD


BARANGER Emmanuel
Le #1895138
Bonjour,


J'ai une linux LFS assez ancienne. Et à cause de son ancienneté, je ne
peux pas utiliser les programmes récents sous forme binaire. C'est la
lib C qui pose problème.

J'ai voulu profiter de l'ajout d'un nouveau disque pour mettre à jour.
J'ai scrupuleusement suivit les étapes. Mais l'installation du 4eme
package a échoué :

- Binutils : aucun problème.
- Gcc 4 : aucun problème
- Linux header 2.6 : aucun problème (la ca aurait été surprenant)
- Glibc 2.3 : pendant la compilation j'ai le message :
FATAL: KERNEL TOO OLD

J'ai eu beaucoup de cas recensé sur Internet, mais aucun se rapportant à
mon cas. Quel package ? Binutils ou Gcc 4 ou meme les headers.


Merci pour votre aide.


LD
Juste en passant comme cela ;) Pourquoi n'ajouterais tu pas un petit

disque dur sur ta machine sur lequel tu installerai une distribution
récente (Debian, Mandriva etc..) juste pour tester en attendant ta
nouvelle LFS. Ainsi tu ne toucherais pas à ta LFS actuelle, elle
continuerais à gérer correctement ton ordinateur comme à ton habitude et
au passage cela te donnerais la possibilité de voir ce que font les
autres ;) C'est toujours utile de savoir

Amicalement Emmanuel

--
BARANGER Emmanuel

http://helijah.free.fr
http://helijah.free.fr/Pack_3D
http://helijah.free.fr/flightgear/flightgear.htm
http://helijah.free.fr/flightgear/H4-Hercules.htm
http://helijah.free.fr/flightgear/hangar.htm

Nicolas S.
Le #1895137

Mais je ne vois pas pourquoi tu parles de package. Il y a des
packages, dans
LFS ?


Je parles de package par analogie avec les autres distributions. LFS est
une "distribution" ou on compile les programmes soit même.


Il ne s'agit pas de packages.

--
Nicolas S.


Nicolas S.
Le #1895136
fenkys wrote in message
J'ai eu beaucoup de cas recensé sur Internet, mais aucun se rapportant à
mon cas. Quel package ? Binutils ou Gcc 4 ou meme les headers.


De toute évidence, il te faut un noyau plus récent. Tu as quelle version ?


Je crois comprendre que tu parles du "running kernel", mais en quoi
peut-il gêner?

--
Nicolas S.


Nicolas S.
Le #1895135

J'ai une linux LFS assez ancienne. Et à cause de son ancienneté, je ne
peux pas utiliser les programmes récents sous forme binaire. C'est la
lib C qui pose problème.

J'ai voulu profiter de l'ajout d'un nouveau disque pour mettre à jour.
J'ai scrupuleusement suivit les étapes. Mais l'installation du 4eme
package a échoué :

- Binutils : aucun problème.
- Gcc 4 : aucun problème
- Linux header 2.6 : aucun problème (la ca aurait été surprenant)
- Glibc 2.3 : pendant la compilation j'ai le message :
FATAL: KERNEL TOO OLD

J'ai eu beaucoup de cas recensé sur Internet, mais aucun se rapportant à
mon cas. Quel package ? Binutils ou Gcc 4 ou meme les headers.


Comment tu t'y prends exactement? Tu en en train de créer ton chroot ou
tu as déjà chrooté?

--
Nicolas S.

Emmanuel Florac
Le #1896722
Le Sat, 28 Jul 2007 14:05:05 +0200, fenkys a écrit :


J'ai eu beaucoup de cas recensé sur Internet, mais aucun se rapportant à
mon cas. Quel package ? Binutils ou Gcc 4 ou meme les headers.


Quelle est la version de ce noyau qui est trop vieux?

--
Three may keep a secret, if two of them are dead.
Benjamin Franklin.

Rakotomandimby (R12y) Mihamina
Le #1896699
fenkys -
Mais je ne vois pas pourquoi tu parles de package. Il y a des packages,
dans LFS ?
Je parles de package par analogie avec les autres distributions.



Justement c'est l'un des points, ou il n'y a pas d'analogie entre LFS et les
autres.

--
"C'est très facile d'avoir des idées de partage quand on n'a rien."
Patrice KARATCHENTZEFF


Rakotomandimby (R12y) Mihamina
Le #1896698
fenkys -
J'ai eu beaucoup de cas recensé sur Internet, mais aucun se rapportant à
mon cas. Quel package ? Binutils ou Gcc 4 ou meme les headers.


Essaie une par une les versions de la libc en décroissant.
Tu en trouvera bien une qui aura été la dernière qui supporte ton noyau.
Après, tu mettras ton noyau à jour... et ça devrait aller.

--
"C'est très facile d'avoir des idées de partage quand on n'a rien."
Patrice KARATCHENTZEFF

Emmanuel Florac
Le #1896696
Le Sun, 29 Jul 2007 15:23:07 +0200, Rakotomandimby (R12y) Mihamina a
écrit :


Essaie une par une les versions de la libc en décroissant.
Tu en trouvera bien une qui aura été la dernière qui supporte ton noyau.
Après, tu mettras ton noyau à jour... et ça devrait aller.


Sinon il y a la solution qui consiste à télécharger le noyau "fat" de
la slackware 12 (pas besoin d'initrd), l'installer sur sa LFS, booter
dessus pour faire sa manip :

ftp://ftp.slackware.com/pub/slackware/slackware-12.0/kernels/huge.s/bzImage

--
Ce qu'il y a d'enivrant dans le mauvais goût c'est le plaisir
aristocratique de déplaire.
C. Baudelaire.

Publicité
Poster une réponse
Anonyme