Lecteur FLV

Le
Dominique Ottello
Bonjour,

Premier essai de lecture de fichier vidéo via "player_flv_maxi.swf"
(http://flv-player.net/players/maxi/) et valide HTML 4.01 strict.

J'ai fait en sorte que cela fonctionne avec Firefox 3 et IE7 et que la
vidéo (40 Mio) ne soit pas « chargée » avant la validation du bouton
start.
Avant de poursuivre mes essais, je voudrais être certain :

- Que la vidéo n'est pas chargée à l'ouverture de la page

- Que cela fonctionne avec des navigateurs autres que Firefox 3 et IE7

La page d'essai est ici :
http://aviatechno.free.fr/test/essais_flash.php

Merci d'essayer.
--
Ce n'est pas parce que l'erreur se propage qu'elle devient vérité. Gandhi
Technologie aéronautique : http://aviatechno.free.fr (http://ottello.net)
Concorde dans la presse de 1965 à 2003 : http://le.pointu.free.fr
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Olivier Miakinen
Le #22059771
Le 05/01/2009 16:58, Dominique Ottello a écrit :

J'ai fait en sorte que cela fonctionne avec Firefox 3 et IE7 et que la
vidéo (40 Mio) ne soit pas « chargée » avant la validation du bouton
start.
Avant de poursuivre mes essais, je voudrais être certain :

- Que la vidéo n'est pas chargée à l'ouverture de la page



Tu peux être tranquille pour SeaMonkey : rien n'est chargé du tout (il y
a juste un cadre blanc). Comment fait-on pour demander le chargement ?

- Que cela fonctionne avec des navigateurs autres que Firefox 3 et IE7



Ah... peut-être que ça ne fonctionne pas, en fait ?

La page d'essai est ici :
http://aviatechno.free.fr/test/essais_flash.php



Information supplémentaire : quand on survole avec la souris l'une des
entrées de menu « Vilgénis », « La Crevette », etc., il y a un cadre
avec du texte qui apparaît, mais dont on ne voit que les extrémités
droite et gauche.
Dominique Ottello
Le #22059741
Olivier Miakinen
Le 05/01/2009 16:58, Dominique Ottello a écrit :
> - Que la vidéo n'est pas chargée à l'ouverture de la page

Tu peux être tranquille pour SeaMonkey : rien n'est chargé du tout (il y
a juste un cadre blanc). Comment fait-on pour demander le chargement ?



Il devrait y avoir un cadre d'environ 400 x 300, fond noir, avec, au
centre le message centré :

Constellation L.049
N9412H ex F-BAZA
Atterrissage Greenwood Lake
Juillet 1977

en, en bas du cadre, une barre avec des boutons > (Start) ¤ (Arrêt), un
contrôle de volume et une barre de progression, Comme sur la copie écran
ici : http://aviatechno.free.fr/test/copie_ecran_01.jpg

> - Que cela fonctionne avec des navigateurs autres que Firefox 3 et IE7

Ah... peut-être que ça ne fonctionne pas, en fait ?



Et sur cette page, qui fait presque la même chose mais avec une url pour
le chargement de la vidéo sur un autre domaine, est-ce que ça
« fonctionne » avec SeaMonkey ?
http://aviatechno.free.fr/constellation/suivi_matricule.php?mat=F-BAZA
C'est presque en bas de page.

Information supplémentaire : quand on survole avec la souris l'une des
entrées de menu « Vilgénis », « La Crevette », etc., il y a un cadre
avec du texte qui apparaît, mais dont on ne voit que les extrémités
droite et gauche.


Pour le moment, c'est « normal » sur la page d'essais. En allant sur la
page d'Accueil ou les autres, on voit bien le texte.
--
Ce n'est pas parce que l'erreur se propage qu'elle devient vérité. Gandhi
Technologie aéronautique : http://aviatechno.free.fr (http://ottello.net)
Concorde dans la presse de 1965 à 2003 : http://le.pointu.free.fr
SAM
Le #22059711
Le 1/5/09 4:58 PM, Dominique Ottello a écrit :
Bonjour,

Premier essai de lecture de fichier vidéo via "player_flv_maxi.swf"
(http://flv-player.net/players/maxi/) et valide HTML 4.01 strict.

J'ai fait en sorte que cela fonctionne avec Firefox 3 et IE7 et que la
vidéo (40 Mio) ne soit pas « chargée » avant la validation du bouton
start.
Avant de poursuivre mes essais, je voudrais être certain :

- Que la vidéo n'est pas chargée à l'ouverture de la page



Non puisque jai un Flash bloqueur ;-)

Hop! je débloque,
Non, on a bien le panneau d'intro.

- Que cela fonctionne avec des navigateurs autres que Firefox 3 et IE7



Ha! Merdum, c'était avec Fx.3
J'essaie Safari.3 mais ... bièvement(*) !
Bon, sauf le no Flash bloqueur ça marche aussi bien(*) qu'avec Fx3

La page d'essai est ici :
http://aviatechno.free.fr/test/essais_flash.php

Merci d'essayer.



(*) c'est de la folie de mettre un flv en pages perso chez Free.fr ! ! !
surtout s'il fait 40Mo ! !
la bande passante autorisée par free ne permet pas
ce genre de prouesse
Outre que le film est mortellement moche et inintéressant, ça n'arrête
pas de buffériser :
qques secondes de vidéo, qques secondes de buffer ... etc ... etc ...

Bon, c'est vrai que j'ai aussi un ADSL poussif (3 à 4 Mbits/s), mais ça
ne merdoie pas à ce point chez YouTube par exemple.

--
sm
TJ
Le #22059701
On 2009-01-06, SAM
(*) c'est de la folie de mettre un flv en pages perso chez Free.fr ! ! !
surtout s'il fait 40Mo ! !
la bande passante autorisée par free ne permet pas
ce genre de prouesse



Peux-tu nous en dire plus ? D'expérience personnelle j'ai
régulièrement observé des débits relativement corrects depuis les
serveurs de page perso de Free. J'ai fait un petit test depuis trois
liens différents :

$ ftp http://aviatechno.free.fr/medias/f_baza_greenwood.flv
[...]
41719464 bytes retrieved in 00:03 (10.05 MB/s)

$ ftp http://aviatechno.free.fr/medias/f_baza_greenwood.flv
[...]
41719464 bytes retrieved in 00:03 (10.38 MB/s)

$ wget http://aviatechno.free.fr/medias/f_baza_greenwood.flv
[...]
00:26:16 (10.83 MB/s) - `f_baza_greenwood.flv' saved [41719464/41719464]

3 machines différentes sur trois liens différents, dans les deux premiers
cas je dois pas être loin de la saturation de l'interface (100 Mbps).
Sur ma connexion ADSL à domicile qui ne fait « qu'environ » 9 Mbps, je
la sature.

Ou alors cela dépend de la route empruntée, mais dans mes tests j'ai
au moins trois routes bien distinctes.

Bon, c'est vrai que j'ai aussi un ADSL poussif (3 à 4 Mbits/s), mais ça
ne merdoie pas à ce point chez YouTube par exemple.



En revanche je n'ai jamais eu de bon débit vers youtube :/ (tout juste
100 ko/s à l'instant).

Serais-tu de l'autre côté de l'atlantique ? :-)


ps : tous mes tests ont été effectués depuis des machines situées en
France (via Nerim, NeoTelecoms et bsocom ?)
TJ
Le #22059691
On 2009-01-05, Dominique Ottello
Bonjour,



Bonjour,

- Que la vidéo n'est pas chargée à l'ouverture de la page



C'est bien le cas chez moi (elle n'est pas chargée).

- Que cela fonctionne avec des navigateurs autres que Firefox 3 et IE7



J'utilise iceweasel 3.x mais c'est tout comme Firefox 3.x.

La page d'essai est ici :
http://aviatechno.free.fr/test/essais_flash.php



En revanche ce qui me perturbe mais qui n'a pas encore été signalé,
c'est que je ne peux « avancer » (seek) dans la vidéo, que ce soit dans
la partie déjà bufferisée ou non. Après je ne sais pas d'où ça vient :

* mon client HTTP
* mon plugin flash
* le serveur qui t'héberge
* le player flash que tu utilises ?

Je serai tenté de dire que le player flash est en cause car même dans
la partie bufferisée cela déconne, mais je dis ça sans aucune
investigation.
TJ
Le #22059681
On 2009-01-06, TJ
On 2009-01-06, SAM
(*) c'est de la folie de mettre un flv en pages perso chez Free.fr ! ! !
surtout s'il fait 40Mo ! !
la bande passante autorisée par free ne permet pas
ce genre de prouesse



Peux-tu nous en dire plus ? D'expérience personnelle j'ai
régulièrement observé des débits relativement corrects depuis les
serveurs de page perso de Free. J'ai fait un petit test depuis trois
liens différents :

[...]

En revanche je n'ai jamais eu de bon débit vers youtube :/ (tout juste
100 ko/s à l'instant).



D'un autre côté il aurait été mieux que je fasse ce test dans
l'après-midi. Les charges devraient s'inverser de part et d'autre :-)
SAM
Le #22059671
Le 1/6/09 12:47 AM, TJ a écrit :
On 2009-01-06, SAM
(*) c'est de la folie de mettre un flv en pages perso chez Free.fr ! ! !
surtout s'il fait 40Mo ! !
la bande passante autorisée par free ne permet pas
ce genre de prouesse



Peux-tu nous en dire plus ? D'expérience personnelle j'ai



Je ne peux en dire plus que ce qui se raconte sur les NGs de free
comme : proxad.free.services.pagesperso
par exemple.

régulièrement observé des débits relativement corrects depuis les
serveurs de page perso de Free. J'ai fait un petit test depuis trois
liens différents :



3 liens ? ou trois lieux ?

Tu es chez Free ?
(tu as une freeBox ?)
Si oui, il est probable que ça fausse tout.

Bon, c'est vrai que j'ai aussi un ADSL poussif (3 à 4 Mbits/s), mais ça
ne merdoie pas à ce point chez YouTube par exemple.



En revanche je n'ai jamais eu de bon débit vers youtube :/ (tout juste
100 ko/s à l'instant).



Je n'ai pas dit que c'était bon, j'ai dit que c'était hyper beaucoup mieux.
J'en reviens et je n'y ai eu aucune bufferisation ... !
(le débit je ne sais pas le mesurer)(le résultat à mon écran: si)

Serais-tu de l'autre côté de l'atlantique ? :-)



Oui, en effet, du côté des Cévennes.
Du côté de Montpellier (en Languedoc-Roussilon, pas celui aux US)

ps : tous mes tests ont été effectués depuis des machines situées en
France (via Nerim, NeoTelecoms et bsocom ?)



Je suis bêtement chez Orange :-)

--
sm
SAM
Le #22059661
Le 1/6/09 12:58 AM, TJ a écrit :
On 2009-01-05, Dominique Ottello
La page d'essai est ici :
http://aviatechno.free.fr/test/essais_flash.php



En revanche ce qui me perturbe mais qui n'a pas encore été signalé,
c'est que je ne peux « avancer » (seek) dans la vidéo, que ce soit dans
la partie déjà bufferisée ou non. Après je ne sais pas d'où ça vient :



Avec ce player, je pense qu'on ne peut "Avancer" qu'après avoir tout
chargé. (au 2ième passage quoi.)
Encore que ... voir + bas sur le site de l'auteur.

Je serai tenté de dire que le player flash est en cause car même dans
la partie bufferisée cela déconne, mais je dis ça sans aucune
investigation.



Oui, c'est certainement la faute du player.
(ou de son réglage ?)

Néanmoins c'est peut-être aussi le poids de la vidéo ?
ici :
le flv pèse 5,6Mo est parait assez fluide sans bufferisation.
Visionné dans VLC on voit bien qu'il a été "optimisé" à mort.

Mais peut-être l'avais-je dans le cache ?
Suspendu le cache et recommencé, le curseur de position dans le timming
fonctionne chez moi très bien.

Je n'ai pas l'impression que le player soit en cause et je m'orienterais
plutôt sur la vidéo hyper lourde bien que de très piètre qualité.
(je suis en train de la télécharger : 40Mo à 90Ko/s :-( merci Free !)
( http://aviatechno.free.fr/medias/f_baza_greenwood.flv )
a visionner dans VLC.

--
sm
Olivier Masson
Le #22059651
SAM a écrit :

Outre que le film est mortellement moche et inintéressant, ça n'arrête
pas de buffériser :
qques secondes de vidéo, qques secondes de buffer ... etc ... etc ...



:D Du coupe je suis allé voir, ça m'a mis l'eau à la bouche. Et je dois
dire que je n'ai pas été déçu :)
Par contre, pas de problème pour l'affichage avec FF3, Op9.6, Safari 3.1 .
Dominique Ottello
Le #22059641
SAM
Outre que le film est mortellement moche et inintéressant, ça n'arrête
pas de buffériser :



Une partie de mon site est consacrée aux Constel's d'air France et il
s'agit d'un film « historique » sur leur histoire. Il n'est pas
inintéressant pour les fanas de Constel's.

Compte-tenu de toutes les remarques de cette enfilade, je vais rester
avec des liens sur YouTube comme ici (Presque en bas de page) :

http://aviatechno.free.fr/constellation/suivi_matricule.php?mat=F-BAZA

comme je l'ai fait pour les films de l'INA ici :

http://aviatechno.free.fr/constellation/constel07e.php

Merci à tous.
--
Aujourd'hui, l'idéal du progrès est remplacé par l'idéal de l'innovation :
il ne s'agit pas que ce soit mieux, il s'agit seulement que ce soit nouveau,
même si c'est pire qu'avant et cela de toute évidence. Montherlant
Technologie aéronautique - http://ottello.net - Les anciens de Vilgénis
Publicité
Poster une réponse
Anonyme