[lenny] problème mount...

Le
fred
Bonjour,

Je viens de passer une de mes babasses en lenny.
Cette babasse est cliente d'un serveur nfs en etch.

Depuis l'upgrade, si j'arrive tjrs à monter les partitions nfs,
il m'est impossible d'écrire quoi que ce soit dessus, utilisateur lambda
comme root (il y a bien le flag rw, bien sûr, dans les options de montage)

Je n'ai rien changé dans mon /etc/fstab, et une autre babasse restée en
etch ne pose aucun problème en ce qui concerne l'écriture sur les
partitions nfs.

J'ai jeté un ½il à mount(1) et nfs(1) mais je n'ai rien vu à ce sujet.

Une idée ?


Merci d'avance.


Cordialement.

--
Fred

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
François Cerbelle
Le #16715331
Le Jeu 4 septembre 2008 12:12, fred a écrit :
[...]
Depuis l'upgrade, si j'arrive tjrs à monter les partitions nfs,
il m'est impossible d'écrire quoi que ce soit dessus, utilisateur lambda
comme root (il y a bien le flag rw, bien sûr, dans les options de montage)



Ça peut venir de la manière dont ton partage est exporté, peux tu nous
donner la ligne correspondant au partage, dans le fichier /etc/exports ?

Ça peut venir d'une désynchronisation des UID, peux tu donner le résultat
de la commande id pour l'utilisateur qui cherche à écrire, (sur le
serveur, sur le client etch et sur le client lenny) ?

Ça peut venir des permissions, peux tu donner le "ls -l" du répertoire
auquel tu accèdes, mais dans lequel tu ne peux pas écrire, sur les trois
machines aussi ?

François Cerbelle
--
Bat. B10 - 6 r d'Andilly - 95600 Eaubonne
SFR : (+33/0) 603 015 512 - FBX : (+33/0) 951 777 756

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
GiGGz
Le #16715541
fred a écrit :
Bonjour,

Je viens de passer une de mes babasses en lenny.
Cette babasse est cliente d'un serveur nfs en etch.

Depuis l'upgrade, si j'arrive tjrs à monter les partitions nfs,
il m'est impossible d'écrire quoi que ce soit dessus, utilisateur lambda
comme root (il y a bien le flag rw, bien sûr, dans les options de montage)

Je n'ai rien changé dans mon /etc/fstab, et une autre babasse restée en
etch ne pose aucun problème en ce qui concerne l'écriture sur les
partitions nfs.

J'ai jeté un ½il à mount(1) et nfs(1) mais je n'ai rien vu à ce sujet.

Une idée ?


Merci d'avance.


Cordialement.




et si tu ajoutes sec=sys dans ton /etc/fstab ??? ça fait quoi ???

regarde les bugs...j'ai eu ce problème il n'y a po longtemps. j'ai
d'ailleurs posté sur la liste. regarde les archives du mois d'aout.

Tcho

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
fred
Le #16715621
François Cerbelle
Le Jeu 4 septembre 2008 12:12, fred a écrit :
[...]
Depuis l'upgrade, si j'arrive tjrs à monter les partitions nfs,
il m'est impossible d'écrire quoi que ce soit dessus, utilisateur lambda
comme root (il y a bien le flag rw, bien sûr, dans les options de montage)



Ça peut venir de la manière dont ton partage est exporté, peux tu nous
donner la ligne correspondant au partage, dans le fichier /etc/exports ?


/home babasseFP(subtree_check,rw,sync) babasseCM(subtree_check,rw,sync)

Ça peut venir d'une désynchronisation des UID, peux tu donner le résultat


Je ne pense pas, non.
de la commande id pour l'utilisateur qui cherche à écrire, (sur le
serveur, sur le client etch et sur le client lenny) ?


Ben ça serait étonnant, parce que sur mon laptop, j'ai la etch et la
lenny installées, avec les mêmes paramètres de conf.
Sur la etch, aucun problème.
Sur la lenny, ça foire.
l'id est donc le même que ce soit sur etch ou lenny.
Sur le serveur, pareil.
Je le donne, mais
Ça peut venir des permissions, peux tu donner le "ls -l" du répertoire
auquel tu accèdes, mais dans lequel tu ne peux pas écrire, sur les trois
machines aussi ?


Ben là, pareil.
C'est la même conf sur les trois machines.

En résumé, ça ne vient pas du serveur (lui aussi sous etch), parce que
la etch (de mon laptop) fonctionne normalement.

Les choses qui ont changé, c'est la version de mount et de nfs-common.

Merci quand même.

--
Fred

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
David Prévot
Le #16715801
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

fred a écrit :
Bonjour,



Bonjour,

Depuis l'upgrade, si j'arrive tjrs à monter les partitions nfs,
il m'est impossible d'écrire quoi que ce soit dessus



[...]

Une idée ?



Oui : #492970 [1], donc comme proposé dans le fil, ajouter sec=sys aux
options de montage permet de résoudre le problème.

[1] http://bugs.debian.org/cgi-bin/bugreport.cgi?bugI2970

Amicalement

David

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iEYEARECAAYFAki/zggACgkQ18/WetbTC/ptaQCfVSlNDLisv2OqyBP2oIH/fjr8
lj8An0Q54cdrEiQS3k3NGKSmNb7KSBA0
=My4p
-----END PGP SIGNATURE-----

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
fred
Le #16715791
GiGGz
et si tu ajoutes sec=sys dans ton /etc/fstab ??? ça fait quoi ???


Ben ça marche bcp mieux ! :-))))
Mais je ne vois rien à ce sujet dans la page de man.

regarde les bugs...j'ai eu ce problème il n'y a po longtemps. j'ai
d'ailleurs posté sur la liste. regarde les archives du mois d'aout.


Merci bcp, je regarde ça.

--
Fred

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Vincent Danjean
Le #16791721
David Prévot wrote:
fred a écrit :
Bonjour,



Bonjour,

Depuis l'upgrade, si j'arrive tjrs à monter les partitions nfs,
il m'est impossible d'écrire quoi que ce soit dessus



[...]

Une idée ?



Oui : #492970 [1], donc comme proposé dans le fil, ajouter sec=sys aux
options de montage permet de résoudre le problème.

[1] http://bugs.debian.org/cgi-bin/bugreport.cgi?bugI2970



Si c'est bien le problème, alors c'est un problème de unstable (sid)
et pas de lenny. Ce bug est "grave" et empêche (à juste titre) le passage
de nfs-common 1.3 dans lenny.

Amicalement

David



--
Vincent Danjean GPG key ID 0x9D025E87
GPG key fingerprint: FC95 08A6 854D DB48 4B9A 8A94 0BF7 7867 9D02 5E87
Unofficial pacakges: http://www-id.imag.fr/~danjean/deb.html#package
APT repo: deb http://perso.debian.org/~vdanjean/debian unstable main

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
fred
Le #17237111
Vincent Danjean
Si c'est bien le problème, alors c'est un problème de unstable (sid)
et pas de lenny. Ce bug est "grave" et empêche (à juste titre) le passage
de nfs-common 1.3 dans lenny.


Exact.

Et du coup, je viens de percuter sur un truc fondamental qui visiblement
m'avait échappé !!!

Merci ! ;-)

--
Fred

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme