Lenteur extreme au demarrage en relation avec la quantite de RAM

Le
Saïd
Bonjour,

Je fais tourner une machine virtuelle linux sur un mac (core 2 Duo) en
utilisant le logiciel Parallels. C'est un noyau 2.6.20-15 d'une ubuntu 7.04.


Lorsque je configure la machine virtuelle en 512Mo tout se passe tres bien.

Si je passe au dessus de 512Mo le boot devient tres tres tres lent, au
point que je n'ai pas le courage d'attendre qu'il finisse. J'ai des messages
qui ressemblent a ca:

[3559.059793 ] Code: 5e . plein de nombres hexadecimaux.

TSC appears to be running slowly. Marking it unstable.

(c'est les seuls messages que je peux voir sur la console)

J'ai mis
acpi=off clock=pit dans les options de boot du noyau par grub, mais ca
neresoud pas le probleme.

Est-ce que quelqu'un a une solution (si possible sans recompiler le noyau)?


--
Sind zu sein und es seiend in einem Schiff. Fällt zu sein hat das Wasser.
Wer bleibt er? -- Heidegger
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Mihamina (R12y) Rakotomandimby
Le #1896193
fr.comp.os.linux.configuration

Est-ce que quelqu'un a une solution (si possible sans recompiler le
noyau)?


Rester sur 512Mo?

Saïd
Le #1896192
Mihamina (R12y) Rakotomandimby :
fr.comp.os.linux.configuration

Est-ce que quelqu'un a une solution (si possible sans recompiler le
noyau)?


Rester sur 512Mo?


:)

Je n'installe pas linux pour faire un concours de bitte. C'est pour
utiliser un logiciel qui peut avoir besoin de braucoup de memoire.

--
Sind zu sein und es seiend in einem Schiff. Fällt zu sein hat das Wasser.
Wer bleibt er? -- Heidegger


sansflotusspam
Le #1896181
Saïd a commis :

Bonjour,

Je fais tourner une machine virtuelle linux sur un mac (core 2 Duo)
en
utilisant le logiciel Parallels. C'est un noyau 2.6.20-15 d'une ubuntu
7.04.


Lorsque je configure la machine virtuelle en 512Mo tout se passe tres
bien.

Si je passe au dessus de 512Mo le boot devient tres tres tres lent,
au
point que je n'ai pas le courage d'attendre qu'il finisse. J'ai des
messages qui ressemblent a ca:

[3559.059793 ] Code: 5e .... plein de nombres hexadecimaux.

TSC appears to be running slowly. Marking it unstable.

(c'est les seuls messages que je peux voir sur la console)

J'ai mis
acpi=off clock=pit dans les options de boot du noyau par grub, mais ca
neresoud pas le probleme.

Est-ce que quelqu'un a une solution (si possible sans recompiler le
noyau)?




tu ne donnes pas la quantité de mémoire physique réelle de la bête ....
si la ram physique (sans la swap) est de 1024 MO, et que tu attribues
PLUS de 512 MO à la machine virtuelle, c'est le système hôte qui se met
à ramer, et c'est normal.
pour info, sur un PC à 1024 MO de ram, un Win98SE sous qemu tourne très
proprement avec 256 MO de ram attribuée à qemu, à 384 MO ça commence à
ramer, à 512 MO pour qemu, le WIN98 se vautre.
je ne saurais t'en donner les vraies raisons techniques, mais j'ai
observé que pour donner 512 MO à la machine virtuelle avec amélioration
sensible, il faut 2 GO de ram physique sur le système hôte, la swap ne
changeant rien.

les vrais technos du groupe vont expliquer ça.

Saïd
Le #1896173
sansflotusspam :
Saïd a commis :

Bonjour,

Je fais tourner une machine virtuelle linux sur un mac (core 2 Duo)
en
utilisant le logiciel Parallels. C'est un noyau 2.6.20-15 d'une ubuntu
7.04.


Lorsque je configure la machine virtuelle en 512Mo tout se passe tres
bien.

Si je passe au dessus de 512Mo le boot devient tres tres tres lent,
au
point que je n'ai pas le courage d'attendre qu'il finisse. J'ai des
messages qui ressemblent a ca:

[3559.059793 ] Code: 5e .... plein de nombres hexadecimaux.

TSC appears to be running slowly. Marking it unstable.

(c'est les seuls messages que je peux voir sur la console)

J'ai mis
acpi=off clock=pit dans les options de boot du noyau par grub, mais ca
neresoud pas le probleme.

Est-ce que quelqu'un a une solution (si possible sans recompiler le
noyau)?




tu ne donnes pas la quantité de mémoire physique réelle de la bête ....
si la ram physique (sans la swap) est de 1024 MO, et que tu attribues
PLUS de 512 MO à la machine virtuelle, c'est le système hôte qui se met
à ramer, et c'est normal.
pour info, sur un PC à 1024 MO de ram, un Win98SE sous qemu tourne très
proprement avec 256 MO de ram attribuée à qemu, à 384 MO ça commence à
ramer, à 512 MO pour qemu, le WIN98 se vautre.
je ne saurais t'en donner les vraies raisons techniques, mais j'ai
observé que pour donner 512 MO à la machine virtuelle avec amélioration
sensible, il faut 2 GO de ram physique sur le système hôte, la swap ne
changeant rien.



J'ai bien 2Go. Le syteme ne rame pas pour la simple raison que
l'attribution de RAM au systeme virtuel se fait a la volee. Le probleme se
pose meme quand je passe a 520 Mo de memoire. Donc, non ca ne vient pas de
l'OS hote.

--
Sind zu sein und es seiend in einem Schiff. Fällt zu sein hat das Wasser.
Wer bleibt er? -- Heidegger


Publicité
Poster une réponse
Anonyme