Lenteur Nfs entre ubuntu 10.04 et XPHome

Le
Qu'est ce qu'elle a ma gueule ?
Bonjour

J'ai une machine client sous XP home (pas le choix), et un serveur (ubuntu 10.04)

Une liaison 100mbs qui fonctionne impec, sauf la liaison NFS client-serveur qui traine à 50Ko/s quelques soit la taille
Beaucoup de petit fichier (20000) et 1 gros fichier de 350Mo. J'ai souvent des decrochage (Erreur fichier illisible)

ça a très bien marché pendant plusieurs jours et depuis hier c'est la cata.

La solution samba, ne fonctionne pas correctement sur un XP home mais très bien sur un pro.

Je m'en remet à vous car ce "chgnva" de windows de "zreqr" commence serieusement à me faire "puvre"

Je sais plus quoi faire pour règler ce probleme.

Merci de vos lumières.




--
« le politiquement correct ne proclame pas la tolérance ; il ne fait qu'organiser la haine. » (Jacques Barzun)
C'est une doctrine obligatoire, qui n'est en réalité que l'expression la plus autoritaire du conformisme
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Sergio
Le #24086041
Le Sun, 18 Dec 2011 19:32:56 +0100, Qu'est ce qu'elle a ma gueule ? a
écrit :

Bonjour

J'ai une machine client sous XP home (pas le choix), et un serveur
(ubuntu 10.04)

Une liaison 100mbs qui fonctionne impec, sauf la liaison NFS
client-serveur qui traine à 50Ko/s quelques soit la taille Beaucoup de
petit fichier (20000) et 1 gros fichier de 350Mo. J'ai souvent des
decrochage (Erreur fichier illisible)



Déjà eu ce problème entre Ubuntu-Ubuntu en liaison Wifi. En filaire ça passe mieux. Jamais compris pourquoi...

La solution samba, ne fonctionne pas correctement sur un XP home mais
très bien sur un pro.



Ah ?
Déjà fait ça... Pas de problème, du moins si le XP-Home est client.

--
Serge http://leserged.online.fr/
Mon blog: http://cahierdesergio.free.fr/
Soutenez le libre: http://www.framasoft.org
Qu'est ce qu'elle a ma gueule ?
Le #24086311
On 18 Dec 2011 18:57:58 GMT, Sergio
Le Sun, 18 Dec 2011 19:32:56 +0100, Qu'est ce qu'elle a ma gueule ? a
écrit :

Bonjour

J'ai une machine client sous XP home (pas le choix), et un serveur
(ubuntu 10.04)

Une liaison 100mbs qui fonctionne impec, sauf la liaison NFS
client-serveur qui traine à 50Ko/s quelques soit la taille Beaucoup de
petit fichier (20000) et 1 gros fichier de 350Mo. J'ai souvent des
decrochage (Erreur fichier illisible)



Déjà eu ce problème entre Ubuntu-Ubuntu en liaison Wifi. En filaire ça passe mieux. Jamais compris pourquoi...



J'essaye un autre XP home sur une autre machine et ça tourne très bien (6,5Mo/s)

Sur la machine qui pose problème, ça a remarché un peu à fond sur un fichier de 250Mo et vers 90% de transfert ça a comencé à s'effondrer.

J'ai désacivé le bouclier résident de AVG antivirus sur la machine XP mais ça change rien.


La solution samba, ne fonctionne pas correctement sur un XP home mais
très bien sur un pro.



Ah ?
Déjà fait ça... Pas de problème, du moins si le XP-Home est client.



C'etait dans le cadre d'un NAS.



--
« le politiquement correct ne proclame pas la tolérance ; il ne fait qu'organiser la haine. » (Jacques Barzun)
C'est une doctrine obligatoire, qui n'est en réalité que l'expression la plus autoritaire du conformisme
Qu'est ce qu'elle a ma gueule ?
Le #24086721
On Sun, 18 Dec 2011 21:25:54 +0100, Qu'est ce qu'elle a ma gueule ?
J'essaye un autre XP home sur une autre machine et ça tourne très bien (6,5Mo/s)

Sur la machine qui pose problème, ça a remarché un peu à fond sur un fichier de 250Mo et vers 90% de transfert ça a comencé à s'effondrer.



Je fais un netstat -i si ça peut aider. 1x toutes les secondes.

:~$ netstat -i Table d'interfaces noyau Iface MTU Met RX-OK RX-ERR RX-DRP RX-OVR TX-OK TX-ERR TX-DRP TX-OVR Flg eth0 1500 0 67192 0 0 0 962206 0 0
0 BMRU lo 16436 0 15707 0 0 0 15707 0 0 0 LRU :~$ netstat -i Table d'interfaces noyau Iface MTU Met RX-OK RX-ERR RX-DRP RX-OVR TX-OK TX-ERR
TX-DRP TX-OVR Flg eth0 1500 0 67193 0 0 0 962206 0 0 0 BMRU lo 16436 0 15747 0 0 0 15747 0 0 0 LRU :~$
netstat -i Table d'interfaces noyau Iface MTU Met RX-OK RX-ERR RX-DRP RX-OVR TX-OK TX-ERR TX-DRP TX-OVR Flg eth0 1500 0 67193 0 0 0 962206 0 0 0 BMRU lo
16436 0 15747 0 0 0 15747 0 0 0 LRU :~$ netstat -i Table d'interfaces noyau Iface MTU Met RX-OK RX-ERR RX-DRP RX-OVR TX-OK TX-ERR TX-DRP TX-OVR Flg eth0
1500 0 67193 0 0 0 962206 0 0 0 BMRU lo 16436 0 15747 0 0 0 15747 0 0 0 LRU :~$ netstat -i Table d'interfaces
noyau Iface MTU Met RX-OK RX-ERR RX-DRP RX-OVR TX-OK TX-ERR TX-DRP TX-OVR Flg eth0 1500 0 67193 0 0 0 962206 0 0 0 BMRU lo 16436 0 15747 0
0 0 15747 0 0 0 LRU :~$ netstat -i Table d'interfaces noyau Iface MTU Met RX-OK RX-ERR RX-DRP RX-OVR TX-OK TX-ERR TX-DRP TX-OVR Flg eth0 1500 0 67197 0
0 0 962214 0 0 0 BMRU lo 16436 0 15787 0 0 0 15787 0 0 0 LRU :~$ netstat -i Table d'interfaces noyau Iface MTU Met RX-OK
RX-ERR RX-DRP RX-OVR TX-OK TX-ERR TX-DRP TX-OVR Flg eth0 1500 0 67197 0 0 0 962214 0 0 0 BMRU lo 16436 0 15787 0 0 0 15787 0
0 0 LRU :~$ netstat -i Table d'interfaces noyau Iface MTU Met RX-OK RX-ERR RX-DRP RX-OVR TX-OK TX-ERR TX-DRP TX-OVR Flg eth0 1500 0 67197 0 0 0 962214 0
0 0 BMRU lo 16436 0 15787 0 0 0 15787 0 0 0 LRU :~$ netstat -i Table d'interfaces noyau Iface MTU Met RX-OK RX-ERR RX-DRP RX-OVR TX-OK
TX-ERR TX-DRP TX-OVR Flg eth0 1500 0 67197 0 0 0 962214 0 0 0 BMRU lo 16436 0 15787 0 0 0 15787 0 0 0 LRU
:~$ netstat -i Table d'interfaces noyau Iface MTU Met RX-OK RX-ERR RX-DRP RX-OVR TX-OK TX-ERR TX-DRP TX-OVR Flg eth0 1500 0 67197 0 0 0 962214 0 0
0 BMRU lo 16436 0 15787 0 0 0 15787 0 0 0 LRU :~$ netstat -i Table d'interfaces noyau Iface MTU Met RX-OK RX-ERR RX-DRP RX-OVR TX-OK TX-ERR
TX-DRP TX-OVR Flg eth0 1500 0 67198 0 0 0 962214 0 0 0 BMRU lo 16436 0 15827 0 0 0 15827 0 0 0 LRU :~$
netstat -i Table d'interfaces noyau Iface MTU Met RX-OK RX-ERR RX-DRP RX-OVR TX-OK TX-ERR TX-DRP TX-OVR Flg eth0 1500 0 67201 0 0 0 962216 0 0 0 BMRU lo
16436 0 15867 0 0 0 15867 0 0 0 LRU :~$ netstat -i Table d'interfaces noyau Iface MTU Met RX-OK RX-ERR RX-DRP RX-OVR TX-OK TX-ERR TX-DRP TX-OVR Flg eth0
1500 0 67201 0 0 0 962216 0 0 0 BMRU lo 16436 0 15867 0 0 0 15867 0 0 0 LRU :~$ netstat -i Table d'interfaces
noyau Iface MTU Met RX-OK RX-ERR RX-DRP RX-OVR TX-OK TX-ERR TX-DRP TX-OVR Flg eth0 1500 0 67208 0 0 0 962218 0 0 0 BMRU lo 16436 0 16107 0
0 0 16107 0 0 0 LRU
--
« le politiquement correct ne proclame pas la tolérance ; il ne fait qu'organiser la haine. » (Jacques Barzun)
C'est une doctrine obligatoire, qui n'est en réalité que l'expression la plus autoritaire du conformisme
Qu'est ce qu'elle a ma gueule ?
Le #24086831
On Sun, 18 Dec 2011 21:25:54 +0100, Qu'est ce qu'elle a ma gueule ?

Sur la machine qui pose problème, ça a remarché un peu à fond sur un fichier de 250Mo et vers 90% de transfert ça a comencé à s'effondrer.



Je remarque une chose quand même, c'est que :
- serveur -> client ça rame grave au point que le transfert plante.
- client -> serveur le transfert est à 7Mo/s



--
« le politiquement correct ne proclame pas la tolérance ; il ne fait qu'organiser la haine. » (Jacques Barzun)
C'est une doctrine obligatoire, qui n'est en réalité que l'expression la plus autoritaire du conformisme
Qu'est ce qu'elle a ma gueule ?
Le #24089721
On Sun, 18 Dec 2011 19:32:56 +0100, Qu'est ce qu'elle a ma gueule ?
Bonjour

J'ai une machine client sous XP home (pas le choix), et un serveur (ubuntu 10.04)

Une liaison 100mbs qui fonctionne impec, sauf la liaison NFS client-serveur qui traine à 50Ko/s quelques soit la taille
Beaucoup de petit fichier (20000) et 1 gros fichier de 350Mo. J'ai souvent des decrochage (Erreur fichier illisible)

ça a très bien marché pendant plusieurs jours et depuis hier c'est la cata.

La solution samba, ne fonctionne pas correctement sur un XP home mais très bien sur un pro.

Je m'en remet à vous car ce "chgnva" de windows de "zreqr" commence serieusement à me faire "puvre"

Je sais plus quoi faire pour règler ce probleme.

Merci de vos lumières.



ça n'inspire personne ?

--
« le politiquement correct ne proclame pas la tolérance ; il ne fait qu'organiser la haine. » (Jacques Barzun)
C'est une doctrine obligatoire, qui n'est en réalité que l'expression la plus autoritaire du conformisme
Emmanuel Florac
Le #24090151
Le Mon, 19 Dec 2011 21:08:25 +0100, Qu'est ce qu'elle a ma gueule ? a
écrit:


ça n'inspire personne ?



Qu'est ce que tu utilises comme client NFS sur le XP? Quel est le contenu
de ton fichier /etc/exports sur le Linux?

--
It always takes longer than you expect, even when you take into account
Hofstadter's Law.
Hofstadter's Law
Qu'est ce qu'elle a ma gueule ?
Le #24091321
On 19 Dec 2011 22:31:42 GMT, Emmanuel Florac
Le Mon, 19 Dec 2011 21:08:25 +0100, Qu'est ce qu'elle a ma gueule ? a
écrit:


ça n'inspire personne ?



Qu'est ce que tu utilises comme client NFS sur le XP?



SFU 3.5 fourni par le lien ci dessous.
Je me suis basé sur ça :
http://doc.ubuntu-fr.org/tutoriel/nfs_client_windows


Quel est le contenu
de ton fichier /etc/exports sur le Linux?



# 192.168.1.11 en lecture écriture pour portable TM233
/home/data/partage/XPhome 192.168.1.11(rw,nohide,crossmnt,all_squash,anonuid00,anongid0,sync,subtree_check)

# 192.168.1.5 en lecture écriture pour portable Akoya
/home/data/partage/XPhome 192.168.1.5(rw,nohide,crossmnt,all_squash,anonuid00,anongid0,sync,subtree_check)

Celui qui pose problème est le 192.168.1.5 alors que le 192.168.1.11 focntionne parfaitement (tous les 2 XP home SP3 licence originale)

Les fichier passwd et group sont identique.

J'ai fouillé sur le net, certain ont le même probleme, mais soit c'est avec du vmware ou un serveur windows alors que je suis en client wuidows-serveur linux.

et il se pourait d'après certain commentaire que se soit peut être un probleme de LDAP/SID et une histoire de root.
http://communities.vmware.com/message/1370661#1370661

Là ça dépasse mes compétences et je suis même pas sur que se soit ça.



--
« le politiquement correct ne proclame pas la tolérance ; il ne fait qu'organiser la haine. » (Jacques Barzun)
C'est une doctrine obligatoire, qui n'est en réalité que l'expression la plus autoritaire du conformisme
Emmanuel Florac
Le #24093451
Le Tue, 20 Dec 2011 12:01:29 +0100, Qu'est ce qu'elle a ma gueule ? a
écrit:

# 192.168.1.11 en lecture écriture pour portable TM233
/home/data/partage/XPhome
192.168.1.11


(rw,nohide,crossmnt,all_squash,anonuid00,anongid0,sync,subtree_check)

# 192.168.1.5 en lecture écriture pour portable Akoya
/home/data/partage/XPhome
192.168.1.5


(rw,nohide,crossmnt,all_squash,anonuid00,anongid0,sync,subtree_check)

Bizarre ces paramètres. sync et subtree_check sont idéaux pour casser la
performance, et crossmnt et nohide sont parfaits pour avoir des problèmes
de compatibilité. Je te conseille de tester avec ces paramètres :

(rw,all_squash,anonuid00,anongid0,async,no_subtree_check)

--
I have not failed. I've just found 10,000 ways that won't work.
Thomas A. Edison
Qu'est ce qu'elle a ma gueule ?
Le #24093921
On 20 Dec 2011 20:39:18 GMT, Emmanuel Florac
Le Tue, 20 Dec 2011 12:01:29 +0100, Qu'est ce qu'elle a ma gueule ? a
écrit:

# 192.168.1.11 en lecture écriture pour portable TM233
/home/data/partage/XPhome
192.168.1.11


(rw,nohide,crossmnt,all_squash,anonuid00,anongid0,sync,subtree_check)

# 192.168.1.5 en lecture écriture pour portable Akoya
/home/data/partage/XPhome
192.168.1.5


(rw,nohide,crossmnt,all_squash,anonuid00,anongid0,sync,subtree_check)

Bizarre ces paramètres. sync et subtree_check sont idéaux pour casser la
performance, et crossmnt et nohide sont parfaits pour avoir des problèmes
de compatibilité. Je te conseille de tester avec ces paramètres :

(rw,all_squash,anonuid00,anongid0,async,no_subtree_check)



Vai voir ça demain.
merci.
--
« le politiquement correct ne proclame pas la tolérance ; il ne fait qu'organiser la haine. » (Jacques Barzun)
C'est une doctrine obligatoire, qui n'est en réalité que l'expression la plus autoritaire du conformisme
Qu'est ce qu'elle a ma gueule ?
Le #24101931
On 20 Dec 2011 20:39:18 GMT, Emmanuel Florac
Bizarre ces paramètres. sync et subtree_check sont idéaux pour casser la
performance, et crossmnt et nohide sont parfaits pour avoir des problèmes
de compatibilité. Je te conseille de tester avec ces paramètres :

(rw,all_squash,anonuid00,anongid0,async,no_subtree_check)



Ben écoute, ça à marché 5mn à 7Mo/s et depuis c'est du 200Ko/s (c'est toujours mieux que 50Ko/s mais ça reste lourd)

Autre indice :
J'ai 2 compte sur winxphome. 1 admin, 1 limité.
Sur le compte admin, je copie 600Mo depuis le serveur.
Sur le compte limité, je copie les même fichier depuis le serveur.

Les 2 compte copie en même temps (modulo le temps de changer de session et de lancer la 2e copie)

Les vitesse sont à peut de chose pres identique (donc pas divisé par 2)
Le CPU de xp est à 4% d'utilisation, le reseau fait un pic à 50% toutes les 20 à 30 sec.





--
« le politiquement correct ne proclame pas la tolérance ; il ne fait qu'organiser la haine. » (Jacques Barzun)
C'est une doctrine obligatoire, qui n'est en réalité que l'expression la plus autoritaire du conformisme
Publicité
Poster une réponse
Anonyme